Kodi Community Forum

Full Version: Subtitles playing, but they are set to "none"
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm trying to play a .mkv file, and subtitles are playing, however, when i click on the subtitles button it says there are none and it is also set to none. Anyone know what this could be or how to fix it? Thanks

If it helps, the file was originally an mkv and an ac3 file, and I merged them.

Thanks
Actually, when I use the XBMC official remote, the subtitles are listed and can be turned off =/
The subs are probably hard coded into the mkv.

AFAIK the subtitle button only enables/disables if you have an external subs file.
Either they are hard-coded as unabatedshagie has suggested or, the sub stream has been flagged as 'forced'. To check, open mkvmerge, file, header editor and open the file in the editor, go to the sub stream and check what flags have been set. If, as I suspect the 'forced' flag is set - change it to no and save.

@unabatedshagie - the subtitle check box (accessed from the video osd, while playing a file) enables\disables subtitles either in external sub files or sub streams muxed to the file. Just noticed there's another subtitle setting in Video Settings - looks like this is for pointing to an external subs directory as you pointed out.
How do I get to the video OSD?
I believe you press O during playback.
O shows the movie info. Are you referring to the menu with play/pause/etc?

I found a "video settings" menu, but I don't see a subtitle setting =/
Press 'm' during playback, then navigate to the video setting from the osd - symbols differ with each skin - from there you will see 'subtitles' and from there you can enable/disable them - though if they have had the 'forced' tag set, checking this will have no effect, they will still be displayed and you would have to change the flag as described in my earlier response.

Subtitles can also be toggled on/off by pressing 't'