Kodi Community Forum

Full Version: [solved] [GIT] DTS-HD MA not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5
Will the kernel upgrade be applied to the next version of XBMC? Running XBMCuntu 12.00 on an Intel NUC with the HD4000 and is perfect except for the DTS-HD MA audio not working. Pretty sure if I try to patch the 3.8 kernel I'll mess it up unless there is a "how to upgrade to 3.8 kernel" for beginners guide.
It's quite simple to install a mainline kernel version (3.7.5 is current) on Ubuntu. Have a look here... https://wiki.ubuntu.com/Kernel/MainlineBuilds .There's no patch needed, just install 3.7.5 (for example) and make the changes above and it should work.

It works for you, because you have no S/PDIF. Every user with an S/PDIF must unload / blacklist the appropriate module (be it snd_hda_codec_realtak) or whatever, because the S/PDIF and the HDMI share the "first" control.

This is what this widespreed Edit of HDA-Intel.conf does. This static mapping would break sound on systems that don't have a S/PDIF on the same intel card.

You can easily find if you are affected, by running:
sudo aplay -L
if you find S/PDIF on the same card as your intel hdmi, you need the CTLINDEX increasement by 1 for hdmi.0 hdmi.1 ... or alternatively rmmod the module, that drives your S/PDIF.

Quote:"how to upgrade to 3.8 kernel" for beginners guide.

Ditto for this, I looked at the link from flitter2009 and that makes no sense (page does not exist). I was kinda hoping the newer kernal would be in the new XBMCubuntu 12.0 stable download, but it looks like the kernal is 3.5. This leaves all of us running Intel boards and limited Linux skills with no passthrough audio. Any help appreciated,
(2013-02-03, 19:20)goslo Wrote: [ -> ]Ditto for this, I looked at the link from flitter2009 and that makes no sense (page does not exist).

He mistakenly included the period in the link. Correct link is: https://wiki.ubuntu.com/Kernel/MainlineBuilds.

I am going to attempt the upgrade path. It seems simple enough.
(2013-02-03, 19:29)uNiversal Wrote: [ -> ]http://kernel.ubuntu.com/~kernel-ppa/mai...t/current/

Done and done


It can't be that simple.

1)exit XBMC (or ssh into NUC).
2)download the header, image, image extras. In my case: the amd64 .
3)sudo dpkg -i *.deb for all 3

That's it?
Isnt it? Cross fingers too, though if it fails you can always boot previous kernel.

Sorry - the link should have been https://wiki.ubuntu.com/Kernel/MainlineBuilds (there was a dot appended to the original link). I followed the procedure mightydh shows above - I didn't need to do anything else except reboot.

Removal of the kernel is easy too, just use apt-get remove on the packages you just installed and reboot.
This worked for me on my i3 and Intel 4000 setup. I installed the frodo XBMCbuntu, update the kernel to 3.7.9 and did the ctlindex trick, rebooted. I have HD audio now.

"ctlindex=" entries and add 1 to the ctlindex numbers (eg. 0->1, 1->2 etc)

i3 motherboard - http://www.amazon.com/ASRock-DDR3-1333-I...1361684756
Sweet, I will try installing 3.7.9 and do the ctlindex trick tonight. Glad to see that it's working for some people, I was almost losing hope.
This is documented on wiki, so you guys know.

Intel_Linux_Modifications_for_HD_Audio (wiki)

(2013-02-03, 21:10)uNiversal Wrote: [ -> ]Isnt it? Cross fingers too, though if it fails you can always boot previous kernel.


So I updated as instructed (busy couple weeks at work), however I still have no HD-Audio. Video works OK, but there seems to be no change in getting DTS-HD.

Attached is my XBMC.log: http://xbmclogs.com/show.php?id=2100
It seems the Intel NUCs are a bit special here.
From what I see xbmc does what it should:

That is 0x06 for passthrough, 0x82 and 0x00 as normal and 0x02 for the Sample Rate, which is 48khz - seems to be your DTS sample

Here basically the same, but 0x0e for 192khz should be DTS-HD.

You can try to ping anssi on IRC. But don't pm him and don't kick in his door, he is extremely busy at these times. Write him the string as your card gets opened, tell him: no sound and ask, which flags especially AES0 and AES1 you could try.
1st time poster and 1st time Linux user when I bought a NUC and wanted Xbmcbuntu running on it playing HD Audio. Everything else bar bitstreaming worked like a dream - only my AMP detected no audio signal when playing an mkv with a HD audio track.

I'd worked out from that Linux mods for HD Audio article that the kernel used by Lubuntu 12.10 (3.5) was too old to include the necessary patch and I needed 3.7 or above. I gave up hope at this point and wondered why Frodo wasn't setup to use the later kernel or have the patch which would enable bitstreaming to work on such a popular CPU.

After much searching I eventually came across this thread, installed the files kindly provided by uNi, bounced the box and it started working! So providing your amp is fine, it should work for everyone else. I updated the kernel by installing the i386 header file first (but appeared to get an error), then the i386 image, then i386 image extras, then the "all" headers file and then the i386 header file again (looked like I got a per-req error and I thought it might of needed the "all" headers installing first).

This obviously sounds like amateur hour to anyone who half knows what they're doing with Linux but I have no idea, so was mega happy when it started working. So many thanks to those on this thread, I hope my experience can help others.
Pages: 1 2 3 4 5