Kodi Community Forum

Full Version: [solved] [GIT] DTS-HD MA not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5
Not sure - just try it :-) 3.9.0 should repair this automatically - if not - just rmmod the spdif module.
After hours on testing, forum reading, google searching I give up. I have no idea what else I can do:

DTS-HD just wont work :-(

What I did:
  • Updated to kernel 3.9.0
  • Installed alsa-utils
  • added i915.i915_enable_rc6=0 to grub
  • sudo aplay -L | grep -i iec958 -> No output
  • edit /usr/share/alsa/cards/HDA-Intel.conf -> No audio at all because HDA Intel PCH was gone - reverted back

After each change I did a reboot and tested DTS-HD. All I got was a video which was very very very slow in play back. Some how jumpy.
My receiver kept flashing "DTS-HD MA". No sound at all - not even the noisy sound others reported.

Here is my XBMC Log: http://xbmclogs.com/show.php?id=17136
Here is the output from alsa-info.sh: http://www.thomasgruebl.at/alsa-info.txt

Would be kind if someone can direct me in the right direction. In my opinion it has something to do with these lines in XBMC Log:
00:00:35 T:139687279585024 DEBUG: CDVDPlayerAudio:: Discontinuity1 - was:685840437.451667, should be:685352666.666667, error:-487770.785000

Thanks in advance.

P.S.: Latest Openelec live and XBMCbuntu are producing the same behavior.
Quote:m_dataFormats : AE_FMT_LPCM,AE_FMT_S32NE,AE_FMT_S16NE,AE_FMT_S16LE

Your Sony AVR does not report any HD format at all - so you can try forever :-)
First I was surprised about your answer, didn't expect this kind of answer :-)

Then I was shocked because I thought you are telling me my Sony AVR is broken.

Therefore I checked it with my PS3 and Avatar. It plays DTS-HD MA just fine:

Picture 1

Picture 2

Now I don't know what to do with your answer. :-( Is XBMC "asking" my Sony what it can do? If yes
can I just tell XBMC to bit-stream the content and don't ask?
The problem is, that intel has issues with handshaking with your receivers Edid (eld). I have seen this now multiple times arround this forum. I personally have a Marantz AVR, which I used with my Celeron 847 for testing and sadly, I did not have a problem with it parsing its information.

There are hacks for intels to highjack the Edids and set another one, but this is not straight forward yes - so a bit difficult. I could supply you the Edid of my Marantz just for testing. You have to override it also with ubuntu.

We can go through the process together, if you want to visit me #xbmc-xvba

Basically, we do the following:
http://askubuntu.com/questions/144088/ho...kms-helper

with this firmwarte (256 Byte in size): https://dl.dropboxusercontent.com/u/5572...arantz.bin

Good luck :-)

Update: Save you the trouble, this did not work.
#xbmc-xvba is a IRC channel or? Which program do I need to use it (on Windows 7)?

Man my brain is already exploding with this new information about linux, alsa, intel, etc. and now EDID :-)
Also webchat will do: http://webchat.freenode.net/
This did not help - it seems with that override you can only replace the modelines.
@Morrtin: Don't forget your post :-)
We activated his edid override but that didn't help either. We then performed a couple of changes to my system.
No all changes were Linux or XBMC related, we changed also the settings of my Sony AVR STR-DH810. In the end
he solved the problem.

I then tried to figure out what change was the solving one, so I restored a image of my system before all changes and
started over. All changes except AVR settings were reverted. After installing XBMC like I used to do it I didn't get any
XBMC screen. I implemented our changes step by step but non helped. At last I updated my kernel to 3.9 again and
all was working.

So I started from scratch again. Restoring image and installing XBMC. I didn't get a XBMC screen this time either. But
now i started with the kernel updated. And that was all I needed to get XBMC running with DTS-HD MA.

Bottom line I needed only a kernel update and the right settings for my AVR.

Settings we did on my AVR:
  • CTRL:HDMI set to off
  • Passthrough set to off (was grayed out anyway after first change)
  • Audio Output set to AMP instead of TV+AMP

Thanks fritsch for the great help!!

A little bit off topic:

During kernel update I get

W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169

At the moment I recognize no problems. Should these warnings concern me?
Concerning the firmware:
sudo mkdir -p /lib/firmware/rtl_nic
sudo cp /lib/firmware/rtl816* /lib/firmware/rtl_nic/

The firmware location seems to have chaned. Normally when installing 3.9.0 kernel on 12.04 updating the linux-firmware package should also be done.

Edit:
Code:
cd ~/
wget http://ubuntu.mirror.cambrium.nl/ubuntu//pool/main/l/linux-firmware/linux-firmware_1.106_all.deb
sudo dpkg -i linux-firmware_1.106_all.deb
Hi,
May I ask somebody to help me find out if my AT3IONT-I DELUXE is supporting DTS-HD MA ? on the ASUS page its written that it supports DTS and that supports HD Audio. but nothing about DTS-HD.
If my board is too old, what is the minimum to support DTS-HD ?
Thanks, Loyd
Minimum requirement ION-2 (which is also too old now).
Thank you Fritsch ... at least I will stop trying to remap or fix the issue Smile
For Passthrough there is nothing you can remap. For PCM there is - and this is also needed for ION-1
Pages: 1 2 3 4 5