Kodi Community Forum

Full Version: [SOLVED] trouble with 16:9
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I'm having some trouble with DTS in combination with 16:9.
When playing a DTS 16:9 movie it will not run smooth and I will see some pixel kinda stuff on the screen.

I'm using the mobo ASrock E350M1/USB3. I've had some issues already because it has an AMD Radeon HD6310 onboard.
I'm using the xvba acceleration to get videos played smooth.
Every movie does except the DTS with 16:9.
I've tested movies with dolby digital and they work fine. DTS with 2.35 works fine as well so I don't really know why 16:9 doesn't.

How do I fix this issue so I can watch all my movies?

Thanks in advance

Still having this issue but it has changed a little..
I was wrong with the DTS 16:9 combination. The problem is only the 16:9 ratio.

It seems to be the combination of 1080p and 16:9 ratio.
The screen starts shocking and I'm not able to watch the movie properly.

Does someone has advice for me to try?
plz post a media info of this file and a debug log
http://sharetext.org/EW28 (Debug Log)
what do you mean with mediainfo?
(2012-08-14, 18:03)cassperr Wrote: [ -> ]what do you mean with mediainfo?
Use the Mediainfo tool to display detailed information about the video file(s) in question. If you're using Ubuntu, it's also available via Synaptic Package Manager.
Debug log as said above.

Unique ID : 211296099406522819143216889238987263852 (0x9EF62603F5C0F90FA6362677D22CCF6C)
Complete name : /media/DATA1/Films/The Shawshank Redemption 1994 1080p BluRay x264 NL subs/The.Shawshank.Redemption.1994.1080p.BluRay.x264-CiNEFiLE/The.Shawshank.Redemption.1994.1080p.BluRay.x264-CiNEFiLE .mkv
Format : Matroska
Format version : Version 2
File size : 7.95 GiB
Duration : 2h 22mn
Overall bit rate : 7 981 Kbps
Encoded date : UTC 2009-06-14 13:12:55
Writing application : mkvmerge v2.9.5 ('Tu es le seul') built on Jun 7 2009 11:07:07
Writing library : libebml v0.7.7 + libmatroska v0.8.1

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : [email protected]
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Duration : 2h 22mn
Bit rate : 7 339 Kbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.148
Stream size : 7.15 GiB (90%)
Writing library : x264 core 64 r987 e71168d
Encoding settings : cabac=1 / ref=4 / deblock=1:0:0 / analyse=0x3:0x113 / me=umh / subme=6 / psy_rd=1.0:0.0 / brdo=1 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-2 / threads=6 / nr=0 / decimate=1 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=1 / wpredb=1 / bime=1 / keyint=250 / keyint_min=25 / scenecut=40(pre) / rc=2pass / bitrate=7339 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:1.00
Language : English
Default : Yes
Forced : No

ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Codec ID : A_AC3
Duration : 2h 22mn
Bit rate mode : Constant
Bit rate : 640 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 652 MiB (8%)
Language : English
Default : Yes
Forced : No

ID : 3
Format : UTF-8
Codec ID : S_TEXT/UTF8
Codec ID/Info : UTF-8 Plain Text
Title : Dutch
Language : Dutch
Default : Yes
Forced : No
No one?

The problem is no (longer) with 16:9.
The problem now appears with every 1080p movie.
Does anyone has a suggestion to try? It is really annoying me!

Movies I've seen before without problems don't play good anymore.
I'm running Ubuntu 12.04 and fully updated.
XVBA version of XBMC by wsnipex.

Any help is appreciated! thnx.
No truncated logs please, only full debug logs. Posting logs on http://xbmclogs.com/ increases the chances that anybody looks at it.
Debug Log; startup, start xbmc, start 1080p movie, stop the movie

Image is shocking, not playing smooth
Problem is solved with much help from wsnipex. Thanks a lot!

Bug in audio engine. Disable ' sync playback to display' in system settings -> video -> playback
wsnipex noticed; "you can try to reenable the sync playback to display option with method resample"

Not needed in my situation.
you are hit by http://trac.xbmc.org/ticket/13281

workaround: disable "sync playback to display"