Kodi Community Forum

Full Version: TMDB fanart not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
These should be some nice simple questions (eden11.0 xbmcbuntu, aeon nox 3.5, connecting to readynas ultra 4 via mounted NFS):
1. Fanart.jpg fails to download upon scrape for my james bond collection (but not others, such as Contraband and Dictator). I can set it manually to the thumb or some extrafanart, and I can also use Artwork downloader to download extrafanar (meaning xbmc can write successfully to the mounted NFS share). Anyone know what I can do here?(also, the extrafanart downloader is being told to fetch 'fanart')

In an effort to get around this I backed up, deleted the db and restored it. Part of deleting the db was going into Video, Files, Remove Source for both TV and Movies. But I didn't put these sources back before the restore. I restored the db by importing the videodb,xml file, with all the tbn files in subdirectories. It worked fine, but fanart still won't download. I thought it was these entries under Videos that defined which scraper to use, but everything still works on my restored db...I can 'Update Library' and it will find new content.

2. If I've got no Movies and TV Shows sources under Videos, how on earth do I edit the scrapers?
3. Can I just add the sources back without creating a complete duplicate library?
4. Finally, if I do add them back and edit the scraper settings on them, does it actually change anything? Xbmc seems perfectly happy to scrape according to something I backed up in the videodb.
5. As Extrafanart downloads quite happily, can I tell the skin to display that in the event that there is no fanart?

I'm asking because I've already restored the db 3 times today; and that's enough of that. I think it's time to ask people who know more about this stuff than I do.
Yeah, there seems to be an issue on TMDB's side of things. A bunch of people are having this problem.
Yep, me too.

Removing the new additions from the library, changing to the Universal Scraper and updating the library again worked for me.
(2012-08-10, 17:08)Ned Scott Wrote: [ -> ]Yeah, there seems to be an issue on TMDB's side of things. A bunch of people are having this problem.

No known issues on TMDb. XBMC is the only app I've heard experiencing any kind of problem.
Issue is fixed. This was a bug I introduced yesterday morning (CET) while fixing another issue.
Once the common scraper library update itself (there will be no notification about this) you will not experience the problem any more.

You can also do a force update from the context menu on the offical team-xbmc repo to quicken up the update.

Sorry about this.
OK no worries, not like we pay for this stuff - and its still better than anything you can buy. I do want to learn though - can someone help me on questions 2-5?