Kodi Community Forum

Full Version: Audio stops after 27 sec (but only after wakeup)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have a dual boot configuration with Win7 and XBMCbuntu on:
* Zotac ION ITX A Motherboard
* Intel Atom N330

As not being firm with linux, I used the Win7 so far and it works more or less very fine (except it crashes sometimes after wakeup). Now I tried to use XBMCbuntu because I expect it to be more stabke, better oerformance and more out-of-the-box experience.

I, as many others, had the "not wakeup" issue, but got it solved with this: http://www.loggn.de/linux-xbmc-aus-berei...aufwecken/
In the end I added the following to rc.local:

Code:
status=`cat /proc/acpi/wakeup | grep "USB0" | awk {'print $3}'`
if [ "$status" = "disabled" -o "$status" = "*disabled" ]; then
echo "USB0" > /proc/acpi/wakeup
fi

echo "enabled" > /sys/bus/usb/devices/3-4/power/wakeup

exit 0

Movies (I guess "pass-through audio" would be more correct to say) work fine, but when I play some music over DLNA (so, normal audio, not pass-through) all of a sudden sound is gone after about 30 seconds (27 to be exact, which does not change really on repeated tries). The music replay continues by the way, just the audio stops. What might be important to know:
* Disabling the wakeup fix above "SOLVES" the problem, music replay is working fine again! But of course is no option.
* Menu sounds do not work as well (I wouldn't care)
* No such problem or any sound problems so far under Win7
* After a restart it works too, problem only occurs after wakeup from sleep
* I fortunately do not have any other problems after wakeup like many other users (remote, network, etc.)

The debug log is here: http://pastebin.com/Zu5gRsB0
# I sent the system to sleep with remote
# Woke it up with remote
# Played some music over DLNA
# After one minute of replay (sound stopped after 27 sec. of course) I stopped playback
# Then I closed XBMC

Help on this would be very much appreciated as I still would prefer Linux over Windows (after I have solved the stuttering which is worse under Linux compared to Win7, which really, really surprised me).
Mmh, is there no one else having this problem? I was sure this is related to XBMCbuntu since it works under Win7 on the same machine.

Or is my method of enabling wakeup with the remote wrong?

Help would be still very much sppreciated.
try to remove pulseaudio