Kodi Community Forum

Full Version: [Solved] Can add Movies to the library but not TV Shows
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I used to use Dharma in Arch Linux quite often with no problems. I since got a new HTPC, installed Arch as well as XBMC 11.0 (first time with 11.0). I don't use scrapers to make my nfo files as I make them by hand. I can add movies and it finds my nfo files, etc and the library looks good. When I try to add my TV shows, it doesn't find anything. Here is an example of my directory structure for TV shows (mount is /media/tv/):

Code:
-Dexter
   -Season 03
   -Season 04
   -Season 05

Inside the root of the show (in this case Dexter) are my thumbnails, fanart, etc. as well as my tvshow.nfo. Inside each season folder is the video file, nfo file, and thumbnail file for each episode (named identically for each episode in the format "Dexter.S03E01.....")

Setting the content of the show it tries to scan but doesn't find anything. I've tried eliminating the season folder structure and putting them all in the root folder of the show which appears to work on scanning but the show doesn't appear in the TV Show library.

Below is a snippet of the log file when they are in season folders:

Code:
DEBUG: ------ Window Deinit (DialogProgress.xml) ------
NOTICE: VideoInfoScanner: Starting scan ..
DEBUG: VideoInfoScanner: No NFO file found. Using title search for '/media/tv/Dexter/Season 05/'
DEBUG: FindMovie: Searching for 'Season 05' using The TVDB scraper (path: '/usr/share/xbmc/addons/metadata.tvdb.com', content: 'tvshows', version: '1.2.4')
DEBUG: scraper: CreateSearchUrl returned <url>http://www.thetvdb.com/api/GetSeries.php?seriesname=season%2005&amp;language=en</url>
DEBUG: FileCurl::Open(0xaa7cda28) http://www.thetvdb.com/api/GetSeries.php?seriesname=season%2005&language=en
INFO: easy_aquire - Created session to http://www.thetvdb.com
DEBUG: scraper: GetSearchResults returned <?xml version="1.0" encoding="utf-8" standalone="yes"?><results></results>
DEBUG: FindMovie: Searching for 'Season 05' using The TVDB scraper (path: '/usr/share/xbmc/addons/metadata.tvdb.com', content: 'tvshows', version: '1.2.4')
DEBUG: scraper: CreateSearchUrl returned <url>http://www.thetvdb.com/api/GetSeries.php?seriesname=season%2005&amp;language=en</url>
DEBUG: FileCurl::Open(0xaa7cda28) http://www.thetvdb.com/api/GetSeries.php?seriesname=season%2005&language=en
DEBUG: scraper: GetSearchResults returned <?xml version="1.0" encoding="utf-8" standalone="yes"?><results></results>
DEBUG: VideoInfoScanner: No NFO file found. Using title search for '/media/tv/Dexter/Season 04/'
DEBUG: FindMovie: Searching for 'Season 04' using The TVDB scraper (path: '/usr/share/xbmc/addons/metadata.tvdb.com', content: 'tvshows', version: '1.2.4')
DEBUG: scraper: CreateSearchUrl returned <url>http://www.thetvdb.com/api/GetSeries.php?seriesname=season%2004&amp;language=en</url>
DEBUG: FileCurl::Open(0xaa7cda28) http://www.thetvdb.com/api/GetSeries.php?seriesname=season%2004&language=en
DEBUG: scraper: GetSearchResults returned <?xml version="1.0" encoding="utf-8" standalone="yes"?><results></results>
DEBUG: FindMovie: Searching for 'Season 04' using The TVDB scraper (path: '/usr/share/xbmc/addons/metadata.tvdb.com', content: 'tvshows', version: '1.2.4')
DEBUG: scraper: CreateSearchUrl returned <url>http://www.thetvdb.com/api/GetSeries.php?seriesname=season%2004&amp;language=en</url>
DEBUG: FileCurl::Open(0xaa7cda28) http://www.thetvdb.com/api/GetSeries.php?seriesname=season%2004&language=en
DEBUG: scraper: GetSearchResults returned <?xml version="1.0" encoding="utf-8" standalone="yes"?><results></results>
DEBUG: VideoInfoScanner: No NFO file found. Using title search for '/media/tv/Dexter/Season 03/'
DEBUG: FindMovie: Searching for 'Season 03' using The TVDB scraper (path: '/usr/share/xbmc/addons/metadata.tvdb.com', content: 'tvshows', version: '1.2.4')
DEBUG: scraper: CreateSearchUrl returned <url>http://www.thetvdb.com/api/GetSeries.php?seriesname=season%2003&amp;language=en</url>
DEBUG: FileCurl::Open(0xaa7cda28) http://www.thetvdb.com/api/GetSeries.php?seriesname=season%2003&language=en
DEBUG: scraper: GetSearchResults returned <?xml version="1.0" encoding="utf-8" standalone="yes"?><results></results>
DEBUG: FindMovie: Searching for 'Season 03' using The TVDB scraper (path: '/usr/share/xbmc/addons/metadata.tvdb.com', content: 'tvshows', version: '1.2.4')
DEBUG: scraper: CreateSearchUrl returned <url>http://www.thetvdb.com/api/GetSeries.php?seriesname=season%2003&amp;language=en</url>
DEBUG: FileCurl::Open(0xaa7cda28) http://www.thetvdb.com/api/GetSeries.php?seriesname=season%2003&language=en
DEBUG: scraper: GetSearchResults returned <?xml version="1.0" encoding="utf-8" standalone="yes"?><results></results>
DEBUG: VideoInfoScanner: No (new) information was found in dir /media/tv/Dexter/
NOTICE: VideoInfoScanner: Finished scan. Scanning for video info took 00:01
INFO: Video scan was stopped or finished ... restoring FindRemoteThumbs
DEBUG: Thread VIDEO::CVideoInfoScanner 2860313408 terminating
DEBUG: CGUIMediaWindow::GetDirectory (/media/tv/)

Any ideas what is happening? Am I missing something basic?

Thanks
At which directory level are you initiating the scan? "Dexter"? "Season xx"? At a higher level (e.g., "TV Shows") which contains the subdirectories for all your TV shows? If you are doing it at the "Dexter" level, be sure to enable the "Selected folder contains single TV show" option on the TVDB scraper settings page.
Thanks a lot. I knew it was something simple that I missed. That solved the problem. Thanks Smile