Kodi Community Forum

Full Version: Shared Thumbnails for profiles using path substitution
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm trying to get path substitution to work for shared thumbnails, but I'm using profile so it gets a little tricky. I am able to substitute the path for the masterprofile (which I renamed to Adults) and it is working very well so far.

But I'm not sure what I need to specify for the Kids profile. I've tried several things but nothing is working so far. Here's a full look at the path substitution from my advanced.xml file:

<pathsubstitution>
<substitute>
<from>special://masterprofile/Thumbnails/</from>
<to>smb://192.168.1.133/videos/Thumbnails/</to>
</substitute>
<substitute>
<from>special://profile/Kids/Thumbnails/</from>
<to>smb://192.168.1.133/kidsvideos/Thumbnails/</to>
</substitute>
</pathsubstitution>

Have I screwed things up by renaming the masterprofile as Adults? Or do I need to use a different <from> syntax for the Kids profile? Thanks for any help you can provide.
I have same problem.. Can anybody help?
Use special://profile instead of special://masterprofile. Just "profile" will always look at the currently loaded profile.

so it should be

<from>special://profile/Thumbnails/</from>
<to>smb://192.168.1.133/videos/Thumbnails/</to>
(2012-09-20, 10:22)Ned Scott Wrote: [ -> ]Use special://profile instead of special://masterprofile. Just "profile" will always look at the currently loaded profile.

so it should be

<from>special://profile/Thumbnails/</from>
<to>smb://192.168.1.133/videos/Thumbnails/</to>

I have two different thumbnail locations depending on what profile is used. Is there any way to specify what profile should be paired up with a specific directory?

Kids profile = kidsvideos/Thumbnails
Adults profile = videos/Thumbnails
Just make the advancedsettings.xml file different for the kids profile so that it says:

<from>special://profile/Thumbnails/</from>
<to>smb://192.168.1.133/kidsvideos/Thumbnails</to>
Totally forgot that the profile would have its own advancedsettings.xml file. Set it up as you said and all is working well, thanks Ned!