Kodi Community Forum

Full Version: OpenELEC Testbuilds for RaspberryPi
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

i like to continue here our OpenELEC Testbuilds thread from http://www.raspberrypi.org/phpBB3/viewto...167#p89072 for various reasons.
  • this forum is watched by many more developers, this helps to fix issues faster
  • this forum is a common place for XBMC installs, here you can get better help with your XBMC

Homepage:
http://www.openelec.tv

IRC Support Chat:
#openelec on freenode.net

Wiki:
http://wiki.openelec.tv

Official development build:
http://sources.openelec.tv/tmp/image/openelec-rpi/

Installing on RaspberryPi
http://wiki.openelec.tv/index.php?title=...spberry_Pi

Updating without loosing your settings:
http://wiki.openelec.tv/index.php?title=...g_OpenELEC
Hi,

OpenELEC Development build (r11930):
http://sources.openelec.tv/tmp/image/ope...30.tar.bz2

to update a older build without reinstalling see:
http://wiki.openelec.tv/index.php?title=...g_OpenELEC

After the last bigger XBMC update there was a rewrite of the XBMC code for RPi from Gimli with the goal to make the RPi port ready for merging with XBMC-master (the actual development branch for the upcoming release "Frodo"). This means there was a lot of changes, internally testing and preparing. After the XBMC Devcon one 2 weeks ago the RPi Pullrequest was merged to XBMC-master shortly after the merge of the also long waiting PVR pull request. This now means PVR and RPi support is officially part of XBMC - and PVR support is avaible for RPi too. Thats both great news - more info you can read at http://openelec.tv/news/item/250-project...nt-changes
Since then many things was fixed too:
  • XBMC with PVR support and PVR addons installed
  • Kernel linux 3.2.28 changed to the RPi foundation 3.2 kernel and updated to 3.2.28
  • some audio related issues fixed
  • fixed XVDR addon
  • fixed CEC support
  • various other improvenments, fixes and package updates
  • a nice (and fixed) Systeminfo dialog to get some informations like the serial to buy the licenses, cpu temperature, hardware revision (see screenshot)
    Image

You can install HTS TVHeadend a PVR backend via XBMC's addon system
(go to: System/Settings/Add-ons/Services/hts-tvheadend install and reboot for more informations see:
http://wiki.openelec.tv/index.php?title=...dend_addon )

It is needed to update the bootloaderfiles which you can find in the build in the folder 3rdparty/bootloader it will be done automatically if you use a build 11766 or newer. For older builds you can update locally via Windows/Linux or via ssh:
  • login via ssh to your Raspi:
    Code:
    ssh [email protected]<ipaddress>
  • remount /flash r/w:
    Code:
    mount -o remount,rw /flash
  • from your linux system copy the files via ssh/scp to the Raspi:
    Code:
    scp 3rdparty/bootloader/* [email protected]<ipaddress>:/flash

because XBMC now supports officially RPi and PVR please use XBMC's Trac (http://trac.xbmc.org/) to report XBMC bugs and OpenELEC's github issue tracker (https://github.com/OpenELEC/OpenELEC.tv/issues) for OS related issues and feature/driver requests.

Is there any way to install this from a windows machine? I do not have access to a Linux machine with a SD slot. Is there an .img that I can use with Win32diskimager?
Cool ! Would it be a good idea to install tvh backend and two dvbs2 usb tvcards and a usb disk. To hide away and have a low power 24h dvr? How to now if this tvcards works http://sundtek.com/shop/Digital-TV-Stick...-S/S2.html
(2012-09-15, 13:10)Jönke Wrote: [ -> ]Cool ! Would it be a good idea to install tvh backend and two dvbs2 usb tvcards and a usb disk. To hide away and have a low power 24h dvr? How to now if this tvcards works http://sundtek.com/shop/Digital-TV-Stick...-S/S2.html

for the sundtek sticks we have a own addon, it will be reviewed the next days for RPi support and then released with RPi support. so i think it should be avaible within the next week
hey thanks for making this thread here!

i just wanted to mention that on the latest build 11930 i get very pixelated fanart for movies/tv. My resolution is 1080p and fanart was very crisp clean in the previous versions, but in this one I get very pixelated fanart. Im wondering if this is just an issue im experiencing, and i need to reload my DB or if its something everyone else is noticing.
Hey, I was wondering on the correct way to shut this thing down with openELEC on it?

Google told me to use either sudo shutdown -h or sudo halt but If I use either command I just get an error saying sudo not found (This is all over SSH)

Is there some other commmand I need to use? I tried poweroff and it seemed to do something similar.
(2012-09-15, 19:02)onetootreefor Wrote: [ -> ]hey thanks for making this thread here!

i just wanted to mention that on the latest build 11930 i get very pixelated fanart for movies/tv. My resolution is 1080p and fanart was very crisp clean in the previous versions, but in this one I get very pixelated fanart. Im wondering if this is just an issue im experiencing, and i need to reload my DB or if its something everyone else is noticing.

Thats a technical limitation we did for now on the PI. In previous version we had GPU memory issues ( running out ). So we limit the mxiumum size for images, until we have a better solution for that.
@gimli,

we had the same issue on atv2, looking at the advancedsettings you have as default, maybe you should update them, frodo has some changes related to this:

look for
<imageres>480</imageres>
<fanartres>720</fanartres>

http://forum.xbmc.org/showthread.php?tid...pid1142983


P.S. talking about the default advancedsettings

<visualizedirtyregions>off</visualizedirtyregions>

It's off by default, so no needs to set it again.

Also, keep an eye on this pull, will enable DR per default
1426 (PR)
I'm getting this error in some addons in latest builds

Code:
22:25:59 T:1220281440   ERROR: Leaving Python method 'XBMCAddon_xbmc_Player_play'. Exception from call to 'play' 'Incorrect type passed to "play", was expecting a "p.PlayList" but received a "p.XBMCAddon::xbmc::PlayList"' ... returning NULL
2

did the python api changed ?

Also music playback starts at 5 secs not 0, so it is off by 5 secs, only the time is wrong the playback seems to be accurate
(2012-09-15, 22:30)Jester Wrote: [ -> ]@gimli,

we had the same issue on atv2, looking at the advancedsettings you have as default, maybe you should update them, frodo has some changes related to this:

look for
<imageres>480</imageres>
<fanartres>720</fanartres>

http://forum.xbmc.org/showthread.php?tid...pid1142983


P.S. talking about the default advancedsettings

<visualizedirtyregions>off</visualizedirtyregions>

It's off by default, so no needs to set it again.

Also, keep an eye on this pull, will enable DR per default
1426 (PR)

I'm aware about the D-R PR. My job as developer to track changes in master Wink
My fault. Will fix shortly.
Can you tell me how you got the error so I can reproduce it?

Thanks.
xbmc-iplayer seems to suffer from the same problem...

this is code in the addon, 1chanell

Code:
    stream_url = urlresolver.HostedMediaFile(url=url).resolve()
    playlist = xbmc.PlayList(xbmc.PLAYLIST_VIDEO)
    playlist.clear()
        // some metadata code here
        playlist.add(url=stream_url, listitem=listitem)
    player = playback.Player(imdbnum=imdbnum, video_type=video_type, title=title, season=season, episode=episode, year=year)
    player.play(playlist)
    while player._playbackLock.isSet():
        xbmc.sleep(250)

Code:
22:25:59 T:1220281440   ERROR: Leaving Python method 'XBMCAddon_xbmc_Player_play'. Exception from call to 'play' 'Incorrect type passed to "play", was expecting a "p.PlayList" but received a "p.XBMCAddon::xbmc::PlayList"' ... returning NULL
22:25:59 T:1220281440   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.RuntimeError'>
                                            Error Contents: Incorrect type passed to "play", was expecting a "p.PlayList" but received a "p.XBMCAddon::xbmc::PlayList"