Kodi Community Forum

Full Version: Segfault since change from pvr branch
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all, My XBMC has been segfaulting every time I try and access any library (music/movies/tv shows/etc) since I have switched from the pvr branch to master.
I am running Linux 3.5.3-1-ARCH #1 SMP PREEMPT x86_64 and I am having the issue with XBMC Media Center 12.0-ALPHA3 Git:20120610-3277107. Running with the --debug flag I receive the following:

ERROR: Exception caught on main loop. Exiting
/usr/bin/xbmc: line 137: 11553 Segmentation fault (core dumped) "$LIBDIR/xbmc/xbmc.bin" $SAVED_ARGS

The crashlog is available at http://codepad.org/re3yYBY1

Does anyone have a clue as to what is causing this?

pvr branch version is XBMC Media Center 11.0 Git:20120725-c01de81

rename the ~/.xbmc dir and try to run xbmc again. I could imagine that there was some change between pvr and master that broke backwards compatibility and causes the crash.
If this does not solve the problem, there seems to be a bug in master branch Wink

mv ~/.xbmc ~/.OLD_xbmc

after your test, you may want to switch back (just if xbmc still fails):
# first get rid of the newly created directory - if this complains about not finding the directory, ignore it and go on with next step
rm -rf ~/.xbmc
# move back/rename the OLD_ directory
mv ~/.OLD_xbmc ~/.xbmc
I have tried that, and as soon as I try and open the library I get the exact same segfault. I have also tried the fix mentioned in https://bugs.archlinux.org/task/30379 and this did not fix my issue. The version of the pvr branch that works for me is XBMC Media Center 11.0 Git:20120725-c01de81 (I only just realised it's 11.0)