Kodi Community Forum

Full Version: Can't locate the wrong dependency
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello! I have a strange problem. I've been updating Simplicity so that it can work with Eden (see that as Archive work...), but I can't install it due to wrong dependency that's can't be meet.

In XBMC.log, I get :

Quote:Addon skin.simplicity requires script.logo-downloader version 2.0 which is not available

However, logo-downloader is not in the required addon insise addon.xml and there's no call to this script in any of the xml files.

I've been using ver 2.0.3 from ronie (http://forum.xbmc.org/showthread.php?tid=129554) as the base template and made cosmetic minor changes. It works on my dev laptop, but it fail to install as soon as I put it on my repo and try to install from there.

Any ideas of what I could try? Thanks a lot!

edit - The only thing I see is that Simplicity that is on the official repo needs script.logo-downloader 2.0.0, but that's not the version that I'm trying to install.
Is there any "scripts" folder in your skin folder?


none of them has call to logo-downloader though... :/

edit - oh, just re-read your post... nope, no script folder.
(2012-09-20, 20:12)Balinus Wrote: [ -> ]edit - The only thing I see is that Simplicity that is on the official repo needs script.logo-downloader 2.0.0, but that's not the version that I'm trying to install.

But does it have the same name? if so, it could be trying to install a zipped version from the 'packages' folder.
Yeah, it did have the same name, but I changed the folder name ("skin.simplicity.svn") and skin name ("Simplicity (svn)"), with the relevant modifications inside addon.xml.

I'll look into the "packages" folder. This could be the cause as the 1st attemp, they had the same name. Though, where is this folder? Can't locate it...
With all the addons.

ok, purged everything from the packages folder... re-downloaded the skin and I still get an error. This time, it's not related to script.logo-downloader. I get this error from xbmc.log :

ERROR: Could not read addon description of skin.simplicity.svn

Here's the addon.xml in case :

<?xml version="1.0" encoding="UTF-8"?>
  name="Simplicity (svn)"
  provider-name="igotdvds and Balinus">
    <import addon="xbmc.gui" version="3.00"/>
    <import addon="script.artwork.downloader" version="1.0.10"/>
    <import addon="script.randomitems" version="3.0.9"/>
    <import addon="script.favourites" version="3.2.2"/>
    <import addon="script.cu.lyrics" version="2.0.6"/>
    <import addon="script.tv.show.next.aired" version="4.1.20"/>
  <extension point="xbmc.addon.metadata">
    <summary lang="en">A skin for XBMC from the creators of Shade.  A fresh take on a simple and elegant skin.</summary>
    <description lang="en">Simplicity was designed around its name, simple.  We tried to keep everything clean and fluid without losing great features.  Enjoy!</description>
Maybe a hidden special character in the description? Accidentally hit one of those keys during typing?
Like for example: a ` or a ~ that was not followed by a space. Just try and retype or with like 1 character in description.
Found the culprit of my problem. I replaced the Textures.xbt with the GIT source media files so that I could work from there and modify some files. I didn't repacked those files with TexturePacker. If I replace all the media files with the old Textures.xbt and only add the one png file I needed for the modification, it will install.

Now, I find it to be "not esthetic" to have a single png file alongside the Textures.xbt. So, I downloaded TexturePacker but hey... there's so much options there... now under Linux, do I need to compile XBMC to have the in-house version of TexturePacker with presets?
yes, if you want to run TexturePacker on linux, compile xbmc.

as for the available options, you can leave all of them to their defaults.
you should only need to specify the inputdir and outputdir.
ok, thanks! I'll look into a windows build then as I don't want to meddle too much with my Linux install right now (for a lot of good reasons!).
Great, now with the Textures.xbt correctly created, it now longer fail.

Thanks to everyone!