Kodi Community Forum

Full Version: Philips hue integration or add-on
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
I checked my settings.xml in the resources directory and it states this:

<setting id="group_id" type="number" label="309" default="0" visible ="eq(-4,0)" enable="eq(-4,0)" />

<setting id="ambilight_dim_group" type="number" label="602" default="0" enable="eq(-1,true)" visible="eq(-1,true)" />

Shouldn't this set the id?
Shouldn't or should? It crashes right? so whatever it should, you need to fix it :-)
Haha, yes I should Smile And I did Smile Simply going into the configure menu. Assigning group 0 there and disabling-enabling the plugin. Then setup my 3 lights at the TV and it works! Thanks a lot fritsch.
I'm trying to install this add on. I install all that is required and then try to search for hub. A pop up comes up saying searching and then it disappears but then that's it. nothing happens.

Any Advice. ?
@fritsch is it possible for you to hack this to work with SPMC? Throws up a load of Python errors at the mo.

I'd ask on the SPMC bugtracker.
(2016-04-05, 08:30)fritsch Wrote: [ -> ]I'd ask on the SPMC bugtracker.

Is that just the SPMC thread? Koying has said it won't work because of Kodi references but someone else has said they have it working. I'm not clever enough for this... [WINKING FACE]
Reproduce with kodi first - best (latest nightly) and see if it works ...
I've just reinstalled Kodi and copied over the config files from SPMC and the addon works fine. Very strange!
I sadly bought a Hue starter kit mainly for this add on. Only my FireTV stick it works but is unusable as video skips and stutters. This is with Jarvis 16.1 RC2 (surface disabled). I also tried Isenguard 15.2 and it did the same thing.

I tried 7.2 and 8 beta 2 from both fritsch's github and michael carroll's.

I then tried the various Hue addon versions on two different Windows desktops and tried the Hue addon. On the Windows systems I couldn't even get it to connect to the bridge. It says it looks for it then gives an error sound after a few seconds.

Unfortunately without Ambilight for TV viewing I can't justify my purchase and will have to return it. If I just want bulbs that can change colors from an app I can get the Mi Light ones on Amazon for dirt cheap.

Thanks for any help.
What is the staus if I buy a Philips hue kit with 3 lamps. Is there still to much delay to use as ambilight in Kodi?
Has anyone got this working on a FireTV box using the kodi 16.1?
I got it installed and then after finding the bridge I get an error, rebooting kodi just throws the same error when the service is trying to load.

(2015-04-17, 22:41)boggo22 Wrote: [ -> ]Hello,
Hopefully someone can help me on this Problem:
Running the lastet OpenElec and I get always an script error.
Trying it on my FireTV with kodi, it works.

Here is the log File from OpenElec:
07:26 T:140275596879616 NOTICE: XBMC Hue: DEBUG creating Light instances
19:07:26 T:140275596879616 ERROR: EXCEPTION Thrown (PythonToCppException) : –>Python callback/script returned the following error<–
Error Type:
Error Contents: list indices must be integers, not str
Traceback (most recent call last):
File “/storage/.xbmc/addons/script.xbmc.hue.ambilight-master/default.py”, line 462, in
hue = Hue(settings, args)
File “/storage/.xbmc/addons/script.xbmc.hue.ambilight-master/default.py”, line 95, in __init__
File “/storage/.xbmc/addons/script.xbmc.hue.ambilight-master/default.py”, line 197, in update_settings
self.light[0] = Light(self.settings.light1_id, self.settings)
File “/storage/.xbmc/addons/script.xbmc.hue.ambilight-master/resources/lib/tools.py”, line 102, in __init__
File “/storage/.xbmc/addons/script.xbmc.hue.ambilight-master/resources/lib/tools.py”, line 118, in get_current_setting
state = j[‘state’]
TypeError: list indices must be integers, not str
–>End of Python script error reportPython Interpreter Initialized<–

Sorry for my bad english,
Best regards,


I am getting the same error. I cannot get this working on OpenElec 6.0.3 / Kodi Isengard 15.2

I have tried the forks from Michael Caroll and Fritsch both version 0.7.2 come up with this script error after Kodi launches.

I also tried the beta version from Michael Caroll, that ones does not have script errors, but I could not get Ambilight mode to work at all.

I have a Gen 1 Philips Hue hub and LED strip.

Anyone else have this working with OpenElec ?

Error Type: <type 'exceptions.TypeError'>
                                            Error Contents: list indices must be integers, not str
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/script.kodi.hue.ambilight-master/default.py", line 560, in <module>
                                                hue = Hue(settings, args)
                                              File "/storage/.kodi/addons/script.kodi.hue.ambilight-master/default.py", line 97, in __init__
                                              File "/storage/.kodi/addons/script.kodi.hue.ambilight-master/default.py", line 249, in update_settings
                                                self.light[0] = Light(self.settings.light1_id, self.settings)
                                              File "/storage/.kodi/addons/script.kodi.hue.ambilight-master/resources/lib/tools.py", line 81, in __init__
                                              File "/storage/.kodi/addons/script.kodi.hue.ambilight-master/resources/lib/tools.py", line 97, in get_current_setting
                                                state = j['state']
                                            TypeError: list indices must be integers, not str

Seems I have it working now and the LED strip light is changing colours with what is being displayed on the screen in the movie.

I had to manually create my own user on the Philips Hue bridge and then I entered that same user ID in to the Kodi add-on settings and it just started working. I used my Windows PC to create the user ID and then entered that ID in to the OpenElec HTPC add-on settings etc.

I am using the Fritsch fork as it seems to be the last one to have been updated?

To do this I read this page here and created a new user as it describes.

Using the Clip API Debugger tool, I entered the following to create a user;

URL Field:


Body Field:


I just called my user kodi

In the Command Response area, you then end up with a user ID like 1028d66426293e821ecfd9ef1a0731df for example.

I then manually added this in to the Kodi add-on settings and hey presto it just started working.

Also worth noting I have the following settings in the Kodi add-on turned off, but not sure if it makes any difference ?

Bridge Configuration -> Enable Initial Flash
Advanced Settings -> Override Hue Colours

So it seems the add-ons auto configuration is not creating a user properly on the bridge Huh

Are there any recommended tweaks to the add-ons settings to optimize the setup ?

Use the "develop" branch. 0.7.2 tries to create it's own user, which is deprecated in Hue.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29