Kodi Community Forum

Full Version: Philips hue integration or add-on
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29

I use
KODI 17 + HUE Bridge 2.0 at AFTV 4 K

i can find the brige
IP + key will be found


Theatre Mode is not working
when i start a movie nothing happens
only when i press multiple time pause/Play
it dimms and Switch on again ?!?

Ambilight Mode
nothing happens

i use the0.8b2 Version

any ideads

or is there a newer Version or a alternative plug in
I'm using this pluging since 0.6.
The current addon will be found in

Now we are in version 1.0, just for kodi 17.
There are a lot of improvements from older versions.
I've it running from a NAS QNAP and everything works perfect.
Two bloom lights for ambilight efects
Two ceiling hue white bulbs for theater mode
A hue bulb in the back of the room as static light.

I've a problem with my nvidia shield tv, reported in https://github.com/mpolednik/script.kodi.../issues/37

If you are ussing the old version you should check this new one...
(2017-03-08, 10:59)mrS4T4n Wrote: [ -> ]Hi!
I'm using this pluging since 0.6.
The current addon will be found in

Thanks for the heads up!

(2017-03-08, 10:59)mrS4T4n Wrote: [ -> ]Now we are in version 1.0, just for kodi 17.

Does this mean it does it requires Kodi 17, and does NOT work in Kodi 16? (Or SPMC, which is currently still based on Kodi 16?)

Looking forward to giving it a whirl but would like to know it's minimum requirements before trying to upgrade what's already working for me. Thanks again!
hi, i'm afraid the addon only works in kodi17...

BTW, this is the error i get in the nvidia setup (works fine in QNAP)

13:04:08.830 T:138001024080 WARNING: RunScript called for a non-script addon 'script.kodi.hue.ambilight'. This behaviour is deprecated.
13:04:11.316 T:138492707920   ERROR: EXCEPTION Thrown (PythonToCppException) :

-->Python callback/script returned the following error<--
Error Type: <type 'exceptions.AttributeError'>
Error Contents: 'MyMonitor' object has no attribute 'update_controllers'
Traceback (most recent call last):
    File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.kodi.hue.ambilight/default.py",
    line 61, in onNotification self.update_controllers()
    AttributeError: 'MyMonitor' object has no attribute 'update_controllers'
-->End of Python script error report<--
Hi all! I just got the latest Philips Hue starters kit. I installed everything OK and I am using only one lamp at the moment in my living room where the home cinema is. I am running LibreElec 8.0.1 on an Intel Nuc. I install the addon from a zip file, it finds the bridge just fine, I configure the ambilight mode (the one that I am only going to use) to use Hue Lamp 1, everything seems fine so far. When a movie or an episode starts though nothing happens and when I restart the system it gives me an error message at the beginning about an addon's error and I suspect that the addon fails to start. Have in mind that I am also using Hyperion from my ambilight led strips behind my TV (just mentioning it in case it causes a conflict or smt). Needless to say I am using the latest version 1.0 of the addon. Thx for the effort and the time to answer my problem!
iazriel Make sure you set hardware acceleration. Go to System -> Settings -> Video (switch to "Advanced settings level") -> Acceleration -> and toggle off "Allow hardware acceleration - MediaCodec (Surface.) This allows it to start working. Cheers
Mediacodec(surface) has nothing to do with a NUC does it?
Sungolfer thx a lot for your reply, I made some changes recently with hardware acceleration options and that might cause the problem (some are not compatible with Intel hardware as it seems). Will test it when I get back home, thx again. Cheers.
Unfortunately I am still getting the same error. I've tried and disabled all hardware acceleration options but I am still getting the same hue error addon when I restart the system. I mean it installs just fine, I configure it just fine and then I reboot and boom it pops the error message in the start. Any ideas? Log file: https://paste.ubuntu.com/24262890/

In my case, i had setup lamps and rooms with special characters within the Hue app. Switching from the swedish "Kök" to "Kitchen" made it work in Kodi.

I hope that this will help
Thx for the reply Lovegun, I already have it in English... Sad
OK so I think I have isolated the problem. First of all I set a static IP (inside the DHCP range for starters). Secondly, I got today another update from Philips, maybe it helped maybe it didn't. I did a hard reset on the hue after the update. Thirdly, I tried the following and it worked. I reset the app settings. I disabled and re-enabled the app. Run the configuration again, it found the bridge, I put a movie on, boom everything works like a charm!

BUT: I reboot the system and after the restart I get the same app error at the start up of LibreElec and the app doesn't work. If I do the above procedure again with the settings reset etc it will work like a charm but it will crash again with every system reboot. Setting an IP outside the DHCP range or a conflict with Hyperion isn't the case since the app is working, as long as I don't reboot the system. Hope this helps a bit... Cheers!
Debug log (wiki)
(2017-03-29, 06:45)nickr Wrote: [ -> ]Debug log (wiki)

I have everything working, however i have an issue. If the philips lights are turned off when kodi starts and they then get turned on afterwards, they will not dim in theatre mode. If the lights are on when kodi starts everything works fine.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29