Kodi Community Forum

Full Version: (UK ONLY)SkyGO Working now in XBMC
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Reading through some of the posts here, it seems that it's possible to use this plugin with Chrome rather IE, I have have defaulted the browser to chrome, but it still seems to use IE when the running the skygolauncher. Any suggestions?
Firstly, thanks to everyone who has contributed.
I'm hoping that the following info will help in finding a solution to SkyGo login problems.

re. Chrome as default browser, I'm also stuck with IE.
I tried Control Panel\Programs\Default Programs\Set Default Programs
highlight Chrome > choose htttp & https as defaults,
as suggested here; http://superuser.com/questions/498467/wh...ng-ignored

I'm using Windows 8 Pro 64bit for all computers.
In common with others I cant get the latest repo or 'SkyGo 1.7b.exe' to login to Sky, strangely:
a) It did access the account once when I ran multiple versions of the exe.
b) Login works on my laptop but not a fresh Windows install on a N40L or N54L server.
SkyGo1.6b will login on the servers but it defaults to the Atlantic channel, with the js error mentioned recently.

same error for 1.6b as 1.7b2013 & repo;
T:4456 WARNING: Attempt to use invalid handle -1
T:5884 WARNING: Previous line repeats 4 times.

analyse wait chain - one or more threads of skygo are waiting to finish network I/O
thread 7572
(using 50% of cpu)

Firewall/antivirus = off.
I've tried to replicate the working laptop setup on the servers e.g. internet options, UAC/admin/compatibility, Silverlight, .net framework...
I've used various versions of XBMC, Silverlight...
& changed paths/users (on C drive), & manually edited repo and Mike's Skydrive files.
Only the version of IE10 differs slightly, I can't downgrade from IE10.

thanks again & help!
This has probably been answered but is/will this ever be compatible with android. Just picked myself up a GBox Midnight for the bedroom and was wondering.
Not on Android, Silverlight is closed source from Microsoft:

re.my post above, I just noticed a web link from the Crashplan app doesn't work,
so the SkyGo login problem probably relates to browser launch paths/permissions.
Hi. First of all thank you for developing this plugin. It is exactly what I've been looking for.

However, I do have a few issues. I have just done a fresh install of Win 7 Pro x64 and installed Frodo 12.2.
I have installed the skygo plugin by downloading the zip file from the google code page and using install from zip in xbmc to install.
I have entered my login details and made sure I have the latest silverlight version.
When running the plugin I get the splash screen saying connecting the sky go but this is as far as I can get.
I have made sure I can login to sky the usual way on the website via IE10 and all works fine.

I downloaded 1.7b2013 manually from the sky drive account and placed that in C:\skygo and place skygolauncher.bat in the root of C but this has the same problem.

If I delete the skygo folder and replace it with v1.6 it works fine manually from the bat file albeit with the IE script error to which I just click yes.

I've even tried to replace the skygo.exe in the xbmc adding folder with the v1.6 file to see if that may work in xbmc but that just gives me an addon.py error when I go to load it.

Does anyone have any ideas as to why the v1.7b2013 version does not get past the connecting to sky go message?


Ps I don't have any antivirus or firewall currently installed.
I have downloaded the latest version of this and installed the program from the repo on my ATV2 but i get a py error. I know someone said something about putting a file in the c: root directory but what file? Could someone help me?
Not sure it's compatible with ATV. Could be wrong though
Ah ok, thanks
Glad people are enjoying my plugin, I am sorry I haven't had time to develop this further but I check every now and again and it seems syborg is doing a great job in developing and maintaining the plugin. :O)

We are almost at the 100,000 views mark and now over 50,000 downloads ! wow

Happy Days

XbmcSkygo Creator
Karl W- Make sure you download the exe and Syborgs stuff in the repository...happy days


can you login to skygo through the web on the machine that has the problem? using IE. The exe uses iexplorer.exe framework.
do you have silverlight correct version installed ?

Thanks mike
Karl w

Will it work on a android box
(2013-08-26, 22:36)Woolfy137 Wrote: [ -> ]Thanks mike
Karl w

Will it work on a android box

no i only designed the app to work on a windows platform. Mainly due to the restrictions that are applied from microsoft in silverlight.

Unless an android developer comes forward and wishes to use my code Huh
(2013-08-26, 22:18)mjeyre Wrote: [ -> ]@stevenwestlake
can you login to skygo through the web on the machine that has the problem? using IE. The exe uses iexplorer.exe framework.
do you have silverlight correct version installed ?

I can login via the desktop app, have tried the Skydrive version of Silverlight.

I don't think the latest exe launches iexplorer (1.6b.exe does), the following may be relevant, Win8 requires process name in addition to url;

(2013-08-14, 23:34)tomcon Wrote: [ -> ]
(2013-08-12, 14:54)syborg Wrote: [ -> ]
(2013-08-12, 14:22)tomcon Wrote: [ -> ]Hi Syborg. I did download your skygolauncher addon but couldn't understand what to do with it, so I downloaded the skydrive files, moved them to their own folder in the C:\ drive and ran skygocache.bat

For the launcher all you have to do is add your username and password in the setting then select your channel done.
The skydrive files aren't really supported anymore.

(2013-08-14, 00:35)syborg Wrote: [ -> ]
(2013-08-14, 00:32)tomcon Wrote: [ -> ]Tried with the skygolauncher addon but it's coming up with the same error. Any ideas?

I have this issue too

Is this error coming up in xbmc or is it a windows error. Did you remove all the sky drive files before installing the addon?

This is the error which comes up...


I didn't remove the sky drive files before installing the addon. Should I do a reinstall of XBMC?