Kodi Community Forum

Full Version: (UK ONLY)SkyGO Working now in XBMC
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi guys

I've found that by uninstalling the internet explorer updates in appwiz and roll back to IE9 I can get skygo working again. This is Win7 Pro 64bit however so I don't know if you'll be able to rollback past IE10 on Win8?

It's hit and miss after loading but I dunno if that's linked to the script errors I can't seem to disable. I've found if I get one where the error reads
Line: 23
Char: 1
Error: 'searchSuggestionsApiHost' is undefined
Code: 0
URL: http://go.sky.com/resources/mpod/static/...js?jsV=9.2

and I say Yes to continuing running scripts on this page it will load (more often than not it will have the channel list selection "form" over the stream though - but if I keep selecting the channel and accepting the same error it goes away), but if I get 2 similar errors in a row it just sits at loading (I think from memory the first of those is Error: 'jsQuery is undefined' or something - but I'm struggling to replicate that atm bizarrely).

Anyway, maybe this will help someone.

Does anyone have any suggestions as to how to fully disable script errors past the usual:
internet options > disable script debugging (IE) - (tick)
internet options > disable script debugging (Other) - (tick)
internet options > display a notification about every script error - (untick)

Am contemplating writing an autohotkey script to send a return keystroke when it detects the error to accept but would rather not have to (as I am crap with autohotkey)..

Merry Christmas Everyone and a happy new year !,

Glad everyone likes the plugin, It has generated far more interest than I ever imagined !

Maybe I will come back in the new year and help my dev friend simon in getting this plugin ready for 2014 !


PS: I have played with Sky On Demand services and actually got some to work through XBMC so may see if the loophole still exists if I find time between work projects.
+ 1 for this mjeyre. Thanks for your hard work that many have come to enjoy in the form of this plug-in. Happy new year!
(2013-12-16, 16:23)peteypops Wrote: [ -> ]Hi All,

I'd like to confirm the Win 8.1 report. Set up on a clean install, confirmed Sky Go works via IE11, runme.bat or skygocache.bat both launch, log-in and drop to a black screen.

Hopefully IE11 hasn't screwed things too badly!!



I am finding the same issue in 8.1.. Black screen after logging in.
Hopefully it works again sometime soon..
Looks like an excellent launcher, unfortunately I cannot get it to work on windows 7 x64

I was getting a black screen after launching, so I un-installed IE11 and I am now getting the same script errors as mentioned by leetalb.

Can anyone suggest a fix?

(2013-12-21, 10:08)leetalb Wrote: [ -> ]It's hit and miss after loading but I dunno if that's linked to the script errors I can't seem to disable. I've found if I get one where the error reads
Line: 23
Char: 1
Error: 'searchSuggestionsApiHost' is undefined
Code: 0
URL: http://go.sky.com/resources/mpod/static/...js?jsV=9.2
ive always had the script errors, its an apparent windows 7 64bit issue i know the developers have reported on working on the issue but so far the only way to fix it is to install windows 7 32bit...
(2014-01-03, 13:52)timeslip1974 Wrote: [ -> ]ive always had the script errors, its an apparent windows 7 64bit issue i know the developers have reported on working on the issue but so far the only way to fix it is to install windows 7 32bit...

I was getting the script errors but they seems to have vanished

Win8 x64.

Sky go works flawlessly. Still irritating when the screen quality sets it to low. Then I have to mess about with the mouse to set it to high. Some times I can't even select a quality to change it too.
(2013-03-12, 19:22)syborg Wrote: [ -> ]Repo
Repo - http://xbmc-skygo.googlecode.com/files/r...-1.0.1.zip

Step 1 -
Download and install the repo from above.
Then install Skygo Launcher - go to configuration and enter your login details.

Step 2 - Only Required if you want freeview channels too.
Favourite all TVCatchup V1 channels

Step 3
Install TVGuide Syborg Mod from the above repo.

Step 4
Open TVGuide configuration and select channels - click update channel list

Step 5
Open Configuration again clear cache then download xmltv file

Step 6
Once download has finished - open tvguide and let it load the xmltv file in

Step 7
Open configuration and run the Channel sort & logos

and that is it you now should open tvguide and it should be fully populated.

I've just performed a fresh install of Frodo and the SkyGo app is now working well via Syborg's Launcher add-on (apart from the expected script errors on Win 7 x64).

I've moved on to setting up the TV Guide as per the instructions above (although I was unsure about Step 2, so I skipped it Confused). The TV Guide is working and launching the SkyGo channels perfectly, but it is showing me all channels (BBC1, BBC2, ITV, etc.) not just the SkyGo channels.

Can anyone provide any guidance on what I may have done wrong and how to correct it so I can only see the SkyGo channels?
Hi All,

Great Add-on. Read all 100 pages (I'm being serious!).

Struggling to get this working for me.

I inherited a PC which has the default drive name H rather than C so I followed the following instructions:

You need to go into H:\Users\[your username]\appdata\roaming\xbmc\addons\plugin.program.skygo.launcher\

Edit the following files

line 5 - 'C:\\Skygo' to 'H:\\Skygo'
line 9 - "c:\skygolauncher.bat" to "h:\skygolauncher.bat"
line 10 - os.path.expanduser(r'~\AppData\Roaming\XBMC\addons\plugin.program.skygo.launcher​\resources\skygolauncher.bat') to "H:\Users\[your username]\AppData\Roaming\XBMC\addons\plugin.program.skygo.launcher\resources\skygolaunch​er.bat"
line 15 - 'c:\\skygo\\' to 'h:\\skygo\\'

line 11 - os.path.expanduser(r'~\AppData\Roaming\XBMC\addons\plugin.program.skygo.launcher​\skygo.cfg') to "H:\Users\[your username]\AppData\Roaming\XBMC\addons\plugin.program.skygo.launcher\skygo.cfg"

and the launchers file which you have already edited yourself.

Firstly this isn't the same for me as I'm using XP rather than Windows 7 so my 'Users' folder is instead called 'Documents and Settings'. I made exactly the same changes as above (Apart from using 'Documents and Settings' rather than 'Users') but I still got errors in both movingfile.py and settings.py. I then changed settings.py line 11 to (Doubed up the backslashes):

configpath = "H:\\Documents and Settings\\Duncan\\Application Data\\XBMC\\addons\\plugin.program.skygo.launcher\\skygo.cfg"

and changed movingfile.py line 10 to (Again, doubed up the backslashes):

source = "H:\\Documents and Settings\\Duncan\\Application Data\\XBMC\\addons\\plugin.program.skygo.launcher\\resources\\skygolauncher.bat"

Which then was successfully copying the batch file into the H:\Skygo\ folder and I no longer get any errors when I launch the add-on. The problem now is that when I actually select a channel to watch, I get the following Windows error:

Windows cannot find 'H:\Documents'. make sure you typed the name correctly, and then try again. ...bla bla bla

Also a command prompt window appears (I guess this is the batch file running) which says:

The system cannot find the file H:\Documents.

This is obviously related to the way that the spaces in 'Documents and Settings' are being handled but I'm unsure how to fix this. As the error is within the batch file and not in XBMC then there are no XBMC logs which can help me work this out. Any help would be greatly appreciated.


School boy error, I even said in the previous post that the problem was in the batch file!

I changed my batch file to read:

@echo off

start /min "" "H:\Documents and Settings\Duncan\Application Data\XBMC\addons\plugin.program.skygo.launcher\cleanietempfiles.exe" -q

start "" "H:\Documents and Settings\Duncan\Application Data\XBMC\addons\plugin.program.skygo.launcher\skygo.exe" %1

and it works - awesome. Now can try getting the tv guide working. (Don't be surpised if I post again within the next hour or so)
So as expected...I'm stuck again.

I've fiddled with the TV Guide Mod files to point to the correct directory (I will document and explain for other users once up and running). Essentially it works - I can select channels from the EPG and the channel plays.

Problem is that some of the scripts aren't running properly.

After installing the add-on, I went into the settings and updated the channel list - that didn't work first time but was easy enough to alter and now it works fine.

Next I tried to clear the cache. When hitting the clear cache button nothing happens. No errors or messages. At this point I wasn't too concerned about this because there was probably no data in the cache.

Next thing is to download xmltv file. This errors in grabbers.py. This is the error from the log:

20:47:05 T:1700 DEBUG: Python thread: start processing
20:47:05 T:1700 NOTICE: -->Python Interpreter Initialized<--
20:47:05 T:1700 DEBUG: XBPyThread:Tonguerocess - The source file to load is H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.syborg.tvguide/resources/XMLTV/grabbers.py
20:47:05 T:1700 DEBUG: XBPyThread:Tonguerocess - Setting the Python path to H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.syborg.tvguide/resources/XMLTV;H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.module.t0mm0.common\lib;H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.module.simplejson\lib;H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.module.myconnpy\lib;H:\Program Files\XBMC\addons\script.module.pil\lib;H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.common.plugin.cache\lib;H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.module.simple.downloader\lib;H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.module.urlresolver\lib;H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.module.buggalo\lib;H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.module.parsedom\lib;H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.module.elementtree\lib;H:\Program Files\XBMC\addons\script.module.pysqlite\lib;H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.module.metahandler\lib;H:\Program Files\XBMC\system\python\DLLs;H:\Program Files\XBMC\system\python\Lib;H:\Program Files\XBMC\python26.zip;H:\Program Files\XBMC\system\python\lib\plat-win;H:\Program Files\XBMC\system\python\lib\lib-tk;H:\Program Files\XBMC;H:\Program Files\XBMC\system\python;H:\Program Files\XBMC\system\python\lib\site-packages;
20:47:05 T:1700 DEBUG: XBPyThread:Tonguerocess - Entering source directory H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.syborg.tvguide/resources/XMLTV
20:47:05 T:1700 DEBUG: DialogProgress::StartModal called
20:47:05 T:1700 DEBUG: ------ Window Init (DialogProgress.xml) ------
20:47:06 T:1700 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
Error Type: <type 'exceptions.KeyError'>
Error Contents: ('Grabbers',)
Traceback (most recent call last):
File "H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.syborg.tvguide/resources/XMLTV/grabbers.py", line 39, in <module>
File "H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.syborg.tvguide/resources/XMLTV/grabbers.py", line 25, in schedule
configini(value, ini)
File "H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.syborg.tvguide/resources/XMLTV\other.py", line 18, in configini
config['Grabbers']['XMLTV_Import'] = '0'
File "H:\Documents and Settings\Duncan\Application Data\XBMC\addons\script.syborg.tvguide/resources/XMLTV\configobj.py", line 567, in __getitem__
val = dict.__getitem__(self, key)
KeyError: ('Grabbers',)
-->End of Python script error report<--
20:47:06 T:3532 DEBUG: ------ Window Init (DialogKaiToast.xml) ------
20:47:06 T:1700 INFO: Python script stopped

So to get around this, I manually ran the batch file to populate the EPG which worked fine.

I was then able to load the add-on and watch channel.

Finally I went to update the channel order and logos but that scripts failed too. This is because my sqllite db sources.db is empty. How is this populated?

Sorry for all the problems.
Hi, sorry to add to the confusion but I'm having some problems too, I have tried reading the thread but not found anything that helps so far.. maybe a status label could be added to the first post!?

I have sky go running fine through chrome and ie11 but, with the advanced launcher and both plugin methods, i get as far as "loading player" and just get a blank screen, if i backspace from there I get the sky go website which is not showing as logged in (so I do) then page elements fail to load and I get script errors. Judging by the posts in this thread this project is still active!? is there another plugin I should try?

frodo 12.2

I'm not looking for individual help, just providing some information in the hope that it will help with fixing the issue.

I think I have found something, sky says here That Internet Explorer 8 or above, Firefox 3.5 or above, Safari 4.0 or above are supported.

I have checked through the xbmc plugin which does support silverlight but identifies itself as ie7. maybe this has something to do with the issue that some of us are experiencing!?
So I'm thinking of rebuilding the PC I have so that the system drive is named C rather than H (Which will fix my problems).

Syborg, if you don't want me to do this and instead keep working on getting it working on a H drive then let me know before the end of the week. I'm only asking really for other users who are in the same position as me who aren't in a position where they can easily rebuild the PC.


Hi idiot guide please new to this so stuck downloaded the 3 in the first page put the other 2 in c: xbmclauncher, made sure i have updated silver and windows explore. still nothing please help.

Thanks doing