Kodi Community Forum

Full Version: [SOLVED] HD Audio Bitstreaming
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello folks, I am a long time user of MPC-HC and I decided I wanted to dive into the world of GUI based media center applications. I used to use XBMC way back in the day on my original modded Xbox and loved it, so I thought I'd give it a go. My set up is as follows:

Windows 7 x64
RadeonHD 6950 w/ Catalyst 12.10
Onkyo TX-NR509 AVR

I am connected to the AVR via HDMI. My problem is that I cannot get Dolby trueHD or DTS-HD MA to bitstream. I am able to achieve perfect bitstreaming using MPC-HC with the ffdshow audio decoder so I know my hardware is capable, it's just a matter of getting XBMC to do so. My audio settings in XBMC have HDMI selected, speakers set to 5.1, all settings for Dolby/DTS capable receiver ticked, and passthrough output device is set to WASAPI HDMI. With the WASAPI HDMI setting, I am unable to get any audio at all during playback (even regular DD5.1/DTS tracks). If I set passthrough output device to DirectSound HDMI, I get DD5.1/DTS playback but trueHD and DTS-HD do not play and the video stutters badly. I've tried every combo of settings in the XBMC audio settings but I can't get it to work.

Anyone have any ideas as to why this isn't working?
Did you install latest xbmc frodo nightly version?
(2012-11-23, 21:14)Martijn Wrote: [ -> ]Did you install latest xbmc frodo nightly version?

Yes, I tried both the beta1 repack and the latest nightly. Same issue with both.

I should add that if I set Audio Output Device to WASAPI, I get no sound whatsoever. My receiver doesn't even recognize it is getting an audio stream.
Hi and welcome to the forums.

Please take advantage of the forum's search feature, because this topic has been covered quite extensively. Numerous threads highlight solutions, including having all settings selected correctly, compatible hardware, etc...
Sorry, I should have done a more thorough search before posting my question. I was able to solve my issue by using the AMD HDMI Audio driver instead of the Realtek HDMI Audio driver. Bitstreaming works perfectly now.
Awesome! Glad it was an easy fix for you!