Kodi Community Forum

Full Version: Can't Find USB Drive Connected to Computer
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Greetings and thanks in advance for any help. I am new to XBMC (11.0) and a novice Ubuntu user (12.10). I thought it would be a great idea to use an inexpensive computer as a media box. So far, not so good.

Ubuntu, runs, installs, as does XBMC. However, XBMC won't find any of my media locations. I store media on 2 large USB hard drives. Both are NTFS formatted, if that makes a difference. Ubuntu itself can locate both drives in the file explorer and I can play media off both of them.

When I am in XBMC, I going to Add Media Source and click on Browse, I get the window where you can chooses sources. The only sources I get that are on my computer is one partition of an NTFS drive inside the PC case and the Ubuntu Home folder. I can't see anything else useful aside from network locations.

I am really at a loss here as I can't find a solution from search.

Please save me from being a douche playing files using VLC using my wireless mouse Tongue I would really like to use XBMC and the lovely phone remote which works, even though I can't add media.

Once again, thanks in advance.
Looks like you have to mount them via XBMCBUNTU.. Good luck
Thanks for the reply. I am not sure/convinced how XBMCbuntu will make a difference. Is XBMCbuntu not just XBMC running in a slimmed linux shell which no accessible background OS? How would I mount those drives in XBMCbuntu rather than XBMC for Linux?

I will try XBMCbuntu. I chose the setup I have in order to run a browser and torrent client in the background as well.

Your USB drives should be listed automatically when you select Videos > Files or Music > Files. If not, then try adding a new source and, on the Browse list, select "Root filesystem", then scroll down, locate and select "media" and your USB drives should be listed there.

Keep in mind that if you hot-plug your drives while the system is already up, it may take a while before they are mounted, especially if they are high-capacity drives with large numbers of files on them. If you already see the drives in Ubuntu, you should be able to see them in XBMC as well.,, just try looking in the root filesystem as noted above.
XBMCbuntu wont load the usb-storage driver automatically if you leave the usb-hdd/keys plugged into machine from cold boot.

try issuing modprobe usb-storage while drives are plugged in to see if they show up in the location where artrafael said Videos>files or Music>files.

Provided the filesystem is compatible (you may need to install ntfs3g in linus if you want to access NTFS formatted drives anyway.

I too face the same problem on 12.10, but not on 12.04.
Maybe it has something to do with the way ubuntu mounts the external drives?
In 12.10 it gets mounted under /media/username/pendrive and does not show up in the add source menu nor in the "files" option.
in 12.04 it gets mounted under /media/pendrive and instantly shows up in the "files" option
refer this for illustration: http://forum.xbmc.org/showthread.php?tid=143237
any workaround/fix for this?

Ah, that's probably it (the change in mountpoint). Maybe try creating a symlink back to the old-style mountpoint and see if XBMC will recognize it?
sudo ln -s /media/username/pendrive /media/pendrive

EDIT: Updated code above to use sudo.
Thanks guys, I could find the drivers through the root file structure. Ubuntu noob, as I said.