Kodi Community Forum

Full Version: Stereoscopic 3D support for half/full SBS, over/under, etc
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
3D on XBMC 13 ALPHA 7, windows.
hey, found a bug :
theres a problem with the audio output:
when on hdmi or optical mode, the 3d movie fast forwards wiith no sound,somewhere along the middle of the movie it sets up right.
when i change to analog the movie works fine.. hope for a fix soon.other then that subtitles work great!
Quote:when on hdmi or optical mode, the 3d movie fast forwards wiith no sound,somewhere along the middle of the movie it sets up right.
when i change to analog the movie works fine
What audio codec does your file have? What are you playing audio to (direct to tv? to amp?)
I have a problem: when XBMC detects the 3D movie and i select anaglyph (red/cyan) it plays in 2D, not anaglyph. Tried several movies but all plays in 2D.
(2013-09-15, 01:49)nickr Wrote: [ -> ]I thought the response you already got was clear enough. Use both tags.

It WAS clear, it was just not correct. You CAN'T use both tags. You need TWO separate tags (at least) for Gotham, however the skin will only handle ONE. For example, if I choose to name my SBS (.3dbd) <---- the code my skin recognizes, I can then tell Gotham to use .3dbd as the tag for SBS. But If I then tell Gotham that (.3dtab) is the tag for O/U, Gotham will see it is 3d, but the skin will not. The skin only recognizes ONE tag, while Gotham requires MORE than one. So if you assign Gotham to recognize TWO tags, only ONE of those tags will be recognized by the skin. I am SURE there is a way to re-code the skin to allow for more tags, but my point was that it would be nice if there were several "universal" tags that work on everything, so you don't have to rename all your movie tags if you switch skins, or rewrite the skin code, or are forced to use the same skin on each system. I have 3 systems and I use a different skin on each.
So are you saying that including .3dbd.sbs won't

(a) signal the skin that it is a 3d movie; and

(b) signal xbmc that it is a sbs movie?
Hmmm. only one way to find out I guess? I was just going by the documentation. I figured if they say that I must use a particular tag, that none others would work.

So apparently using .3dbd.ou does still trigger the skin, I guess having 3dbd in the tag somewhere is enough? I did have to remove and re scan the movie with the new .3dbd.ou tab into the library and it also removed the "watched" status... But I guess that is not such a bog deal as any new movies I add will no be affected like this.

I placed <stereoscopicflagstab>3dbd.ou</stereoscopicflagstab> in advanced settings.

However, Gotham did say "Playing in 2d monoscopic" when I started playing the movie, but it is still playing as split screen (only for the O/U movie with the .3dbd.ou tag). Clearly it recognized it as 3d, and it also attempted to play it in 2d, but I think it is still viewing it as a SBS as the video is still split top to bottom, but I can only see the left half of the movie. I'll have to mess around with it and see if I can fix this. Thanks for the help.
um, if you are trying to watch a 3d H-SBS file in 2d mode, then that is what you will get...

in which case, xbmc is just playing the file, nothing fancy here... unless maybe subtitles and menus changing positions??.

if your display device supports hsbs/hou, and you manually set display to 3d, then you should get 3d effect with glasses etc, using the 2d mode.

at least that is my understanding of what the 3D functionality integrated within Master builds entails.

D.
I think your problem lies in the advancedsettings. You have defined 3dbd as sbs file and 3dbd.ou as tab file. In this case 3dbd.ou will be treated as sbs also.
(2013-09-16, 20:58)szape Wrote: [ -> ]I have a problem: when XBMC detects the 3D movie and i select anaglyph (red/cyan) it plays in 2D, not anaglyph. Tried several movies but all plays in 2D.
We need more infos on this. Which platform are you using? I suppose Windows with DXVA enabled. Please disable DXVA in settings and test again. AFAIK there currently is an issue with DXVA not processing the anaglyph stuff.
(2013-09-17, 07:49)da-anda Wrote: [ -> ]We need more infos on this. Which platform are you using? I suppose Windows with DXVA enabled. Please disable DXVA in settings and test again. AFAIK there currently is an issue with DXVA not processing the anaglyph stuff.

You're right, latest nightly build under Windows 7 x64 with DXVA2 enabled. Turned off DXVA, anaglyph works but stutters, so i have to wait for the video acceleration to work. Thanks for your suggestion and support and all of your work!
szape - out of curiosity, what brand and model is your GPU? I suppose some older AMD with legacy drivers?
(2013-09-17, 07:00)baijuxavior Wrote: [ -> ]I think your problem lies in the advancedsettings. You have defined 3dbd as sbs file and 3dbd.ou as tab file. In this case 3dbd.ou will be treated as sbs also.

See? This is my problem all along. It seems as if there is no way to tell your skin to recognize 3d movies (for 3d covers) AND tell Gotham to recognize them. Unless you have only one format for all your 3d movies. I guess for now, one is stuck with either having Gotham recognize 3d, OR having the skin recognize 3d, but not both.
@tommymsw - there is work in the pipes for 3D flags in XBMC that skins can use
(2013-09-17, 17:39)da-anda Wrote: [ -> ]szape - out of curiosity, what brand and model is your GPU? I suppose some older AMD with legacy drivers?

I have a HP microserver N36L with AMD ATI HD6450 PCI-E video card. Not legacy driver, i think the version is 13.4.
I got it all working now I think. My skin allowed for 2 3D tags, so I have the sbs as .3dbd and the O/U as just .3d... The I have the proper settings in advanced settings. Smile