Kodi Community Forum

Full Version: Stereoscopic 3D support for half/full SBS, over/under, etc
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Can you post a screen shot?
we had the issue described with DXVA renderer IIRC, but never with anything OpenGL or the PI.
(2014-07-28, 14:02)baijuxavior Wrote: [ -> ]Can you post a screen shot?

I've hooked it up to my non-3d tv to make sure the 2d is rendered properly (which it isn't Wink)
The first screen is from the build (compile date is blocked, but the same as my prev. post).
The second shows when 2d is activated and the video is squeezed.
The third shows the output when 3d is activated.
I hope this helps you helping me!

Image

Image

Image
(2014-07-28, 18:45)da-anda Wrote: [ -> ]we had the issue described with DXVA renderer IIRC, but never with anything OpenGL or the PI.

How was it solved back then?
AFAIK it was a bug in DXVA renderer, but as this renderer is independet form OpenGL I don't think it could be the same issue
Unfortunately this brings me back to my main question: Now what?
sorry, can't help with that. Best would probably be if you could provide a sample of that video so that devs could more easily test/debug what's going on. Sample has to cause the same issue for you ofc or it would be useless Wink
Allright, I'll try to get my hands on a sample. Sadly it's going to be a post-weekend job for me Tongue
Possible issue in incorrect aspect ratio for Full SBS/TAB content?
The resolution is 1920x1080 (this is when showing the two screens side by side, in VLC, so not converted in any way). Can it be that the 3D>2D conversion is only for Full SBS? I thought HSBS was the contenttype to use.
Where is your sample?
(2014-08-01, 09:14)Trupke Wrote: [ -> ]Allright, I'll try to get my hands on a sample. Sadly it's going to be a post-weekend job for me Tongue

(2014-08-01, 13:29)nickr Wrote: [ -> ]Where is your sample?

Will get to it ASAP, but I have a busy weekend ahead. BTW, where to UL it?
Dropbox?
Here is the link to the sample file. I've tested it and it has the render-problem as described before:

SAMPLE FILE
@Trupke thanks for the sample. Sample itself seems fine, it's at least working for me on both Windows and the PI (I'm running a experimental newclock4 build atm)