Kodi Community Forum

Full Version: Stereoscopic 3D support for half/full SBS, over/under, etc
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Thanks, I'll see how I go.
@da-anda
Tried that build and it does not solve the issue in http://trac.xbmc.org/ticket/15322#comment:6
reads like this is a more generic issue in a way that Kodi doesn't reset the meta data/settings of the videos properly
Milhouse was so kind and included my 3D Playlist PR in his latest experimental OE build for the PI - see here for details and download link: http://forum.xbmc.org/showthread.php?tid...pid1777504
Hi all,
searching for NVIDIA 3D Vision support I found this thread
where in the past afedchin released an xbmc version with this support.
I tried to download it without success, the links are all offline Sad

Someone can redirect me to an updated version of this mod?
anybody in here using a RaspberryPI and running a recent Milhouse nightly from http://forum.xbmc.org/showthread.php?tid=192380 ? If so, could you please test playlist handling of stereoscopic videos? Following needs testing:
- configure Kodi to use preferred stereoscopic playback mode (no ask dialog)
- set preferred stereoscopic mode to "auto detect / same as movie"
- allow refresh rate adjustment to match video (required for 3D mode switching)
- disable any 3D-mode handler addon that triggers 3D mode in case you use it on the PI
- create a video playlist of videos with mixed modes (sbs, ou, mono, sbs, sbs)
- play the playlist and report if 3D mode switching is working correctly for you

Unfortunately my LG seems to have issues with the current way we switch resolutions (first refresh rate switch and then immediately 3D mode switch) - so I can't test if the feature itself is working in general or not. I assume it's just my TV, but I need verification by others.
Is there a way to circumvent the frame-packed 3D restriction by enabling FullSBS support? At least then there would be no loss of quality involved.
There is no frame-packed restriction as such in XBMC. If you look around here there are windows builds that do it, on certain nVidia cards with appropriate drivers.

What doesn't work in mythtv is MVC decoding, because ffmpeg doesn't do MVC decoding, and XBMC is based on ffmpeg.

There are also instances of FSBS (and presumably HTAB) working on mythtv, and if you look you'll find a thread about that.

The difference between MVC (an encoding technology) and frame-packing (an output technology) is little understood it would seem.
so nobody willing/able to test my above request? Well, seems there is no demand for fixing this then - will close the PR
I could try and test, but 3d TVs are LG - are you wanting testing on LG or on other TVs?
Frame packed used to work fine when i added it. You only needed to add a custom resolution with the right dimensions on linux. Ive not followed what have happened since then though.
@nickr - please test as any testing is welcome. My LG is also a quite old model (no smart TV yet) and I bet at least one of your's is newer. And even if not - please test and if it's only to confirm that there are issues for whatever reason. Thanks.

@elupus AFAIK nothing changed as nobody is working on this. The experimental changes done by Popcornmix are only in experimental PI builds.
Is there a particular build to try?
as stated above - pick any recent build from http://forum.xbmc.org/showthread.php?tid=192380 - they all contain this patch.
I'm just trying to watch full over under movie (1920x1600), but without any success. I tried:
- remux with setting 1920x1600 in mkv. In this case I have always wrong aspect ratio and wrong proportions.
- remux with setting 1920x1080 in mkv. In this case, aspect ratio is correct but it won't help. When I set 3D as interlaced in Kodi, it converts video to 3d incorrectly (there are many horizontal lines and no 3d effect at all). When I set to over - under and set my monitor to 3D mode over-under, still aspect ratio in 3D mode is wrong. I need to set pixel ratio to 1.20 to get correct video.

So, in summary, for full over under:
- I need to remux it with 1920x1080 size in mkv (why?) to have any chance for success
- Even if I do this, interlaced 3d mode is completly useless (but aspect ratio in 3d mode is ok).
- Over Under mode in this case is useless too, I need to correct pixel ratio manually.

Are you sure that all is ok here? I can share sample for testing (if needed).

[edit]
I just noticed, than I need to remux with 1920x800. But still interlaced mode generates incorrect output (it's actually only a little incorrect, but annoying). I need to use over under mode to get full featured 3d effect. There are no problems like this with regular half ou movies.