Kodi Community Forum

Full Version: XBMCBuntu not liking my audio encoding
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
In short, I have XBMCBuntu up and running on a Zotac ZBox ID41 and I have Audio over HDMI working partially.

AAC audio encoded streams seem to work perfectly fine, I get audio out of my TV over HDMI.

Both AC-3 and DTS encoded streams however, do not work, I get "Failed to initialize audio device" and, of course, no audio output.

Any suggestions or commands I need to run to provide you guys with more info?
I seems your passthrough audio device is wrong. Try fixing it or turning off passthrough for ac3 and dts.
How would I go about fixing it?

I've tried doing both this: http://wiki.xbmc.org/index.php?title=HOW...controller

and this: http://forum.xbmc.org/showthread.php?tid...+xbmcbuntu

and I still can't get it working. There's a few other things I'm going to try today but the more ideas I get thrown at me the better chance that something will work.
Does your TV support AC3 and DTS decoding?
if not, just disable AC3 and DTS capable receiver
(2012-12-14, 16:55)wsnipex Wrote: [ -> ]Does your TV support AC3 and DTS decoding?
if not, just disable AC3 and DTS capable receiver

Something I did not think of (I'm don't know much about media centers or home theaters, more on the computer system side of things). That being said, disabling AC3 and DTS capable receiver makes perfect sense as it's just a pretty standard 60" TV.

Disabling them fixed it, and I now feel dumber for not realizing that earlier, they were both enabled by default so I just figured they would be fine.

Thanks for the help.

EDIT: I would +rep you, but I can't figure out how...
DTS would be iffy but I would be surprised if the TV didn't support AC3 since it is the audio codec used in HDTV and should be standard.
It's a pretty old TV, an early generation 60" Plasma, it's the LG 60PC1D.

That being said, I tried a mixture of both AC-3 and DTS when I had XBMC set to AC3 and DTS capable receiver, and neither one of them worked.
you can't +1 yet, because you don't have enough posts
glad it works now