Kodi Community Forum

Full Version: Comskip for Linux released
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
Ok folks,

i managed to get this working.

i'm on openelec 2.99.5 (RC5) with xbmc 12.0

i've got comskip working as post-processing script after tvheadend did the recording. comskip outputs 2 files for me. one EDL and one TXT.

The EDL contains the cutmarks in typical comskip format:
1837.84 2552.44 3
3369.04 3916.56 3
4354.92 4430.04 3

The TXT contains the cutmarks in typical Frame format:
45946 63811
84226 97914
108873 110751

i know xbmc reads the edl if found. i can log this in xbmc.log:

DEBUG: ReadEdl - Read 3 cuts and 0 scene markers in EDL file: /media/Volume/Recording/xxx.edl
DEBUG: AddCut - Pushing new cut to back [00:30:37.840 - 00:42:32.440], 3
DEBUG: AddSceneMarker - Inserting new scene marker: 00:30:37.840
DEBUG: AddSceneMarker - Inserting new scene marker: 00:42:32.440
DEBUG: WriteMplayerEdl - Mplayer EDL file written to: special://temp/xbmc.edl

But xbmc does not skip the commercial....... why not?
How are you accessing the file? Locally, over SMB, over NFS, via the PVR client's "Recordings" option...?

I don't think EDLs work in every scenario - some as bugs (there were issues with SMB, IIRC) and some as functionality.

You might find that accessing the file in a different manner would get a different result.
If you view the file using the PVR - i.e if you go into the Recordings window and play the file - the EDL file is not recognised (I believe this is because the PVR code does not yet support EDL). However, if you play the recording via the Video menu, (by creating a video Source that references the Recordings folder), you should find that the EDL files are recognised. That has been my experience anyway.
Hello cbxbiker61

I've got comskip compile succesfully and work on Ubuntu 12.04.2 but comskip creates only a *.txt (as like above) and not an *.edl of a recorded movie (mkv). What I'm doing wrong?
Check comskip.ini (probably in /etc/comskip/) and make sure you have "output_edl=1"
(2013-03-24, 20:31)Daddy_Dog Wrote: [ -> ]Check comskip.ini (probably in /etc/comskip/) and make sure you have "output_edl=1"

This is already set to 1 by default (and verified) in /usr/etc/comskip/comskip.ini
Solved. Had to create a folder /etc/comskip and link comskip.ini from within to /usr/etc/comskip.ini.
I gave it another attempt to get comskip compiled on my my NAs but it fails on the compiler not being compatible with C++11

Code:
DS211> cd comskip-0.93b/
DS211> ./configure --prefix=/usr
checking for a BSD-compatible install... ./install-sh -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... ./install-sh -c -d
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... no
checking whether make supports nested variables... no
checking for style of include used by make... none
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... none
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... none
checking for gawk... (cached) awk
checking how to run the C preprocessor... gcc -E
checking for size_t... yes
checking for working alloca.h... yes
checking for alloca... yes
checking for ANSI C header files... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for strings.h... (cached) yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking for stdbool.h that conforms to C99... yes
checking for _Bool... yes
checking whether g++ supports C++11 features by default... no
checking whether g++ supports C++11 features with -std=gnu++11... no
checking whether g++ supports C++11 features with -std=gnu++0x... no
configure: error: *** A compiler with support for C++11 language features is required.

Any ideas ?

@seminox
Can you describe in detail how to get comskip compiled for OpenELEC for me ?

Edit:
Using latest script on Ubuntu 12.10
http://pastebin.com/JDGzrXHx

Config log: http://pastebin.com/MVXrQVNi
Nobody ?
i got that too schumi2004 untill i install clang and got past that but no i get this error when ive executed this line:
make -j8

Error:
ProcessCsv.o comskip-ProcessArInfo.o comskip-LoadSettings.o -pthread -L/var/tmp/ComSkipWork/ffmpeg-1.1.1-install/lib -lavcodec -ldl -lrt -lavutil -lm -pthread -L/var/tmp/ComSkipWork/ffmpeg-1.1.1-install/lib -lavformat -lavcodec -ldl -lrt -lavutil -lm -L/var/tmp/ComSkipWork/ffmpeg-1.1.1-install/lib -lavutil -lm -largtable2
clang: warning: argument unused during compilation: '-std=gnu++11'
make[1]: Leaving directory `/home/xbmc/comskip/comskip-0.93b'
@AuXBoX
Still the same error here:

Using BuildCrossArm-4.7-2013.01.sh armv5tel
Code:
checking for a sed that does not truncate output... /bin/sed
checking for gawk... gawk
checking for i686-xilka-linux-gnu-gcc... i686-xilka-linux-gnu-gcc
checking for C compiler default output file name...
configure: error: in `/var/tmp/CrossArm-4.7-2013.01/respin/obj/binutils':
configure: error: C compiler cannot create executables
See `config.log' for more details.

Using instructions from startpost.
Code:
checking pkg-config is at least version 0.9.0... yes
checking for AVCODEC... no
configure: error: Package requirements (libavcodec >= 53.42) were not met:

Requested 'libavcodec >= 53.42' but version of libavcodec is 53.35.0

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables AVCODEC_CFLAGS
and AVCODEC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
i think you have to

Code:
cd /var/tmp
mkdir ComSkipWork
wget http://ffmpeg.org/releases/ffmpeg-1.1.1.tar.bz2
tar xf ffmpeg-1.1.1.tar.bz2
cd ffmpeg-1.1.1
./configure --prefix=/var/tmp/ComSkipWork/ffmpeg-1.1.1-install
make -j8
make install
cd ..
wget http://www.xilka.com/xilka/source/comskip-0.93b.tar.xz
tar xf comskip-0.93b.tar.xz
cd comskip-0.93b
PKG_CONFIG_PATH=/var/tmp/ComSkipWork/ffmpeg-1.1.1-install/lib/pkgconfig ./configure --prefix=/usr
make -j8
sudo make install
(2013-03-31, 05:33)AuXBoX Wrote: [ -> ]i think you have to

Code:
cd /var/tmp
mkdir ComSkipWork
wget http://ffmpeg.org/releases/ffmpeg-1.1.1.tar.bz2
tar xf ffmpeg-1.1.1.tar.bz2
cd ffmpeg-1.1.1
./configure --prefix=/var/tmp/ComSkipWork/ffmpeg-1.1.1-install
make -j8
make install
cd ..
wget http://www.xilka.com/xilka/source/comskip-0.93b.tar.xz
tar xf comskip-0.93b.tar.xz
cd comskip-0.93b
PKG_CONFIG_PATH=/var/tmp/ComSkipWork/ffmpeg-1.1.1-install/lib/pkgconfig ./configure --prefix=/usr
make -j8
sudo make install

ffmpeg did the trick, thanks.

Now i need to find out why i can't create executables for amrv5tel systems, want to run comskip on my ARM based NAS.

@cbxbiker61
Is it possible you place the binary for arm systems somewhere on the web or check Build script because i can't get it compiled (Ubuntu 21.10), not even with Synology toolchain (spksrc).
I need some guidance here getting comskip to work on my NAS, i got it running but it keeps asking for option file

Can anyone tell me how to get a proper launch line with details etc i'm kinda lost here although it's working on my nas.

Remote support is appreciated Wink

Edit:
Quote:DS211> cd /opt/comskip/
DS211> ./comskip
Comskip 0.93b.000, made using avcodec
The commandline used was:
./comskip

Usage:
comskip [-h|--help] [-w|--debugwindow] [-n|--playnice] [--zpcut] [--zpchapter] [--videoredo] [--csvout] [--quality] [--plist] [-m|--demux] [-p|--pid=<string>] [-t|--ts] [-d|--detectmethod=<int>] [-v|--verbose=<int>] [-u|--dump=<int>] [-s|--play] [--timing] [-q|--quiet] [--ini=<file>] [--logo=<file>] [--cut=<file>] [--output=<file>] [--selftest=<int>] <file> [<file>]

<cut>

Errors:
ComSkip: missing option <file>
DS211>

comskip.ini and comskip.dictonary are in /opt/comskip/etc

Test video is located @ /volume1/recordings/top.gear.mkv

Edit2:
I'm a bit further now.
I finaly got it running against a TS and MKV file but it always gives segmentation faults and unsupported codec

Code:
sage_framenumber_bug=0
sage_minute_bug=0
enable_mencoder_pts=0

Could not find the logo file.
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpegts @ 0x21dd20] PES packet size mismatch
Input #0, mpegts, from '/volume1/recordings/The-Mighty-Jungle/JimJam-The-Mighty-Jungle.2013-04-11.01-25.ts':
  Duration: 00:16:13.29, start: 72198.871178, bitrate: 3464 kb/s
  Program 1
    Stream #0:0[0x191]: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p, 720x576 [SAR 16:15 DAR 4:3], 25 fps, 25 tbr, 90k tbn, 50 tbc
    Stream #0:1[0x19b](dut): Audio: mp2 ([4][0][0][0] / 0x0004), 48000 Hz, stereo, s16p, 128 kb/s
Unsupported codec!
Segmentation fault (core dumped)
(2013-04-11, 00:16)schumi2004 Wrote: [ -> ]I need some guidance here getting comskip to work on my NAS, i got it running but it keeps asking for option file

Can anyone tell me how to get a proper launch line with details etc i'm kinda lost here although it's working on my nas.

Remote support is appreciated Wink

Edit:
Quote:DS211> cd /opt/comskip/
DS211> ./comskip
Comskip 0.93b.000, made using avcodec
The commandline used was:
./comskip

Usage:
comskip [-h|--help] [-w|--debugwindow] [-n|--playnice] [--zpcut] [--zpchapter] [--videoredo] [--csvout] [--quality] [--plist] [-m|--demux] [-p|--pid=<string>] [-t|--ts] [-d|--detectmethod=<int>] [-v|--verbose=<int>] [-u|--dump=<int>] [-s|--play] [--timing] [-q|--quiet] [--ini=<file>] [--logo=<file>] [--cut=<file>] [--output=<file>] [--selftest=<int>] <file> [<file>]

<cut>

Errors:
ComSkip: missing option <file>
DS211>

comskip.ini and comskip.dictonary are in /opt/comskip/etc

Test video is located @ /volume1/recordings/top.gear.mkv

Edit2:
I'm a bit further now.
I finaly got it running against a TS and MKV file but it always gives segmentation faults and unsupported codec

Code:
sage_framenumber_bug=0
sage_minute_bug=0
enable_mencoder_pts=0

Could not find the logo file.
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpeg2video @ 0x21efb0] 0x0 is invalid
[mpegts @ 0x21dd20] PES packet size mismatch
Input #0, mpegts, from '/volume1/recordings/The-Mighty-Jungle/JimJam-The-Mighty-Jungle.2013-04-11.01-25.ts':
  Duration: 00:16:13.29, start: 72198.871178, bitrate: 3464 kb/s
  Program 1
    Stream #0:0[0x191]: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p, 720x576 [SAR 16:15 DAR 4:3], 25 fps, 25 tbr, 90k tbn, 50 tbc
    Stream #0:1[0x19b](dut): Audio: mp2 ([4][0][0][0] / 0x0004), 48000 Hz, stereo, s16p, 128 kb/s
Unsupported codec!
Segmentation fault (core dumped)

Ok may be its my mistake. I'll try to build it on other ffmpeg.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23