Kodi Community Forum

Full Version: Setting Keyboard Shortcut to Switch Audio Output for Video Playback
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have many movies in .mp4 format, but I have been archiving more and more movies in .mkv (particularly my blu-ray collection). For some reason, my .mp4 files only play back when set for "Analog" audio output, whereas my .mkv files will play on "Analog", but sound much better on "HDMI". Before recently switching from Eden to Frodo, I had a keyboard shortcut set to switch the audio output from my Harmony remote, but that setting has been wiped out, and I can't find the original instructions on how to set that up for the life of me. If anyone can point me in the right direction, I would be extremely grateful.

Even better would be if anyone knows how I could set it up so that .mp4 files automatically output with "Analog" and .mkv files output with "HDMI". What's odd about this situation is that my only connections are HDMI (from media PC to tuner and tuner to TV). Thanks in advance for any insight or help!
So I ended up completely uninstalling XBMC including all profile data and then reinstalling...somewhere in the process the issue got fixed....go figure!