Kodi Community Forum

Full Version: No add-ons can be found
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Dear all,

I just installed (upgrade) Frodo RC3, when I try to install some of my favorite add-on's I just getan empty list from the repository
Hereby is a part of the listing of my log file
Can any one tell what went wrong
Code:
10:49:30 T:6128   ERROR: SQL: SQL error or missing database
                                            Query: select addon,version,optional from dependencies where id=667
10:49:30 T:6128   ERROR: CAddonDatabase::GetAddon failed on addon 667
10:49:30 T:6128   ERROR: SQL: SQL error or missing database
                                            Query: select addon,version,optional from dependencies where id=668
10:49:30 T:6128   ERROR: CAddonDatabase::GetAddon failed on addon 668
10:49:30 T:6128   ERROR: SQL: SQL error or missing database
                                            Query: select addon,version,optional from dependencies where id=669
10:49:30 T:6128   ERROR: CAddonDatabase::GetAddon failed on addon 669
10:49:30 T:6128   ERROR: SQL: SQL error or missing database
                                            Query: select addon,version,optional from dependencies where id=670
10:49:30 T:6128   ERROR: CAddonDatabase::GetAddon failed on addon 670
10:49:30 T:6128   ERROR: SQL: SQL error or missing database
                                            Query: select addon,version,optional from dependencies where id=671
10:49:30 T:6128   ERROR: CAddonDatabase::GetAddon failed on addon 671
10:49:30 T:6128   ERROR: SQL: SQL error or missing database
                                            Query: select addon,version,optional from dependencies where id=672
10:49:30 T:6128   ERROR: CAddonDatabase::GetAddon failed on addon 672
10:49:30 T:6128   ERROR: SQL: SQL error or missing database
                                            Query: select addon,version,optional from dependencies where id=673
.
.
.
.
10:49:31 T:6128   ERROR: CAddonDatabase::GetAddon failed on addon 1029
10:49:31 T:6128   ERROR: SQL: SQL error or missing database
                                            Query: select addon,version,optional from dependencies where id=1030
10:49:31 T:6128   ERROR: CAddonDatabase::GetAddon failed on addon 1030
10:49:31 T:6128 WARNING: XFILE::CCurlFile::CReadState::FillBuffer: curl failed with code 22
10:49:31 T:6128   ERROR: CCurlFile::CReadState::Open, didn't get any data from stream.
10:49:31 T:6128   ERROR: XFILE::CFileCache::Open - failed to open source <http://mirrors.xbmc.org/addons/frodo/pvr/win32/addons.xml.md5>
10:49:31 T:6128 WARNING: XFILE::CCurlFile::CReadState::FillBuffer: curl failed with code 22
10:49:31 T:6128   ERROR: CCurlFile::CReadState::Open, didn't get any data from stream.
10:49:31 T:6128   ERROR: Repository XBMC.org PVR Add-ons returned no add-ons, listing may have failed
10:49:33 T:5732  NOTICE: Thread Background Loader start, auto delete: false
10:49:33 T:5732 WARNING: XFILE::CFileFactory::CreateLoader - Unsupported protocol(addons) in addons://more/executable.tbn
10:49:33 T:3000  NOTICE: Thread Background Loader start, auto delete: false
10:49:34 T:1656  NOTICE: Thread XBPyThread start, auto delete: false
10:49:34 T:1656  NOTICE: -->Python Interpreter Initialized<--
10:49:34 T:1656  NOTICE: Launcher: found 1 launchers
10:49:34 T:1656   ERROR: NEWADDON Invalid Date Format ""
10:49:34 T:284  NOTICE: Thread Background Loader start, auto delete: false
10:49:35 T:4252  NOTICE: Thread XBPyThread start, auto delete: false
10:49:35 T:4252  NOTICE: -->Python Interpreter Initialized<--
10:49:35 T:4252  NOTICE: Launcher: found 1 launchers
Hi,

Did you ever get this sorted?

I'm seeing this too, tried deleting addons15, tried using the force but still no sign of the addons.

Has been working perfectly up until recently. Installed addons are fine.

thanks

Kevin
@kcarson,

Upload a copy of your entire debug log (wiki) to a public paste site such as www.xbmclogs.com and post the assigned URL here. The log needs to encompass the time period when you tried to install these add-ons.
Hi, thanks for the reply, appreciate it.

There's no useful log from when the repositories were added, I think. This had been happily working so I think something has broken since.

Now if I try to "get addons" I don't get anything returned from any repository.

Tried re-installing, although kept the profile, tried upgrading to the latest nightly. Disabled all firewalls

I'm on windows 7

I get this:

00:17:26 T:5796 ERROR: CAddonDatabase::GetAddon failed on addon 4207
00:17:26 T:5796 ERROR: SQL: SQL error or missing database
Query: select addon,version,optional from dependencies where id=4860
00:17:26 T:5796 ERROR: CAddonDatabase::GetAddon failed on addon 4860
00:17:26 T:5796 ERROR: SQL: SQL error or missing database
Query: select addon,version,optional from dependencies where id=4036
00:17:26 T:5796 ERROR: CAddonDatabase::GetAddon failed on addon 4036
00:17:26 T:5796 ERROR: SQL: SQL error or missing database
Query: select addon,version,optional from dependencies where id=9
00:17:26 T:5796 ERROR: CAddonDatabase::GetAddon failed on addon 9
00:17:26 T:5796 ERROR: SQL: SQL error or missing database
Query: select addon,version,optional from dependencies where id=5670
00:17:26 T:5796 ERROR: CAddonDatabase::GetAddon failed on addon 5670
00:17:26 T:5796 ERROR: SQL: SQL error or missing database
Query: select addon,version,optional from dependencies where id=847
00:17:26 T:5796 ERROR: CAddonDatabase::GetAddon failed on addon 847
00:17:26 T:5796 ERROR: SQL: SQL error or missing database
Query: select addon,version,optional from dependencies where id=436
00:17:26 T:5796 ERROR: CAddonDatabase::GetAddon failed on addon 436
00:17:26 T:5796 ERROR: SQL: SQL error or missing database
Query: select addon,version,optional from dependencies where id=4208
00:17:26 T:5796 ERROR: CAddonDatabase::GetAddon failed on addon 4208

logs here

http://www.xbmclogs.com/show.php?id=94220
(2013-12-07, 02:25)kcarson Wrote: [ -> ]logs here

http://www.xbmclogs.com/show.php?id=94220

It's blank.
hmm, possibly took too much. The paste is there on that id, I can see it if I browse through the archive but not when I go to the url directly.

I'll have another go and grab less logs.

thanks
OK - shorter log

http://www.xbmclogs.com/show.php?id=94366

I'm getting lots of failed dependencies - I'm guessing they aren't auto updating either.

Tried to add 1channel again - Looks like mysql is not quite right?
Its used by argustv, so it is running - what credentials does XBMC use to log in etc?

thanks

ok, the mysql 1channel ref may be something else -I see further down its sqllite, which makes more sense with the db files.
You will not get any help with any piracy addon like 1channel.
see forum rules
Sorry, bad example.
Every repository looks empty to me, including the official XBMC one. Tried forcing them.
Had all been ok until recently.
Christian, did you get this resolved?
If so, what was wrong?

Even if I add a new repository it's empty.
does anyone have a link that works for the xbmc wizard addon the one on the download page is broken
(2013-12-26, 06:23)satcabler67 Wrote: [ -> ]does anyone have a link that works for the xbmc wizard addon the one on the download page is broken

No support for that virus addon here