Kodi Community Forum

Full Version: Frodo 12.0: No internet connection
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Never had problems with the internet connection in XBMC, now I updated Frodo from RC2 to RC3 and cannot connect to the internet.

LAN connection works fine, Windows 7 on the same hardware has no such issue.

Debug log: http://pastebin.com/5QaEbBrg
All of a sudden it is working now...
Same here... after entered on console and did a ping to google, all is working fine.
Unfortunately the problem occurred again a few days ago, now I cannot update to Frodo 12.1.
Here's the debug log:

http://pastebin.com/YmLCS7LD

I have already tried to disable DHCP and set proxy on and off again without any success.
Internet connection is working fine in XBMC 12.0 under Windows on the same machine...

Here's the result of ifconfig:

Code:
eth0      Link encap:Ethernet  HWaddr f4:6d:04:e4:d0:23
          inet addr:192.168.0.44  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::f66d:4ff:fee4:d023/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:300 errors:0 dropped:0 overruns:0 frame:0
          TX packets:161 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:26417 (26.4 KB)  TX bytes:33717 (33.7 KB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:320 errors:0 dropped:0 overruns:0 frame:0
          TX packets:320 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:24276 (24.2 KB)  TX bytes:24276 (24.2 KB)
Have you tried assigning the IP address statically? I don't know as I don't really understand how to read the XBMC log files. While I honestly have no idea for sure, I'm leaning moreso towards it being an issue within Linux or or possibly your router since XBMC doesn't (at least to my knowledge) have anything to do with the networking portion). When it's not working are you able to get a ping out from the command line or anything?

The only reason I suggest possibly doing a static IP assignment is because you're running on a private network and I've had it happen to me countless times where my router when full retard mode and starting handing out duplicate IP assignments resulting in no connectivity sporadically until I finally figured it out and statically assign literally every device in my house. It's just my shot in the dark, so don't feel as though you have to try this, I just figured if you've got the patience to try it out, it can't hurt. Smile
Yes, manual IP assignment is what I meant when I said that I disabled DHCP (;
I'm guessing you got it cased and all, but I've been known to fat finger an IP or two in my days (considering I work with them all day lol), you sure you got the right Gateway Address/DNS server address in there? Can you ping via IP address at all (such as 74.125.225.223 - google.ca)? Also (admittedly not likely to fix your problem) you could try disabling IPv6 unless you're actually using it (Based on your IPv4 address assignment I'd say it's safe to assume you're not)... Sorry, was really hoping that was the problem and I'd save the day without having to figure something else out, because this is about all I got hahah... Someone more knowledgeable might be able to give you a hand...
IPv6 is disabled in my advancedsettings.xml

But it turns out to be a DNS problem:

Code:
[email protected]:~$ ping google.com
ping: unknown host google.com
[email protected]:~$

Code:
[email protected]:~$ ping 173.194.70.113
PING 173.194.70.113 (173.194.70.113) 56(84) bytes of data.
64 bytes from 173.194.70.113: icmp_req=1 ttl=48 time=19.6 ms
64 bytes from 173.194.70.113: icmp_req=2 ttl=48 time=20.1 ms
64 bytes from 173.194.70.113: icmp_req=3 ttl=48 time=19.8 ms
64 bytes from 173.194.70.113: icmp_req=4 ttl=48 time=19.9 ms
^C
--- 173.194.70.113 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 19.600/19.901/20.146/0.221 ms

And I just noticed that localhost (127.0.0.1) is shown under Primary DNS Server in network settings... trying to fix that now...
You should be able to get away with just using your router as your dns server (although I usually use my ISP's primary and secondary and have my router as a third just because. I'm thinking if you can get your dns figured out you should be good to go Smile
I have changed network connection from within XBMCUbuntu from DHCP to fixed IP address and entered the IP address of my DSL router in the primary DNS server field, rebooted, but XBMC is still showing up 127.0.0.1 as primary DNS address.
After having switched back to DHCP also added the IP address of my DSL router in the "prepend domain-name-servers" line in /etc/dhcp/dhclient.conf, but that did not solve the issue either...
(2013-03-19, 04:22)Bobby Blixberg Wrote: [ -> ]And I just noticed that localhost (127.0.0.1) is shown under Primary DNS Server in network settings... trying to fix that now...
That seems to be the way ubuntu does it now.
Before spending more hours in trying to fix the problem I decided to re-install from scratch, updated to Frodo 12.1 without any issues.
Will be back here when internet connection fails again...
I have noticed this on openelec rc5 from the upgrade last week. internet comes and goes, weather constantly busy and no rss feeds at all since the upgrade. I have tried disabling ipv6 a couple different ways no change. I had no problems at all in rc4 in fact as soon as i upgraded to rc5 it seemed the system almost slowed to a crawl. Lan seems fine other than sometimes when it comes out of suspend mode and try to play a file it will hang up and the system says it cannot play the file and I have to reboot. I have checked the logs but do not see anything out of the ordinary. I think I will try a fresh install as well on the weekend.

Thanks,

Dave
I had suddenly exactly the same issue with XBMCbuntu v13 Gotham today. Never had this problem since Frodo and didn't change a thing with XMBC or even within the Ubuntu settings. I was just using end enjoying Gotham.

Internal LAN severs (NAS etc.) were reachable but nothing "outside". Pinging Google just gave me "unknown host".

I tried Resetting the DSL Modem an the Router. No luck.

After this i began playing with /etc/network/interfaces config.

Before:

Code:
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

After:

Code:
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet dhcp
dns-nameservers 192.168.2.2 194.77.111.24 194.77.8.1 213.73.91.35

...suddenly after lots of reboots it pinging the "outside" was possible again. I don't know if it's related to my interfaces experiments (configuring the eth0 interface and adding dns servers). Who knows?