Kodi Community Forum

Full Version: HOW-TO setup Boblight for Windows and Boblight XBMC
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10
Does anybody of you know where I can find Boblight for Windows with Lightpack support? Did not find any compiled package.
This version has lightpack support.
Really? Damn ^^ Ok I will give it a try. Thank you Smile

This is the example config from the google code page.
Just tested it here in the office without a lightpack attached. The example config gives me a error with unknown lights or somethin.
Will try to get it working at home.
This is probably the better thread to post to: I tried to delte the poswt on the other thread but couldn't do it.


I have been struggling to get boblightd to work in in system. I beleie I was able to create a correct boblight.conf file using


With the config file setup XBMC connects to boblightd and I get the light flashes but I still don't get any lighting effect when watching a movie

Here is the boblight output

c:\boblightd>C:\boblightd\boblightd.exe -c c:\boblightd\boblight.conf
ERROR: unable to make directory /home/Ian/.boblight/:
No such file or directory
(PrintFlags) starting /boblightd/boblightd -c c:\boblightd\bo
(CConfig::LoadConfigFromFile) opening c:\boblightd\boblight.conf
cygwin warning:
MS-DOS style path detected: c:\boblightd\boblight.conf
Preferred POSIX equivalent is: /boblightd/boblight.conf
CYGWIN environment variable option "nodosfilewarning" turns off this warning.
Consult the user's guide for more details about POSIX paths:
(CConfig::CheckConfig) checking config lines
(CConfig::CheckConfig) config lines valid
(CConfig::BuildConfig) building config
(CConfig::BuildConfig) built config successfully
(main) starting devices
(CClientsHandler:Tonguerocess) opening listening socket on *:19333
(CDevice:Tonguerocess) ambilight: starting with output "/dev/com5"
(CDevice:Tonguerocess) ambilight: setting up
(CDevice:Tonguerocess) ambilight: setup succeeded
(CClientsHandler:Tonguerocess) connected
(CClientsHandler:TonguearseMessage) said hello
(CClientsHandler:TonguearseSet) priority set to 128
(CClientsHandler:TonguearseSet) priority set to 255
(CClientsHandler:TonguearseSet) priority set to 128
(CClientsHandler:TonguearseSet) priority set to 255

Here is the conf file

Anyone got a config for an Lightpack (USB) version with 60 leds? I see only Adalight as Device in boblightconfigcreator.
Isnt every lightpack the same?


thats the example file from the boblight page.
That one doesnt work.
I finally got boblight to work on my computer. More magic and tenacity than I would have liked but it is working.

I noticed that the colors are not quite what they should be. Is there a way to optimze the colors?
I give up.

I made an config file, but i cant get boblightd started.

Would be nice if we could start the deamon from the windows services console, and not being configured through dos prompt. I know alot from dos, but the boblightd commands dont make any sense to me.

In the start.bat it does (clearing?) something with the com port.

MODE COM3:9600,N,8,1 >NUL

tasklist /FI "IMAGENAME eq boblightd.exe" 2>NUL | find /I /N "boblightd.exe">NUL
if "%ERRORLEVEL%"=="0" goto running

C:\boblightd\boblightd.exe -c c:\boblightd\boblight.conf -f

echo running..

For the boblight.cnf i have this:


name ambilight
channels 3
type lightpack
interval 20000
#bus 1
#address 6
#debug true

name red
rgb FF0000

name green
rgb 00FF00

name blue
rgb 0000FF

name 1
color red ambilight 28
color green ambilight 29
color blue ambilight 30
hscan 0 16.67
vscan 75 100

name 2
color red ambilight 19
color green ambilight 20
color blue ambilight 21
hscan 0 16.67
vscan 50 75

name 3
color red ambilight 16
color green ambilight 17
color blue ambilight 18
hscan 0 16.67
vscan 25 50

name 4
color red ambilight 22
color green ambilight 23
color blue ambilight 24
hscan 0 16.67
vscan 0 25

name 5
color red ambilight 25
color green ambilight 26
color blue ambilight 27
hscan 0 16.67
vscan 0 16.67

name 6
color red ambilight 1
color green ambilight 2
color blue ambilight 3
hscan 50 66.67
vscan 0 16.67

name 7
color red ambilight 10
color green ambilight 11
color blue ambilight 12
hscan 66.67 83.33
vscan 0 16.67

name 8
color red ambilight 7
color green ambilight 8
color blue ambilight 9
hscan 83.33 100
vscan 0 16.67

name 9
color red ambilight 13
color green ambilight 14
color blue ambilight 15
hscan 83.33 100
vscan 0 25

name 10
color red ambilight 4
color green ambilight 5
color blue ambilight 6
hscan 0 0
vscan 0 0

The error output


C:\boblightd>MODE COM3:9600,N,8,1  1>NUL

clear wordt niet herkend als een interne
of externe opdracht, programma of batchbestand.

C:\boblightd>tasklist /FI "IMAGENAME eq boblightd.exe"   2>NUL  | find /I /N "bo
blightd.exe" 1>NUL

C:\boblightd>if "1" == "0" goto running

C:\boblightd>C:\boblightd\boblightd.exe -c c:\boblightd\boblight.conf -f

running: wordt niet herkend als een interne
of externe opdracht, programma of batchbestand.

C:\boblightd>echo running..


When i run start.bat a few command likes running and clear arent recognized by windows, and the boblightd deamon dont get started.
You can pretty much remove all of that. You only need the commands when using an Adalight so boblight can use the com port but I dont think you have to do this with Lightpack.

In your conf channels should be 30 and not 3.

Everything else looks ok.

You can just shedule a task (Win 7 - 8,1)


and as parameter;
-c c:\boblightd\boblight.conf -f

works great for me just set it to start at system start.

Getting an error: "boblightd.exe is not a valid Win32 application ".

Edit: Checked the file. It was 0kb. Deleted all files within the directory and upacked boblightd.zip again and tried again with my config through dos prompt without the -f option.

Then i get this:


Maybe i got a wrong boblightd version?
[remove post]
Hi guys, I need to know one simple thing: is this boblight add-on (and boblight in general) fundamental to use an adalight system on XBMC?

I want to follow step by step the famous guide of adalight (the adafruit's guide), but there's no mention of boblight (except in "advanced topics" section) because they use Processing IDE instead of boblight.
Is the adalight system working on XBMC with the Processing IDE setting instead of boblight?

Pages: 1 2 3 4 5 6 7 8 9 10