Kodi Community Forum

Full Version: Frodo RC3 Mysql Issue - Tables not creating
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All,

First time post here so I'll try and give all the info for someone to help me out hopefully.

Windows 7 32bit PC with Frodo RC3 installed.
unRaid Server with Mysql 5.0.67 installed.

XBMC was working fine, but now I need to setup sharing info via DB, I followed the instructions from the Wiki:

advancedsettings.xml file is as below and has been put in C:\Users\MyUser\AppData\Roaming\XBMC\userdata\



The user xbmc has full rights to do ANYTHING it wants within mysql and can do it from ANY location (localhost, any IP, %).
Port 3306 is allowed in and out from and to any source / destination on my Win 7 PC, I have no other firewalls or restrictions on the unRaid server.
I have tested the xbmc mysql user by creating tables etc from my Win 7 PC using MySQL Workbench and it can do what it needs to: http://www.mysql.com/products/workbench/

I have tried this without doing Export / Import and also with doing it.
I have completely removed XBMC and started from scratch.

No matter what I do this happens:

First time open, 2 DBs (MyVideos75 & MyMusic32) are created but No tables / contents are created.
pre_crash_xbmc_debug.log: http://xbmclogs.com/show.php?id=27725

If I leave this and restart XBMC it crashes when starting up

post_crash_xbmc_debug.log: http://xbmclogs.com/show.php?id=27727

At this point it also created an error file called "xbmc_crashlog-12.0-RC3 Git_20130102-7a6cb7f-20130112-222423" (not sure how to get this onto the forum if needed?)

To get back into xbmc I have to DROP the databases that it created and then it just repeats the above issue.

I would really appreciate any help with this. If I have missed any info that would be useful please let me know. Also be good to know if anyone has got it to work on same as my setup.
Very odd.

This might be a solution:

Scroll down to where it says "Troubleshooting": http://xbmclgnas.blogspot.com/2011/03/se...-your.html

This is just a guess, though.
I tried following that, (some of it is out dated and doesn't apply anymore). No joy, has anyone else got any ideas please? I'm pulling my hair out because so many other people seem to have got it working and I can't see why it will not work. The whole point of me building the server was so that can be left on all the time and not a PC.

If anyone got this working in similar scenario can you tell me what procedure you followed?
Go here http://mirrors.xbmc.org/nightlies/win32/ and download a build from a week ago and install it then try, if it doesn't work go back another week and try, drop the failed databases between attempts. Once you get a working database then update to the latest build. This may or may not work, just thinking there might be a problem with the build you're on now.
Thanks Dilligaf. I'll try those but have not used nightly builds before. Do I need the .pdb file at all or just the exe?
Just the .exe is fine
Yeeeeessss! (I think) ok I went for the most recent nightly build, from scratch, so far so good, it created the DBs and the tables. Fingers crossed! I will report back how I get on.

I hadn't gone the nightly build route before because lots of messages saying only for the brave, things may not work etc.
XBMC is getting so close to release that the nightlys are real stable. If something were to go wrong then it's easy enough to go back.

I have also problems with using Mysql from Xbmc RC3.
It works fine with the musicdatabase but not with the videodatabase.
The musicdatabase is created automaticaly by xbmc at startup as xbmc_music32.
No sign of the videodatabase in Mysql.

If I try to add a video source the scanning ends at once.
Sorry but I do not have any logs at the moment because I am doing a initial scan of my music right now.
But if I remember it correct there were not much in the logs.

Any idea why music works but not video?

A debug log would be needed to determine why XBMC was unable to create/upgrade the video DB.

I'm also having this issue.

Here is the debug log


Mysql version 5.5.23

That was with the latest nightly

]I'm not sure if this is stated somewhere else, but hells if I could find it...
But I was able to peel it away from here
It's basically in the configuration of MYSQL that it won't let external devices edit it, unless you do the following
Once I did this, I was able to create the database and XBMC was able to send stuff to it

Quote:Allowing external access

Per default external access is not allowed as this is a security risk. But many tools like HeidiSQL or other external administrator-programs rely on access from the outside of your NAS.

Caution: You should explicitly check the rights of your users! All MySQL-users should have passwords!

First follow the section on “running mysql under a user with limited rights“, then follow these instructions:

Stop the mysql-server:

sh /ffp/start/mysqld.sh stop
Edit /ffp/etc/my.cnf and add a comment to the line skip-networking, so that it looks like this:

Edit /ffp/start/mysqld.sh and find the line beginning with mysqld_flags and remove “--skip-networking” between the two quotation marks. Save the file afterwards.

Of course you would change the paths to whatever the path is on your system and then poof, that should work...

Only had me reinstalling my system a couple times and killing too many hours