Kodi Community Forum

Full Version: libstagefright - Experimental hardware video decoding builds
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2013-05-19, 06:42)Triebr Wrote: [ -> ]This works beautifully on my Galaxy Nexus. Runs 1080p content over the network smoothly and synced perfectly. Great work!
Do you get any script failed errors on the n10
(2013-05-19, 10:55)batdroid Wrote: [ -> ]Do you get any script failed errors on the n10
Script errors are definitely not related to libstagefright.
(2013-05-14, 14:30)Koying Wrote: [ -> ]
(2013-05-14, 14:29)mo123 Wrote: [ -> ]Any change for a new Gotham Alpha3 hw build?
Will do this week.

Looking forward to testing it.
Also there is a new 4.2.2 firmware for the Imito MX1 as well Smile
Are you running it on Ouya. Everytime I install it gives me and error and will not allow me in. It just says working w/ a black screen. I have the libstagefright from the first page. Any ideas what I might be doing wrong? Thank you

(2013-05-16, 19:45)DiscoDave Wrote: [ -> ]
(2013-05-16, 15:09)coromi52 Wrote: [ -> ]Ant news on Sports Devil fix? Thanks

Working fine for me? Version
I haven't managed to get any video plugins or scripts working on my OUYA with this build but I've just assumed it was due to Gotham not libstagefright.
(2013-05-19, 18:56)ctarwater Wrote: [ -> ]I haven't managed to get any video plugins or scripts working on my OUYA with this build but I've just assumed it was due to Gotham not libstagefright.

Always difficult to tell without a debug log.
I will say that this development is AWESOME! I do have a question, if it can be entertained. I, like the others here, am having the known issue of XBMC crashing to the OUYA menu system when starting certain types of streams... I see, through reading, that the thought is that it is a general issue with the current state of android builds of XBMC. My confusion is that the current 12.2 apk plays all of these streams flawlessly.

I'm not seeking support on the issue as two of the addons in question are not supported here... But I am curious if there is any thought as to what the difference between 12.2 and this build could be... causing this issue. If this is still not a question I should ask... Forgive me and I understand if it needs to be deleted.

Thanks for all you do!
(2013-05-19, 19:32)natethomas Wrote: [ -> ]Always difficult to tell without a debug log.

Yeah, sorry if it sounded like a complaint, I was just commenting on the comment before mine really. I'm perfectly happy just having HW acceleration with this build.
After I followed this thread my XBMC on mk808b is playing HD flawlessly. Hats off to these guys and the folks making libstagefright.
Basically these things.
1. libstagefright build from 2/19 (Gotham alpha 1, I think). Latest ones after that dont work.
2. advancedsettings.xml to force gpu decoding
3. libstagefright patch
4. livestream patch

Not sure if skipping one or more those would still be fine, but this combination sure works. Tried this on both Finless 1.7 and Hybryd 2.2.3 with 1080p (currently on), both work. Tried it on Finless 2.1, but android 4.2.2 seemed so slow, useless.

Its just so experimental. I spent countless hours scouting these forums, freaktab, armtech for this kinda thing (operator error?). I wish/hope going forward google finds that thread as the first result for anyone looking for "XBMC android" currently.

Hope this helps someone.
(2013-05-19, 11:11)Koying Wrote: [ -> ]
(2013-05-19, 10:55)batdroid Wrote: [ -> ]Do you get any script failed errors on the n10
Script errors are definitely not related to libstagefright.

The issue was aeon NOx. Confluence works perfectly
Galaxy Nexus, stock 4.2.2 JellyBean.

The Monsters Inc. clip from http://www.auby.no/files/video_tests/ plays fine, but a 1080p trailer of The Hobbit crashes when attempting to play. The same trailer works in the non-stagefright build.

Log: http://xbmclogs.com/show.php?id=20699
Uploaded the problematic trailer here: http://depositfiles.com/files/lv54yljyh
Surely you guys already know about open source libraries for Rockchip libstagefright


does could it be of any help for us to get hardware accelaration working?
Well, it was working fine when I first tried this and I could play an 11GB 1080p movie fine, but now I any 720p+ video is choppy just like the non-libstagefright XBMC. I have no idea why it's suddenly not working, and I have no idea how to get the debug log off my phone to post here. Any ideas?

Restarted my phone and seems to be working again Smile
Hello I just tested this alpha2 build on my Samsung galaxy S3 and its is the first build wich run PERFECT Smile Both 720 and 1080 movies.

1080p 12 gb movie (1 hour and 58 min) mkv.

Chipset Exynos 4412 Quad
CPU Quad-core 1.4 GHz Cortex-A9
GPU Mali-400MP

Os: Cm 10.1 - Android 4.2.2
Test with cm kernel and siyah.

On my rikomagic mk802 iiis, only 720 is perfect yet. as soon as i get my rikomagic mk802 IV with rk3188 quad chip I will test it on that. rk3188 should be qual or faster than Exynos 4412 Quad, so maybe my mk802 IV can manage 1080, else xbmc just fit better for the exynos right now.

Keep up the good work,

Update: I testet the hobit trailer, xbmc crash.
I've got a MiniX Neo X5 (RK3066) running their latest libstagefright enabled firmware (released 5/20) and the XBMC build linked in the OP as of yesterday (5/20). I'm accessing media from a Seagate NAS. I've experimented with both NFS and SMB connections over a gigabit wired connection.

Seems I can view individual VOB files fine, but for some reason I can't get whole movies to play from the Movie Library. Same thing if I flatten or stack them from the files view. Homemade 720p video shot from my digital camera is pretty choppy as well (shows as 1080p on playback, for some reason, even though the camera is only capable of recording 720p, not sure why).

I was a bad kid and didn't pull a log last night before I gave up, but am curious if others have encountered the movie library issue with this build. I spent about 45 minutes searching yesterday, but the closest thing I found was a reference to it only working on local directories. Can anyone suggest how to do a hard map to an NFS drive in Android 4.1.1?