Kodi Community Forum

Full Version: libstagefright - Experimental hardware video decoding builds
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2013-04-20, 03:58)vel2000 Wrote: [ -> ]ONDA V972
Allwinner A31
Android version : 4.1.1
Ram 2 GB
Processor ARMv7 Processor rev 3 (v7l)
Kernel 3.3
Resolution: 2048 x 1440

Videos from http://www.auby.no/files/video_tests/ in top/down order



01. doesn't play - crashes the app - debug log here: http://xbmclogs.com/show.php?id=13005
02. plays with low framerate, between 9-10 fps
03. Only audio - no Video - stopping the video crashes XBMC | debug log 2+3 here: http://xbmclogs.com/show.php?id=13009
04. plays fine, around 30 fps
05. plays fine, 24 fps stable
06. stutters a bit, between 22-25 fps
07. starts playing, but crashes XBMC after a few seconds | debug log 4-7 here: http://xbmclogs.com/show.php?id=13012
08. plays fine - 30 fps
09. plays fine - 30 fps
10. starts playing, but crashes XBMC after a few seconds | debug log 8-10 here: http://xbmclogs.com/show.php?id=13013
This was the result with the original Onda-Firmware
Meanwhile, I modded the Archos Platinum 97 HD Firmware a little bit, to run on my Onda...and:
Now, all Videos play fine at full frame rate, no crashes, no stuttering.
Except No.2 which plays only with 10 FPS
Great work!
Ouya, running the latest Ouya firmware and XBMC alpha 2. Plays my 20GB 1080p DTS-MA rip of the Matrix as smooth as silk. Have seen it crash once (potentially lost network connectivity), whilst ffwd and rwd remain flakey.
Thank you, it did the trick ^=^.
What doesnt work (even if everybody already knows about it ) :

- DTS/AC3 passtrough (ouya firmware)
- CEC with or without the adaptater (ouya firmware)
- sound if i use CEC adaptater
- buttons from the controller (except touchpad controller and enter/back button)
- deinterlacing for livetv (available with frodo build)
- ffwd/rwd
- wifi (ouya firmware)

It's just an alpha so thank you for the hard work everyone !!!
I've updated the OP with a Gotham alpha4 build.
(2013-06-03, 13:14)Koying Wrote: [ -> ]I've updated the OP with a Gotham alpha4 build.

Good stuff, is there a change log anywhere? Thanks
(2013-06-03, 15:29)batdroid Wrote: [ -> ][Good stuff, is there a change log anywhere? Thanks
This is just Gotham alpha4, build with the libstagefright PR. So the changelog is the same as on all other platforms...
Alpha 2 did play 1080 on my rk3188 quad core tv stick. But alpha 4 wont evrn startup on my stick or on my galaxy s3
Currently, I noticed XBMC on Android crashes at startup about 33-50% of the time, due to some Android refactor unrelated to libstagefright.
If you retry, it will eventually start.
Had the same issue on my MK809II (RK3066) I'll try it again later on today!
My setup MK808 rockchip 3066 android 4.1.1 with libstagefright.

Gotham Alpha 4 is very unstable it run one time at 5 attempts. Ive tried to play stream tv from weeb.tv it crashed logs http://xbmclogs.com/show.php?id=24538 than Ive tried h264_720p_hp_5.1_6mbps_ac3_unstyled_subs_planet.mkv and it crashed again http://xbmclogs.com/show.php?id=24542 I dont have more time to test it since it is difficult to even start it.

Gotham Alpha 1 (tv stream is working fine) was way better where is the progress ?

best regards
(2013-06-03, 19:47)peras Wrote: [ -> ][...] where is the progress ?
I'll be kind and assume this is some kind of poor joke and you forgot the emoticon, right?
Tested Gotham Alpha 4. It's unstable, even after a successful start it crashes when opening some video files.
Back to 20130219 release, it's more stable.

My current setup.
MK809II/Rockchip 3066/Android 4.1.1/Custom ROM measy_u2c_finless_17_rom

720p doesn't work most of the times, lots of stutter and dropped frames
1080p works fine most of the times.

I can't seem to make it work with 720p.
And even on 1080p subtitles seem to cause more drop frames.

Keep up the good work
(2013-06-03, 20:37)peras Wrote: [ -> ]No this is not a joke Iam trying to figure out how to run GA4. Since xbmc is my favorite app.

All Gotham builds are going to be inherently unstable, and will likely become more unstable as time goes on as more features are added. This is a normal part of the development process, and is independent from libstragefright work.
Just a quick update.

Installed fine but refused to load most of the time on my ouya. The few times it loaded, it crashed within a few minutes and took me back to the ouya screen.

At no point was i able to test any videos. I have now reverted back to the previous build.
As with Batroid, I've installed on the Ouya and whilst it refused to load initially, after 5-6 attempts it eventually started. When up and running, video playback was similar to the previous release where it played smoothly although fast forward/rewind didn't work. Started playing a video and after about 5-6 minutes XBMC crashed back to the Ouya menu.