Kodi Community Forum

Full Version: libstagefright - Experimental hardware video decoding builds
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm working on the issues...
(2013-06-04, 11:34)Koying Wrote: [ -> ]I'm working on the issues...

Love your work! Cool
(2013-06-03, 19:47)peras Wrote: [ -> ]Ive tried to play stream tv from weeb.tv it crashed logs http://xbmclogs.com/show.php?id=24538 than Ive tried
Have you done something to librtmp.so on this one? It says it cannot load it...
No, file is intact. As I said before gotham alpha 1 is working fine with tv stream I can send you logs from old version. I know about quick fix for life stream for Gotham alpha 2

Quote: http://d-h.st/lQB Live stream patch - Place files into /system/etc/
set permisions to rwx and run install-recovery.sh

Is there any chance that librtmp.so is broken in GA2 and GA4 ? After work I will do more tests.
After fresh installation of Gotham Alpha 4 my librtmp.so have this MD5 checksum: 6d82c3664eb2a24865a77372c32f11c9

Btw this is log from Gotham Alpha 1 playing tv stream:
Today I tested alpha4 on my ouya: no problems at startup, but some random crash on xvid files (like buffering is not working properly and movie stops).
I've updated the build. Should solve most of the obvious issues.
After quick test I am impressed ! TV stream is working great, Ive played only one xvid lq movie it was ok. Thank you Koying for your great job.
Tested a few files and everything is running smoothly.
Just one question, did you increase the cache size?in previous builds it wouldn't go further than 25MB (more or less) and now I'm getting more than 300MB and increasing.

Keep up the good work
Not me on libstagefright, but I think caching work has been committed to xbmc globally.
Loaded the new Alpha 4 onto my Ouya earlier this evening. Best release yet - started first time, flawless playback and ffwd/rwd working a treat. Cheers!
This is the libstagefright thread Wink
I don't know what there is in those patches above our librtmp, and I won't investigate it...
I still get a split second of audio when a video has been paused for a few minutes
(2013-06-06, 10:50)tennisbgc Wrote: [ -> ]I still get a split second of audio when a video has been paused for a few minutes

I got this on every platforms. It is unrelated to libstagefright.
Guys, for anything not obviously related to HW accelerated video, please try first with a stock Android build.
If it fails the same way in the stock build, it is unrelated to libstagefright and must be reported elsewhere.