Kodi Community Forum

Full Version: libstagefright - Experimental hardware video decoding builds
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
there's an xbmc addon that can retrieve the log and post it.
@Koying, it would be nice to also have the source code posted for these binaries so others that know what they are doing can play too Smile
Tried it yesterday evening.

Streaming of 720p and 1080p mkv files from my pc (SMB) to my Asus TF300T worked.

Device: Asus TF300T
Custom Rom: Jellybean JB@Overclock Edition V03 - The Ultra Fast Rom - based on last Asus Firmware 10.4.2.13




I saw it yesterday on a friends Asus TF300T stock JB playing SMB 720 and 1080 content flawlessly even if the sound was DTS encoded..
(2013-01-18, 02:52)davilla Wrote: [ -> ]@Koying, it would be nice to also have the source code posted for these binaries so others that know what they are doing can play too Smile

Not sure what you mean... The binaries posted here reflect exactly the sources in the associated PR...

I'll update both the PR and the binaries with a new version today or tommorow (probably in a new thread, to avoid mixing up feedback)
I've been asked how to build the SW renderer version.
(2013-01-18, 09:54)davilla Wrote: [ -> ]I've been asked how to build the SW renderer version.

Oh. The SW rendering version is actually the version -1 of the PR Wink
(2013-01-18, 09:40)Koying Wrote: [ -> ]
(2013-01-18, 02:52)davilla Wrote: [ -> ]@Koying, it would be nice to also have the source code posted for these binaries so others that know what they are doing can play too Smile

Not sure what you mean... The binaries posted here reflect exactly the sources in the associated PR...

I'll update both the PR and the binaries with a new version today or tommorow (probably in a new thread, to avoid mixing up feedback)

if we could get it building on buildbot that would be great Smile
(2013-01-18, 11:09)Martijn Wrote: [ -> ]if we could get it building on buildbot that would be great Smile

Yeah, yeah... What a pressure Wink

I have a Rikomagic MK802III
This has a Rockchip RK3066 GPU and runs Android 4.1.0
I can confirm that hardware decoding is working great within XBMC when I'm playing local movies or from my NAS on the local LAN.
When I use the Channel1 or icefilms plugin the picture has so many artifacts that it's not viewable.
(2013-01-18, 11:37)Koying Wrote: [ -> ]
(2013-01-18, 11:09)Martijn Wrote: [ -> ]if we could get it building on buildbot that would be great Smile

Yeah, yeah... What a pressure Wink

In the meantime... qualcomm S4 is confirmed as working with the latest patchset in PR 1832, although adreno is complaining. I'll test the rest of the platforms in an hour or 2

W/SurfaceTexture(29882): [unnamed-29882-0] updateTexImage: clearing GL error: 0x500
W/Adreno200-ES20(29882): <process_gl_state_enables:463>: GL_INVALID_ENUM
(2013-01-15, 00:06)CK1one Wrote: [ -> ]wow...great work!!
jellyfish upto 80mbps and even the original killasample (16ref) runs smooth on my nexus7(4.1.1) Smile

...sgs3 seems laggy and tearing at the upper right corner...

nice start Smile

Finally a log for sgs3 Wink

Thanks for your work!
There is an updated build at http://mirrors.xbmc.org/test-builds/andr...bi-v7a.apk
This one should hopefully solve the "trembling" and "green bars" issue.
Note that this one is XBMC signed, so you'll have to uninstall the previous test before installing this one
(2013-01-18, 21:00)Koying Wrote: [ -> ]There is an updated build at http://mirrors.xbmc.org/test-builds/andr...bi-v7a.apk
This one should hopefully solve the "trembling" and "green bars" issue.
Note that this one is XBMC signed, so you'll have to uninstall the previous test before installing this one


OMAP4 also confirmed as working
Better on Note 2 but still losing frames on high bitrate were other players do.