Kodi Community Forum

Full Version: [RELEASE] Movie Set Artwork Automator
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38
See my post two up from yours, need to edit one file for the add on and you should be right after that
Thanks for your replies bro.
I dont see the file folder script.moviesetart in "userdata/addon_data/script.moviesetart/" 
however i do see script.moviesetart in C:\Users\Administrator\AppData\Roaming\Kodi\addons\script.moviesetart" but there is no settings.xml in it.
i have installed the addon from the first thread of that post. Is that obsolete for the current version of kodi?
If it is obsolete, where can i download the latest version for kodi v17.6
I believe the op link should be good, but will check tonight.

As for where the settings XML file is, I just pointed to where it is on a libreelec build, not sure where windows keeps it. Might be able to check that tonight too.

I guess you configured the add on.
Thanks. Looking forward to it.
Do i need to create a master folder for a given movie set and add the movies in that master folder, eg:- create folder "Aliens collection", then add all the 4 alien movies into that folder, and process? or can all the movies sit independently in the main movies folder (like we do as default).
So script.moviesetart.frodo.0.2.2.zip is the last version of this addon. But, from my quick testing, this addon does not download the artwork from the internet, but uses local artwork for Movie Sets.

As Developer for Media Companion, I use this addon, as MediaCompanion downloads the artwork either into the Collection folder ie: Mission Impossible Collection ( as long as all movies are in sub folders of this collection )
or you can set it that the movie set artwork is downloaded to a central folder, and MSAA (once set to check that folder) will pull the artwork for found collections.
(This would be ideal if your movies sit in a main movies folder)

Hope this is of help.
It worked well for my Kodi 17 "Krypton" setup. Here's the info:

macOS 10.12.3
Kodi 17.6 "Krytpon"

I keep all of my movie set artwork in a single folder so I enabled this add-on's setting Enable single artwork folder for all sets. I entered the path to my artwork folder folder in the Path to single artwork folder field. I already had my artwork named correctly as <moviesetname>-poster.jpg and <moviesetname>-fanart.jpg.

I ran the add-on and it worked. No problems at all. I did not have to edit any of its files, perform a non-standard install, or jump through any other hoops. It simply worked the first time as if it were created for Kodi 17 "Krytpon".

Just wanted to let other people who may be using the same setup as me know that it still works.

OSMC 2018.07-1 (kernel:Linux4.14.34-4-os...
OSMC running Kodi 17.6 "Krytpon"
Skin is Xonfluence V 3.3.19 from the Helly Repo

I had this running perfectly on an exactly same build for my Raspberry Pi, but after the SD card developed a bad sector I had to reinstall everything onto a new microSD card.  After getting my movies all reinstalled/populated in KODI, I installed MSSA and enabled only the ENABLE SINGLE ARTWORK FOLDER FOR ALL SETS selection and the tried to enter the path to my folder that contains all the movie set artwork.  I am unable to see the path as a selection when you can choose your path.  It only shows Home folder, NFS, Root filesystem, UPnP devices, SMB, Zeroconf browser.  Before the SD card crash it showed my Set Art entry that I made in the File Manager area of KODI.  I tried to edit the setting.xml by changing the  line <setting label="32003" type="folder" id="artwork_folder_path" default="" enable="eq(-1,true)" source="auto" /> to <setting label="32003" type="folder" id="artwork_folder_path" default="" enable="eq(-1,true)" source="smb:// Art" />.  That didn't work either.  I can't see the SMB share through the SMB selection since my share is connected to my DD-WRT router and I have been unsuccessful in getting the router/server running the proper code, but if I manually enter the address it works perfectly.  MSSA or KODI just won't allow me to manually enter the network address like it does in all the other areas of KODI.  Thanks for any help you can give.  I had this running perfectly and then a card crash and now am frustrated.  Sorry if I didn't use the right lingo to explain my dilemma, but I just an end user and have never developed anything.  Also, since my editing of the settings.xml didn't appear to work I uninstalled MSSA and reinstalled it to a fresh version of 0.2.2.
Anoyone knows how to get all your actual movie sets artworks and back them up in one folder? I did in the past but i don't remember how, i tried with this addon and others but i just can't figure out how i'd done it in the past.
I have TMM set to save all movieset artwork in each movie folder. So every movie folder that is part of a set also contains a movieset-poster.jpg and a movieset-fanart.jpg. What would be the way to go with MSAA?
(2018-11-29, 13:14)Uatschitchun Wrote: [ -> ]I have TMM set to save all movieset artwork in each movie folder. So every movie folder that is part of a set also contains a movieset-poster.jpg and a movieset-fanart.jpg. What would be the way to go with MSAA?
 You should be fine, just start MSAA and let it do his job. No further steps required.
any chance to get this working for Leia?
UPDATE: it works fine in Leia, has my moviesets incorrectly labeled!
Just used it today to get everything locally working - awesome - thank you very much for your work put in!
Hm, spoke too early. Works great on Windows Kodi 18.0 (locally, with mySQL remote). But not on Android devices (used 18.1, but tried 18.2) (phones, fire tv). It only shows empty fields (without a frame).

Plus in both instances I used a mySql (Maria5 on a Synology, Maria10 BTW does NOT work!) for supplying the information.

Any ideas what causes this I really like your add-on!
Just tried this add-on on Kodi 18.1 running on Nvidia Shield TV (Andoid TV I have several of these boxes), and it doesn't work. I do have this working on a Shield TV that is running Kodi 17.6, and everything works great there.

I uses the setting to have all the Sets Artwork download to a Central File location, if that matters. All settings are the same between the version running on Kodi 17.6 and Kodi 18.1, yet MSAA doesn't work for my in Kodi 18.1.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38