Kodi Community Forum

Full Version: VNSI versions and compatibility
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6
@uuzi: We had that already I think. Your radeon does mpeg-2 on shaders, that are not thread safe. Upgrade to tomorrows version of the fernetmenta-ppa. Go to expert settings under Video Playback and disable MPEG-2 codec in the VDPAU section.
Since Gotham update of Raspbmc, I have problems with my VDR connection. I have installed a server with yaVDR, and it uses vnsiserver3. Since Gotham, my raspbmc is trying to connect using protocol 5, so it can't connect. I have tried to install vnsiserver5 in yaVDR, but I couldn't do it without have all the packages and dependences broken (I almost had to reinstall all yaVDR to correct it all) because vnsiserver is in testing apt source. So... is it posible to use protocol 3 from client side? (vnsi client from raspbmc with Gotham).
Thanks
Gotham requires vnsiserver 1.0 or later. Future versions will be less rigid regarding protocol version.
"vnsiserver 1.0" is equal to "vnsiserver5" ?
No, they are not equal. vnsiserver5 is version 0.9.x. But both versions use protocol 5 and work with Gotham.
I'm confused. Recentenly my VNSI wouldn't connect to my server. Log states its looking for protocol 6:

Code:
Jun  5 21:37:35 Server vdr: [5446] VNSI: Welcome client 'XBMC Media Center' with protocol version '6'
Jun  5 21:37:35 Server vdr: [5446] VNSI-Error: Client 'XBMC Media Center' have a not allowed protocol version '6', terminating client
Jun  5 21:37:35 Server vdr: [5446] VNSI-Error: Clients must be logged in before sending commands! Aborting.

Don't think I changed anything.

So I recompiled from your master and its still the same. XBMC 13.1 Beta 2
Don't mix up things. You compiled vnsi addon from my master, used with Gotham, against on older version of vnsiserver.

- we are working on 14.x and there is no guarantee that m master is compatible with G releases (currently it is but this may change)
- upgrading the client (addon) may require an upgrade of server. -> my master branch of vnsi addon requires vnsiserver 1.1.0. It was supposed to be compatible with 1.0 but due to some bug it compares against a wrong version.
Hi. I am completly new into this Business. I try To get an pi Running with openelec 4.0.4 connecting To my yavdr 0.5 with stabile sources. I have read in some threads about version of vnsi and protocol but not sure what to do.

With the stable source of yavdr the version of vnsi is to old. In my mind the only version of get vnsi running is to get an alternative source or compile the correct version.

Is here someone who currently running this setup? What would you prefer? What is the correct version / git branch for openelec 4.0.4 Protocol Version 5?

Thanks
Hello!

I upgraded to xbmc 13.2 final on mac --> everythings working there using protocol version 5

I upgraded my Openlec Installation on raspberry to 4.1.5 (xbmc 13.2)
Using LiveTV my vdr server log complains about wrong protocol version 6
Openelec 4.0.7 (xbmc 13.1) uses vdr-vnsi protocol 5 --> switched back to 4.0.7 everythings OK

Is there already a protocol version 6 ??
If yes, is your vnsi server via https://github.com/FernetMenta/vdr-plugin-vnsiserver supporting protocol 5 and 6 ??

right now I'm using vnsi server from yavdr testing ppa
vdr-plugin-vnsiserver5 1:0.9.4+git20140304-0yavdr0~trusty amd64 VDR-Network-Streaming-Interface

thx for any info
martin
With version 1.1.0 of vnsiserver backwards compatibility is back. This allows that clients with a minimum protocol version of 5 can connect to the server. AFAIK version 1.1.0 is in yaVDR unstable.
Yep,

PPA yaVDR unstable holds 1.1.0
vdr-plugin-vnsiserver 1.1.0~git20140723-3f11c8e-0yavdr0~trusty seahawk1986 (2014-08-08)

Does it make sense to use this one
or shall I compile from your sources since you are on Version 1.1.0 since May 17th

Thanks for info
Will give it a try tonight

Martin
according to git sha vdr-plugin-vnsiserver 1.1.0~git20140723-3f11c8e-0yavdr0~trusty is identical to current master branch.
Hi FernetMenta,

I'm using yavdr's repos (unstable) to simplify my tests, so my backend use vdr 2.1.6 + plugin-vnsi-server 1.1.0.

With kodi RC2 as front end, all is working great, but i've some questions:

- handling a dvb-t dongle, vnsi "stream" took about 350kb/s on SD and 700/800kb/s for HD channels. This looks strange to me, expecting a larger data flow (5/9Mbps). Is vnsi plugin compressing the stream ?

Thanks
vnsi does not touch the stream other than demuxing it. how did you measure bitrate?
Pages: 1 2 3 4 5 6