Kodi Community Forum

Full Version: XBMC not installing. Help!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi all.
Here's the problem: Accidently updated my ATV2 to iOS6. Untill then XBMC worked perfectly. I was able to revert with Seas0npass and a custom IPSW to version 5.0.2 (4950). Confirmed the JB, the Firecore icon is there. Installed atv flash black 2.1. No problem. Installed Media Player. No problem. Installed NitoTV. No problem. Tried to install XBMC through NitoTV. NO WAY. "dependencies not met" errors. Tried to install through atv flash black 2.1. NO WAY. Same errors.
Can someone please tell me where did I go wrong with the XBMC installation?
Thanks a lot!
(2013-02-09, 01:41)miappa Wrote: [ -> ]Try to install threw command line:
http://wiki.xbmc.org/index.php?title=How...and_line_2

Thanks but it doesn't work. I try the first command with Putty (apt-get install wget) and I get the same errors: "dependencies not met". I get this: "The following packages have unmet dependencies:
beigelist: Depends: mobilesubstrate (>= 0.9.3353-1) but it is not going to be installed
com.firecore.maintenance: Depends: mobilesubstrate but it is not going to be installed
com.nito.nitotv: Depends: mobilesubstrate but it is not going to be installed
com.nito.sshack: Depends: mobilesubstrate but it is not going to be installed
com.nito.updatebegone: Depends: mobilesubstrate but it is not going to be installed"

Ratz!
Anyone? My ATV looks like a paperweight right now...
apt-get install mobilesubstrate

Maybe? Though this should be there After jb already!
same error here. I cant seem to get it to install mobile substrate. it acts like it does but it doesnt.
I have tried removing nitotv to reinstall i have run the apt-get -f install and nothing.


The following packages have unmet dependencies:
beigelist: Depends: mobilesubstrate (>= 0.9.3353-1) but it is not going to be installed
com.nito.nitotv: Depends: mobilesubstrate but it is not going to be installed
com.nito.updatebegone: Depends: mobilesubstrate but it is not going to be installed
com.rrr.rowmotehelper-atv2: Depends: mobilesubstrate but it is not going to be installed
com.saurik.substrate.safemode: Depends: mobilesubstrate (>= 0.9.3367+38) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Try 'apt-get -f install' with no packages (or specify a solution).
did that and it comes up saying it will install it but says 0K space will be used. Then it runs through and we start the process all over again
I ended up giving up on getting XBMC 12 installed through NitoTV on ATV 2 with 5.1.1 (iOS 6.0.1 - 10A831) because of this "Unmet dependencies" stuff (5.1.1 is a tethered boot anyway, so no great loss)

Instead, I used the same/latest Seas0nPass ( 0.8.8.10839 ) to build a 5.0.2 (iOS 5.1.1 - 9B830) IPSW and restored that. FireCore 2.1-7 on that version includes options to install PLEX and XBMC 12 (Frodo) directly from the FireCore Maintenance window. Everything works so far, although the whole reason to upgrade from Eden to Frodo was to get a fix for the fuzzy, aqua, letters that are rendered for many "forced" vobsub subtitles.

I wish I had taken a "before" picture on XBMC 11 on ATV 2 running 4.3 (iOS 4.3 - 8F455) to see if the fuzzy, aqua, subtitle letters I saw at 21:21 (beginning of Chapt 7) in "District 9" on Eden were as bad as the seemingly, slightly-less annoying rendering on Frodo.

By the way, before I gave up and went to 5.0.2, I tried both the 'apt-get' commands mentioned by Memphiz, without any good results. It also appeared that the packager/prereq code was broken because after doing an "update all" through NitoTV, my mobilesubstrate was at a level above what the code claimed was needed! Stoopid logic.
I have followed the downgrading from 12 to 11.04 and i have no background picts and my xbmc system info says im on 11 but yet the menus look like xbmc 12. Everything is marked as broken and dependencies not met.

I got around my issue of last night by finding out apple is still singing 5.02 so i re did a jailbreak and reinstall xbmc that was the only thing that worked. But now i have this issue.
Code:
wget http://mirrors.xbmc.org/apt/atv2/deb/org.xbmc.xbmc-atv2_12.0-0_iphoneos-arm.deb

dpkg -i --force org.xbmc.xbmc-atv2_12.0-0_iphoneos-arm.deb

rm *xbmc*.deb
Can i do this except replace with eden link? Because i have been having issues with frodo so i had originally downgraded. And i need the AAC to DD5.1 too.

Thanks so much guys
probably
Having the same problem on a brand new flash. There's something wrong with the package installer. Manually installing org.xbmc.xbmc-seatbeltunlock was the only way I could updatebegone to install. After that I was able to install xbmc with the --force-all option.
It seems I solved my problem.
Downgraded from 5.2 to 5.0.1.
JB again with Seas0npass
Installed NitoTv with NitoTV Installer.
installed XBMC with XBMCHUB Wizzard.
Now I have Frodo and only thing left is to check if XBMC Subtitles add-on work with Frodo.
Pages: 1 2