Kodi Community Forum

Full Version: [RELEASE] TFC.tv (Filipino) Video Addon Available
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi There
How to install TFC.tv xbmc on apple tv2
Hi aljho20,

First, you must have a working xbmc installation in your apple tv2. Here are some links that will help you do that:

Then you can follow these instructions to install the TFC.tv plugin:

Cheers and enjoy!
I am having an issue with this addon particularly the Movies. I have subscribed to the Movie Channel and when I open the TFC.tv icon I can usually get movies to stream when I first open it but when I try to test again the same movie I would then get the message One or more items failed to play please check your logs. I would try and open other movies but I would get the same message and cannot watch any movies anymore. Sometimes the movie would open but only audio and no video but most of the time I would just get this message. Sometimes restarting the modem would help but then I would just encounter the same problem.
hi xbeamer,

I could not reproduce your issue. I am always able to play the movie. It might related to the internet connection. You can try selecting the low quality in the plugin settings and see if this still happens.
Hello there good folks of XBMC. I'm sure you know that the new XBMC 13 (Gotham) has been promoted to beta. However, the TFC.tv Addon is not compatible with this new XBMC version. I will be updating the Addon to make it compatible with the new XBMC. However, this would mean that the TFC.tv addon will not work with XBMC 11 (Eden) anymore.

Edit: Well I think it will still work with Eden but it wont be install-able from the repo directly.
First of all let me thank you todits for this great addon. I have now seem to resolve my issue with movies playing audio and that seems to happen when I leave my ipad/iphone in airplay to xbmc mode. The problem I am having now is that I get a script plugin fail when I click the movie section. I can go to the subscribed shows (no problem) and that plays but that doesn't have the posters on the main page so I prefer to go to the Movies section. I rebooted my modem but that didn't help. I have encountered script plugin fail error in times past with quite a few addons and refreshing my connection from the isp end helped but I tried that and that still didn't seem to help. Is there any reason why this is happening? I know with Icefilms and 1Channel disabling the metadata seem to help but there is no option for that in tfc.tv. Thanks.
Hi guys. I realized that there are errors when accessing the shows via the Entertainment/News/Movies menu. This might be related to what xbeamer is seeing. Thanks xbeamer for pointing that out and for the kind words. I'll try to investigate this but for now, please use the Subscribed Shows to get to your shows.

Hi guys. Just made some changes. The issue should be fixed. Please update your addons. Thanks.
(2013-11-26, 05:09)janemalory Wrote: [ -> ]Hi! I just downloaded the plugin... and tried using it now... but I'm getting this error


Btw can I download videos using this? or do you know any software where in I can download. ty

I am experiencing like this since morning
any update for this?
Hi romy4321. If you just had it installed, could you uninstall and reinstall the plugin? This sometimes happens because the other required addons failed to install. It might take sometime to download and install everything including the required addons. I just tried it and it's working for me. Checked with my friends and it works for them too.
thank you very much
I noticed that every time I subscribed on premier movie, "plug error" come out, so need to wait for two days or after expiration it will come to normal
Thank you for the this addon todits.

I understand this addon is in it's Alpha stage. When do you plan to move this to Beta, or release a more stable version?

Currently, when forwarding ahead in my TFC subscription videos I will get kicked back to the beginning of the show, and I'm forced to stop and resume every time this happens. Is there a fix in the works for this?

Thank you very much!
Hi romy4321. Sorry for getting back late. I'll try to see what's happening with the premier movies. But can you confirm that this is only happening on premier movies? The other shows work for me, though. I currently don't have a premier movie subscription so, I'll see what I can do.

Hi Stivort. Unfortunately, the issue that you're experiencing is more related to XBMC. It also happens to me. What I do instead is to pause the show before I do the seek. I don't actually forward using the "forward" button and instead I seek through the stream by tapping on the progress bar but not too far from the current position. If you're on tablet, you can do this easily. Same if true if you're watching on your computer. If you're on a mini pc or raspberry pi attached to your TV via HDMI, you can use some remote controls available on the market that you can install in your tablet or phone. Yatse for Android is a good one.
By the way, XBMC 13 is on Beta 4. See if it works better when seeking through the stream.