Kodi Community Forum

Full Version: After syncing libraries, thumbnail updates are painfully slow
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hopefully someone can help me with this as I have trawled though a lot of posts and not really found a definitive answer as of yet

I have multicomputer setup at home, and this basically means I have a total of 5 machines with XBMC on, 4 are PC based, and the other is an iMac.

To serve4 all of these devices, I have a 40TB server connected to all of these machines (as well as the rest of the house) via a 24 port gigabit switch.

Everything has been running fine and each machine did a local scrape to update all of its library data, but after upgrading all of my machines to Frodo, I decided I wanted to go with a central database for my media collection (this is just video, ie TV and Movies, all music is dealt with via Sonos). So I went with the new MySQL route and that all went smoothly. Followed the multiple file export as well, as guides seemed to say that was the better option.

Once all machine had been started on the new database, I imported the library on one machine and this as expected has populated the library on all machines.

This is where I come a bit unstuck though.

Ever since I did the NEW library update, the thumbnails take forever to update on some of the machines. I appreciate that the thumbnails are now stored locally within each folder in the movie/tv database BUT it is painfully slow. I can only assume this is because each machine is accessing ALL of the thumbnails at once over the network, this is what is slowing down the machine.

So my question is this....is there some way I can have a local database for the thumbnails so each machine just accesses them as it would do if it were a standalone and not synced to other machines.

If this is possible, is there also way to have each individual machine check with a central database to make sure each machines local database is updated as films are added. Granted it wont be a pain to update each local machine with thumbnails each time but we are of course moving towards not having to do this

If I’ve missed this somewhere I apologise but would really appreciative some pointers or tips
Just a ditto here - similar set up, really slow thumbs. Check your debug logs to see if you can see what it is doing - for me there just seems to be some thumbnailing processes running insanely slow and I have no idea why...

http://forum.xbmc.org/showthread.php?tid=148941

For me I found ffmpeg errors were the likely issue - and it didn't happen with Eden....so I think it is Frodo more than mySQL related.
XBMC only loads the images once from the media folders. Then it copies them to a local cache folder on each XBMC install. Something else must be wrong. debug logs (wiki) needed.
Yep posted one in the other thread, but it got missed I think - hear it is again:

Ok - not a minimal log, but here there is a Survivor thumb that takes way longer than 10 seconds to generate: http://dl.dropbox.com/u/108804/xbmc.log

There's a bunch of ffmpeg errors around line 4477 that last a good couple of minutes.

Sorry for the length but needed to catch it in the act....
ok ill get logs tonight and get them posted
here is my log

Any assistance would be great I can se there arte a few instances of a certain movie having its chapters scanned which makes no sense to me
(2013-02-14, 20:06)Ned Scott Wrote: [ -> ]XBMC only loads the images once from the media folders. Then it copies them to a local cache folder on each XBMC install. Something else must be wrong. debug logs (wiki) needed.

After your post and also posting up my lg as suggested, I have gone though and deleted all of the thumbnails jpgs and nfo files created by the library export when syncing library across all machines...and as you suggested, they are obviously not coming from the shared drives as the speed issues still remain...so now I have no idea why the jpgs would still be loading so slow a when the machine hd their own scarped libraries they were nice and smooth and fast
has anyone in the know had a chance to take a look at my log??
Are those the files the thumbmnails are slow for?

In my log (above) - the survivor is one that failed to appear for minutes. But from yours it's hard to tell if your log really shows the actual issue.
I ran into similiar issues when frodo was in beta stage. jmarshall gave me the answer that "this is the way that its meant to be" and "there is nothing we can do about it for frodo". obviosly my mysql device (synology ds211j) is way to slow to handle the new xbmc system. that's why i had to keep eden as this slow thumbnail system which should make frodo even faster (and did, when you are on local databases but NOT on mysql) is no option at all. i hope that there will be massive improvements in xbmc 13. not everyone wants to get a high end nas or a similiar high end mysql device just to speed up things that were perfectly running on eden.