Kodi Community Forum

Full Version: [RELEASE] TexturePacker for Mac OS X (Download Here)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi,

I was hunting high and low for a copy of TexturePacker for MacOSX, but could not find one, until i was pointed to the fact I would have to compile XBMC to get a copy.

After compiling XBMC I then found out the fact it had dependancies to a hard coded path of /Users/Shared/xbmc_depends. I wanted something portable that could be part of our current skin development. After further research I managed to repoint the dependancies to the executables local folder so is now fully portable.

Hopefully this will be of use to the Mac community especially for those who wouldn't even know how to begin compiling XBMC.

You can download from here...

https://bitbucket.org/teamblackbolt/team.../downloads

Please note when running the TexturePacker it will say some warnings like...

Class SDLTranslatorResponder is implemented in both /Path/To/TexturePacker/libSDL-1.2.0.dylib and /Path/To/TexturePacker/libSDL_image-1.2.0.dylib. One of the two will be used. Which one is undefined.

I have been unable to suppress those messages, but hoping someone can fix the problem in the XBMC repo, at which point ill recompile and submit again. Other than that I have tested on Mountain Lion 10.8 and appears to work fine.

Let me know any feedback/issues
Thank you so much.
Nice. Thanks.

I wonder if those messages would go away when 32bit version is used?
Thanks, works like a charm.
Thanks.
(2013-02-18, 12:05)pecinko Wrote: [ -> ]Nice. Thanks.

I wonder if those messages would go away when 32bit version is used?

Not thiught of that, Ill have a go see if compiling 32bit fixes issue.
(2013-02-18, 18:34)EqUiNoX Wrote: [ -> ]
(2013-02-18, 12:05)pecinko Wrote: [ -> ]Nice. Thanks.

I wonder if those messages would go away when 32bit version is used?

Not thiught of that, Ill have a go see if compiling 32bit fixes issue.

After well over a hour or two of compiling on my Mac, 32bit also has the same warnings, there must be some kind of cyclic dependancy but not sure how to fix.
EqUiNoX, thanks for sharing this. I hope someone can help me get started with this. I recently started using a Mac, and I have no idea how I would actually use this. On Windows I had a .bat file that was setup to run the .exe, but I am in the dark about how to do this on a Mac.

When I run the Texturepacker executable I get this:

Code:
Last login: Tue Apr 16 09:43:58 on ttys001
Jeroens-Mac-mini:~ Jeroen$ /Users/Jeroen/Library/Application\ Support/XBMC/addons/skin.refocus/TexturePacker ; exit;
dyld: Library not loaded: libSDL_image-1.2.0.dylib
  Referenced from: /Users/Jeroen/Library/Application Support/XBMC/addons/skin.refocus/TexturePacker
  Reason: image not found
Trace/BPT trap: 5
logout

[Process completed]

That libSDL_image-1.2.0.dylib is in the same folder, is that correct?

I am probably missing some basis knowledge, but Mac's are new to me Smile
If you are doubleclicking it, don't. It needs to be run from a terminal.

I have never run it without parameters but i think it needs to be extracted directly to the media directory if you want to run it like that. Not skindir/TexturePacker or skindir/Media/TexturePacker. If you run it without parameters you get the available options

-input <dir>     Input directory. Default: current dir

Since the Mac version also has the libraries in the same directory where the TexturePacker is i'm not sure if it will also compress those libraries, probably not.

You can move the TexturePacker directory anywhere you like and run the packer with something like this from a terminal window

./TexturePacker -dupecheck -input /Users/Jeroen/Library/Application\ Support/XBMC/addons/skin.refocus/media -output /Users/Jeroen/Library/Application\ Support/XBMC/addons/skin.refocus/media/Textures.xbt
toiva, that worked perfectly Smile Cheers!
Hi,

Sorry for my silence, still settling in Vancouver, my iMac should be arriving here from the UK any day now. Thanks Tovia for guiding Jeroen. I am planning on updating how texturepacker searches for its libraries. At moment its using the path it was called from rather than the path of the executable itself. I will update it as soon as possible and let you all know once done.
Hi All,

I wonder if someone can help me, I am trying to run Texturepacker and get:

Illegal instruction: 4

Does that mean anything to anyone?

Thanks for your help
How to you exactly use this I'm trying to recompile the texture.xbt?
check the post by SpaceMonkey in this thread.
Hi can anyone give me some simpified instructions for this as im really struggling but i want to make a better build. thanks
Pages: 1 2