Kodi Community Forum

Full Version: HOW-TO:Share libraries using MySQL: Wiki Edition
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40
Quote:and created xbmc_video and xbmc_music databases

That's the problem. Go back and follow the wiki's instructions. Do not manually create any databases. Make sure to drop the existing MySQL DBs so that XBMC can create fresh DBs for you.
Code:
CREATE USER 'xbmc' IDENTIFIED BY 'xbmc';
CREATE database xbmc_video;
CREATE database xbmc_music;
GRANT ALL ON *.* TO 'xbmc';

Why are you creating the databases - the Wiki doesn't say you should be doing this. Just leave the job of database creation to XBMC. Hardly surprising you've got a problem when you go off piste. Also naming the video (with the <name> tag in advancedsettings.xml) usually causes more problems - do you really need to use a custom name prefix? If not, don't.

Also turn on debug log (wiki) and check xbmc.log for errors, or upload the log on pastebin.com or xbmclogs.com if you still can't spot the problem.

Edit: Ned beat me to it - that'll teach me to leave a post open for an hour before hitting reply... Smile
All sorted ...... as you say no need to create the databases AND especially don't use the name variable in advancedsettings.xml - the databases in mysql are redundant and I may delete them one day to keep things tidy.

One XBMC instance is now scanning my tv database ...... once it has finished then I can do the same for movies. The original databases were due for a good cleanup and so starting again will be good.

I know there will be tweaking to do afterwards but that can wait and since I've now read all of the posts in this forum I am sure that you have all run into any issues I may find.

Now I can go to the pub and enjoy a nice pint to celebrate.

Cheers, Duncan
Thank you so much for taking the time to do this, I'm sure it'll greatly benefit the community.
I need help
I got mysql sever running on synology nas 3 clients (2 windows 7 and ouya) i got them all connected to database the all working well except my 2nd instance of windows 7 my 2nd client when i go into tv show it shows poster.jpg but when i go into seasons no poster and then when i go into each season i got no fanart or thumbnails my other 2 clients display all art just not one windows 7 machine
All features work
Update libary
Watched flag
Resume
Just no tv show art on 2nd instance w7

Update
I scraped my tv collection with emm and all is working thanks anyways
With the release of Gotham can we now update mysql and if so is it just install it over 5.5?
I assume there are no changes to advancedsettings.xml either.

Was hoping Gotham would eliminate using mysql Sad
I am using mysql with Frodo 12.3 but would like to upgrade to Gotham. I have not seen a mysql connector module for Gotham yet. Is this something that will be available anytime soon?
(2014-05-17, 17:48)gwilly7 Wrote: [ -> ]I am using mysql with Frodo 12.3 but would like to upgrade to Gotham. I have not seen a mysql connector module for Gotham yet. Is this something that will be available anytime soon?

Connector module?
Module.myconnpy
(2014-05-18, 16:35)gwilly7 Wrote: [ -> ]Module.myconnpy

There's no need for any extra's, just follow the wiki.

If you already have the database, the only thing that's needed in xbmc is the reference to the database in your advancedsettings.xml:

http://wiki.xbmc.org/index.php?title=MyS...ttings.xml
since 13.0 on all clients (win7 64bit, osx ML and raspbmc) the Movies are updated, but the tvseries not. any idea?

i had a <name> tag in advancedsetting, removed, and scraping to a new database now, will see if tv series will come back. but dontwanna loose all the "seen"marks

worked all well on 12.3
(2014-05-19, 20:12)chewara Wrote: [ -> ]since 13.0 on all clients (win7 64bit, osx ML and raspbmc) the Movies are updated, but the tvseries not. any idea?

i had a <name> tag in advancedsetting, removed, and scraping to a new database now, will see if tv series will come back. but dontwanna loose all the "seen"marks

worked all well on 12.3

As long as you have an export (split files) and

<videolibrary>
<importwatchedstate>true</importwatchedstate>
</videolibrary>

in your advancedsettings.xml, you will no lose your "seen" marks.
(2014-05-19, 08:18)Raytestrak Wrote: [ -> ]
(2014-05-18, 16:35)gwilly7 Wrote: [ -> ]Module.myconnpy

There's no need for any extra's, just follow the wiki.

If you already have the database, the only thing that's needed in xbmc is the reference to the database in your advancedsettings.xml:

http://wiki.xbmc.org/index.php?title=MyS...ttings.xml

I have mysql 5.1 installed and works great in Frodo 12.3 but one of the addons I use needs the script.module.myconnpy to update to mysql but I have not seen the module available for Gotham yet.
Tell the script author they should be using JSON not direct database access.
(2014-05-19, 20:54)Raytestrak Wrote: [ -> ]
(2014-05-19, 20:12)chewara Wrote: [ -> ]since 13.0 on all clients (win7 64bit, osx ML and raspbmc) the Movies are updated, but the tvseries not. any idea?

i had a <name> tag in advancedsetting, removed, and scraping to a new database now, will see if tv series will come back. but dontwanna loose all the "seen"marks

worked all well on 12.3

As long as you have an export (split files) and

<videolibrary>
<importwatchedstate>true</importwatchedstate>
</videolibrary>

in your advancedsettings.xml, you will no lose your "seen" marks.

Wait, i have to export the database before updating to 13? Because i have over 7000 Episodes and that will create a hole lot of files for each episode...

I'm also using mSQL and was under the impression one only needed to update XBMC and voilá...Advancedsettings.xml is pointing to mySQL database with all info etc...

Guess i'm wrong >.>
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40