Kodi Community Forum

Full Version: [RELEASE] MLS Live
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
Here is my log though: https://paste.ubuntu.com/24149189/
system settings->logging then set debug on and then the individual components.
Thanks,

I had a look... its a bit odd. First, can you delete the zip-version and get the official one from the repo and try again... probably wont make a difference, but I'd like to see.

What I noticed was that your token is _WAY_ bigger than mine. Mine is about 1.5kb and yours is 2.4kb. It also looks like due to the huge size the http header buffer is getting truncated.... I had a quick look at ffmpeg and its max size is 4096 I think...

Leave it with me -- I want to talk it over with some people. I don't know why yours is so big, but anyway, I think we're all vulnerable... It might require an ffmpeg change -- I might also be able to get rid of a field (the token is duplicated)...
(2017-03-10, 05:29)micahg Wrote: [ -> ]Thanks,

I had a look... its a bit odd. First, can you delete the zip-version and get the official one from the repo and try again... probably wont make a difference, but I'd like to see.

What I noticed was that your token is _WAY_ bigger than mine. Mine is about 1.5kb and yours is 2.4kb. It also looks like due to the huge size the http header buffer is getting truncated.... I had a quick look at ffmpeg and its max size is 4096 I think...

Leave it with me -- I want to talk it over with some people. I don't know why yours is so big, but anyway, I think we're all vulnerable... It might require an ffmpeg change -- I might also be able to get rid of a field (the token is duplicated)...

Here's my log, too. Hopefully it contains the info that's useful:

https://db.tt/BT2pM8DY
Hi, thanks for the logs. I've created an AuthFix branch that I'd like the people having trouble to try out: https://github.com/micahg/plugin.video.m...master.zip.

Please let me know if that enables playback and I'll push a fix in.
Hello, all!
I'm new here, new to Kodi, new to MLS Live.
I was scrolling through Kodi's add-one and saw this plugin and immediately downloaded it. I'm a bit lost, though. It asks me for an email and password, is this like a subscription type thing? Or is a specific email and password provided here on the forums? I'm confused.
Any help would be much appreciated!
FORZA MLS!!!!
(2017-03-11, 18:15)Gtbetta35 Wrote: [ -> ]Hello, all!
I'm new here, new to Kodi, new to MLS Live.
I was scrolling through Kodi's add-one and saw this plugin and immediately downloaded it. I'm a bit lost, though. It asks me for an email and password, is this like a subscription type thing? Or is a specific email and password provided here on the forums? I'm confused.
Any help would be much appreciated!
FORZA MLS!!!!

You need to have a paid subscription to MLS Live
(2017-03-11, 03:13)micahg Wrote: [ -> ]Hi, thanks for the logs. I've created an AuthFix branch that I'd like the people having trouble to try out: https://github.com/micahg/plugin.video.m...uthFix.zip.

Please let me know if that enables playback and I'll push a fix in.

Link isn't working for me?

*edit*

Found it manually here:

https://github.com/micahg/plugin.video.m...UIFeatures

Works! YAY! THANK YOU!
Hi i'm also new to the forums. I just got the MLS live add on for Kodi 17 and I can't watch the live streams. Is that the current status of the add on? It keeps saying "unable to get stream address". I do have a paid subscription and i can view last weeks completed games just fine if that helps.
Also what does that fix do?
Hey all, first time poster. I seem to be having the same issue as above. Updated to krypton on my amazon fire tv, installed the mlslive through kodi repo, log in, choose game, choose bit rate, wheel, nada.
I see there is a fix suggested, but I am unsure how to apply it to the amazon fire tv. Suggestions? Or is a full fix being pushed shortly?
Thank you bigly!!
Yep... it seems to be a problem with the http header size. I've got confirmation that my auth fix works, so I'll merge it in.

The fix is visible on github if you really want to see it, but basically the app no longer sends the token twice.
(2017-03-12, 02:24)micahg Wrote: [ -> ]Yep... it seems to be a problem with the http header size. I've got confirmation that my auth fix works, so I'll merge it in.

The fix is visible on github if you really want to see it, but basically the app no longer sends the token twice.

Thanks again. This worked great yesterday. Seattle vs Montreal game, though, was blacked out for me here in Seattle. Last season that would have worked. Not sure if there's a way around that or not...
Im sorry im new to using Kodi. How do get that fix above? there are just a bunch of files on the link. Do i need to download each one or is their a specific one i need?
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22