Kodi Community Forum

Full Version: VNSI4 alpha
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
@ezechiel1917, I pushed some fixes. Your sample runs smooth on my system now.
@ezechiel1917

sry. The aap vdr may cause some problems (did so in my case as he loads fw in the start of vdr and my dvb device isnt ready then...)

I switched to etobi vdr

Code:
sudo apt-get -y install dvb-apps
    sudo apt-get -y install fakeroot git-core
    echo deb http://e-tobi.net/vdr-experimental wheezy base addons vdr-multipatch >> /etc/apt/sources.list
    echo deb-src http://e-tobi.net/vdr-experimental wheezy base addons vdr-multipatch >> /etc/apt/sources.list
    wget http://e-tobi.net/vdr-experimental/pool-wheezy/binary/base/e-tobi-keyring_2008.03.08_all.deb
    sudo dpkg -i e-tobi-keyring_2008.03.08_all.deb
    rm e-tobi*
    rm /etc/apt/preferences
    echo "Package: *" >> /etc/apt/preferences
    echo "Pin: release o=Debian,a=stable" >> /etc/apt/preferences
    echo "Pin-Priority: 600" >> /etc/apt/preferences

    echo "Package: *" >> /etc/apt/preferences
    echo "Pin: release o=ctvdr4" >> /etc/apt/preferences
    echo "Pin-Priority: 1001" >> /etc/apt/preferences

    echo "Package: *" >> /etc/apt/preferences
    echo "Pin: release o=e-tobi.net" >> /etc/apt/preferences
    echo "Pin-Priority: 1001" >> /etc/apt/preferences
    apt-get update
    
    sudo apt-get -y install vdr vdr-plugin-femon vdr-plugin-live
    mkdir /home/xbmc/build
    cd /home/xbmc/build
    rm -R vdr* xbmc*
    apt-get build-dep -y vdr
    apt-get source vdr
    mv vdr-* vdr
    rm -R vdr/PLUGINS/src/*
    git clone --branch vnsi4 https://github.com/FernetMenta/xbmc-pvr-addons.git
    git clone https://github.com/manio/vdr-plugin-dvbapi.git
    ln -s /home/xbmc/build/xbmc-pvr-addons/addons/pvr.vdr.vnsi/vdr-plugin-vnsiserver /home/xbmc/build/vdr/PLUGINS/src/vnsiserver
    ln -s /home/xbmc/build/vdr-plugin-dvbapi /home/xbmc/build/vdr/PLUGINS/src/dvbapi
    cd /home/xbmc/build/vdr/
    make plugins -j4 LIBDIR=/usr/lib/vdr/plugins
    make plugins install LIBDIR=/usr/lib/vdr/plugins
    rm /etc/default/vdr
    echo "ENABLED=1" >> /etc/default/vdr
    echo "SVDRP_PORT='6419'" >> /etc/default/vdr
    echo "ENABLE_SHUTDOWN=1" >> /etc/default/vdr
    echo "OPTIONS=\"-w 60 --lirc=/dev/null --video=/recordings\"" >> /etc/default/vdr
    mkdir /recordings > /dev/null 2>&1
    chmod 777 /recordings > /dev/null 2>&1
    /etc/init.d/vdr restart

apt-get install -y dh-autoreconf zip
    cd /home/xbmc/build/xbmc-pvr-addons
    ./bootstrap
    ./bootstrap
    ./configure --prefix=/usr
    make -j4
    make install
(2013-03-29, 04:06)ezechiel1917 Wrote: [ -> ]Is it possible you could share the code so I could include this debug in my compile and help FernetMenta identify stuttering of my channels?
No problem, here is the diff

Code:
--- parser.c-orig       2013-03-28 15:04:27.642355888 +0100
+++ parser.c    2013-03-28 22:18:22.154686725 +0100
@@ -90,12 +90,13 @@
   if ((buf[6] & 0x30) != 0)
     return hdr_len;

+  int64_t pts;
+
   // parse PTS
   if ((hdr_len >= 13) &&
       ((((buf[7] & 0xC0) == 0x80) && ((buf[9] & 0xF0) == 0x20)) ||
         ((buf[7] & 0xC0) == 0xC0) && ((buf[9] & 0xF0) == 0x30)))
   {
-    int64_t pts;
     pts  = ((int64_t)(buf[ 9] & 0x0E)) << 29 ;
     pts |= ((int64_t) buf[10])         << 22 ;
     pts |= ((int64_t)(buf[11] & 0xFE)) << 14 ;
@@ -164,6 +165,8 @@
   else
     m_curDTS = m_curPTS;

+  INFOLOG("%s: ID %02x, pts %09lx, m_curPTS %09lx, m_curDTS %09lx, m_Wrap %d, m_NoOfWraps %d", __FUNCTION__, buf[3], pts, m_curPTS, m_curDTS, m_Wrap, m_NoOfWraps);
+  
   return hdr_len;
}
(2013-03-29, 16:01)FernetMenta Wrote: [ -> ]@ezechiel1917, I pushed some fixes. Your sample runs smooth on my system now.

Great, this channel plays perfectly now! Cool
I've sent you some more samples to pm of other channels which are currently still stuttering. Hopefully you can fix these too Blush

Thank you very much

Ez.
ezechiel1917, yes you were right, I messed something up on the last round. It's corrected now, all your three samples run smooth. Note that I have squashed the fix to one of the last commits.
(2013-03-30, 09:27)FernetMenta Wrote: [ -> ]ezechiel1917, yes you were right, I messed something up on the last round. It's corrected now, all your three samples run smooth. Note that I have squashed the fix to one of the last commits.

so far so good, thanks again! Smile
Ez is happy, now I can come with my next issue Angel

Watching a recordings in progress has at least one issue, these silly 2GB ts-files. If playback comes to the end of one 2GB part, it get's an error (see log file) and continues with normal LiveTV. This is reproduceable and I checked it, it happens always at the end of a 2GB part.

Code:
Mar 29 23:57:10 [12117] recording to '/srv/videos/vdr/Rob_Roy/2013-03-29.23.23.11-0.rec/00002.ts'
Mar 29 23:57:11 [12994] VNSI-Error: Could not read file, size:  0
Mar 29 23:57:24 last message repeated 97 times

I can skip this position with [Big]StepForward and playback will continue until the next end of 2GB file arrives.

Btw, watching this as a recordong works flawlessly
Fix pushed.
@ FernetMenta

I cant say if it is related to any changes in the 13 - but it seems that the Nvidia GPU + Audio Engine fails from time to time, resuling in heavy stuttering and almost freezed system. I face this in normal mkvs (yesterday for example enjoying the awesome "Steel Panther - British Invasion" BD with DTS HD Wink

Only a reboot is working. I think my latest pastebins attached to this feed may help u ... but i dont knowof it is related to any changes with vdpau / deinterlacing / vnsi / vdr
DTS HD makes me think that this is related to AE. SoftAE is still borked, I get audio stream stalls on almost every commercial break. Because this bothers me most atm, this will be my next project. fritsch and I will write a new audio engine.
Two questions: I'm trying to cross compile vnsi4 for windows/ios (ios not that important but the windows one is something I'd like) on my ubuntu machine but I'm just good at following instructions and not figuring stuff out myself. Big Grin Tried to do it the same way I used to cross compile xvdr but that doesn't seem to be working.

Code:
./bootstrap
./configure --host=i686-mingw32msvc
make

Anybody got this working?

And second of all, how do I change the port for the vnsi vdr server? I tried to google and checked some bits of the source code, also found some mention of "listen_port" but I couldn't get it to change.
Why do you want to cross compile for Windows? That won't work that simple. The addon uses DirectX rendering for the VDR UI. The required dependencies are set in the Visual Studio project.

The port is defined (hard coded) in config.h. That's a heritage, I have never touched this. Might be a good idea to define a command line parameter which allows to change the default.
Thanks for that, I actually saw the port in exactly that file but thought there is a config option somewhere, I'll just recompile with different port.

Regarding cross compiling I mainly wanted to make my windows pc work with vnsi4 and couldn't be bothered to set up everything I need to compile on windows, when I tried to use the vnsi pvr addon that came with the xbmc 13 nightly it complained about protocol versions not matching, so either I'm doing something wrong on either the vdr or the xbmc addon end or it just doesn't work with the addon shipped with xbmc 13.
The nightlies still ship with vnsi3 which is not compatible. Here is a Windows version of vnsi4:
http://dl.dropbox.com/u/47522966/addon.zip
Thanks a lot, so just to make sure for next time: There is pretty much no way around setting up everything to compile on windows/ios itself instead of cross compiling on linux? (At least not for people with limited skill set)
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20