Kodi Community Forum

Full Version: Movie Scraper scrapes all files, then tries to scrape the database IDs
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm running XBMC 12.0, using a shared MySQL database. Recently upgraded to Frodo, noticed that the IMDB scraper wasn't picking up a bunch of my movies (including common ones that it should be able to identify such as Star Wars), plus it was taking a really long time to scan, so I decided to try The Movie Database scraper instead. After I switched, it picked up the rest of the movies beautifully, but then once it finished scanning the source, it then proceeded to start adding a bunch of bogus movies that I definitely don't have. When I checked the details of the movies, it was saying that the file paths were things like "videodb://1/2/684". This problem seems to occur on all three of my clients connecting to this database.

I took a look at my database, and these numbers that it thinks are filenames correspond to the idMovie column from the movie table in the database. It seems like XBMC is taking the list of movie titles to be another media source and attempting to scrape it. I've seen one other post where someone had this issue and had to recreate their entire database from scratch - I would really like to avoid that as I have almost 2 years of watching history that I would prefer not to lose.

Does anyone have any suggestions?
You somehow managed to "Set Content" on a videodb:// URL.

If you can figure out how you did it, please let us know.

To fix, edit your database and delete any videodb:// URLs from the path table:

Code:
delete from path where strPath like "videodb://%";

Cheers,
Jonathan
Thanks! That worked perfectly. I'm not sure how I might have done that. The database was updated from XBMC 11, following the howto from the wiki, and I have three clients connecting to it, all running the same version of XBMC, which were all updated to the latest version at the same time. I also attempted to connect an android tablet to it unsuccessfully a few months back, not sure if that might have affected it. Hope that helps.
I had exactly the same problem, and no idea how the weird path got in there. I didn't upgrade from 11 - went directly to 12.1.
I too have a shared DB on MySQL on another PC. The problem started about the same time as the db was changed from internal to MySQL. I restored a backup from XBMC to the new db once it was created.
Thanks to jmarshalls response the problem is gone.

Its been driving my OCD mad for days. Smile
Sorry to bring up this old thread, but I am having the same issue now.

I'm not sure how to scan through my database and remove the items with 'videodb://' as the source.

Also, would the movies not simply be re-added the next time I run xbmc? Unless you managed to find how the 'set content' is using videodb:// as a source. I have tried looking and can't seem to find it.
Just fixed my problems with this fix as well.
I used PHPMyAdmin, and ran the sql statement on the database, and problem was gone ;-)
Thanks !

Claus Hansen
I too am having issues with this. The only way I have been able to fix this is with a fresh reinstall of XBMC and MySQL. This is a huge headache for me.