Kodi Community Forum

Full Version: Startup issues with larger disks
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi. Has anyone had an issue like this or more importantly is there a resolution?

I generally build my XBMCbuntu machines using HP desktops as they are relatively generic and most of the time it just works or if there is an issue it's not hardware related. I have encountered the following issue using larger HDDs in an HP DC7700 desktop machine. I have isolated it to the HDD by a process of elimination.

If I Install a fresh build of XBMCbuntu (Eden or Frodo) on a 2TB HDD, in this case a WD Caviar Green drive, the install goes through flawlessly. On the first restart after the install has completed XBMC fires up and everything is fine. Now however, if I shutdown the machine and restart it XBMC fails to start. In fact I don't even get the Linux desktop login screen. What I end up with is a command line login request and that's it. If I log in as the xbmc user and try to start the GUI manually it just fails.

I have another HP DC7700 desktop and the problem is identical using the same HDD.

This problem also occurs if I substitute the 2TB WD HDD with a Seagate Barracuda 1.5TB HDD in either machine.

If I use a Seagate 750GB HDD everything is fine and there are no issues. No matter how many times I reboot the machine XBMC fires up great.

If I take either of the 2 large HDDs and install them in an HP 8000 Elite desktop I have no issues and XBMC works fine.

I am thinking this is more of an underlying OS issue than XBMC itself.

Any ideas as to what is causing this?
Perhaps a subtle issue with large drives, and bios? Although why they would boot once and then not again is a strange mystery.

I love those HP SFF boxes, but I have never used them with that big hard drive, and DC7100 is the latest box I have. I use them as frontend/player machines rather than servers, and use them with the hard drive they came with, plus alow profile fanless nvidia card. Cheap, but probably uses too much power for the modern age.
Yeah, it's got me stumped although I'm not all that up with Linux but I'm learning fast. The absence of any kind of error message is irritating because at least I'd then have something to base a search on. I've tried BIOS updates and looked through the BIOS settings but nothing stands out. I've tried installing XBMCbuntu with the download updates option selected and deselected and still no joy. I may just have to use the original drive as the boot drive and load XBMCbuntu on that and install the large drive as a second drive for the media storage. It's just a pain as I then have to edit config files to allow it to be seen over the network etc for loading media blah, blah.

They are good boxes and you can pick up the earlier models really cheap as most businesses send them out to auction when they've finished with them. The latest 8000 series look really good as HTPCs as the styling matches in with the rest of the home theatre gear quite nicely. I do exactly as you say with the low profile fanless video cards although the 8000 series have a 3.5 inch bay accessible from the front panel so I've installed a Crystalfontz LCD into that bay. Works great. I also mainly use my machine as a front-end box although I do load my TV episodes directly to it. I have my movies and DVD ISOs loaded onto a couple of NAS boxes elsewhere on the network.

Ha, on another note the reputation button has finally appeared as an option for me so I've given you a tick for the help you gave me last time with the NetBIOS naming issue I was having.

I'm doing a few of the DC7700 XBMC installs for the family upgrading their modified Xboxes that I installed years ago running XBMC. Unfortunately the Xboxes don't have quite enough snuff to run the HD stuff we have now hence the upgrades. Would've been nice if it had been simple. They need the larger drives as they don't have NAS like me.