Kodi Community Forum

Full Version: Strange error in latest XBMC build with Tvheadend HTSP Client
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I just updated to the latest xbmc (xvba) build from here, at the moment 'compiled MAR 20 2013'.
I know of course of the troubles that may arise with such builds. The build from the same repository I had before (FEB 13 2013) worked flawless.

This is the problem:

Code:
19:25:22 T:139870039176960  NOTICE: PVRManager - starting up
19:25:22 T:139870519936768  NOTICE: Thread PVR manager start, auto delete: false
19:25:22 T:139869988570880  NOTICE: Thread PVR add-on updater start, auto delete: false
19:25:22 T:139869988570880 WARNING: Unable to resolve: XBMC_Tvheadend.pvr ADDON_Announce, reason: /usr/lib/xbmc/addons/pvr.hts/XBMC_Tvheadend.pvr: undefined symbol: ADDON_Announce
19:25:22 T:139869988570880   ERROR: Unable to resolve exports from dll /usr/lib/xbmc/addons/pvr.hts/XBMC_Tvheadend.pvr
19:25:22 T:139869988570880 WARNING: UpdateAndInitialiseClients - failed to create add-on Tvheadend HTSP Client, status = 6
19:25:22 T:139869988570880 WARNING: UpdateAndInitialiseClients - failed to load the dll for add-on Tvheadend HTSP Client, disabling it
19:25:22 T:139870951802624  NOTICE: Thread CAddonStatusHandler:pvr.hts start, auto delete: true

Is this something that easily can be resolved, or have things really changed in the latest xbmc builds?
you're mixing up versions. if you run master (or a deritive), you need the master branch of the add-ons. if you're using Frodo (or again a deritive), you need the frodo branch of the add-ons.
I have exactly the same problem. How do I fix this Smile
that's what my previous post says. use the correct branch and follow the instructions in the README.
I don't get it. I just installed xbmc through the xvba repo (wsnipex). I presume the add-ons that came with it are in the package it downloads? How can I pragmaticly change to the correct branch? I don't get to which readme you are referering.
you installed an unsupported alpha version (13.0, xbmc's master branch). so you need the add-ons from my master branch. i guess it's built for that ppa too and if not, then you'll have to build them from source. or use the official release (12.0)
Somewhere I messed up with my ppa settings. I reverted and will test tonight if it works. According to wsnipex it looked fine..
Working!