Kodi Community Forum

Full Version: Music Videos sharing via UPnP issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Music Videos sharing via UPnP seems to be buggy in 12.1. I tried

1) XBMC 12.1 (Linux i586) -> Bubble UPnP 1.6.6 (Android)
No issues, everything is fine.

2) XBMC 12.1 (Linux i586) -> ShowTime 4.3.104 (hacked PS3)
Movies play fine but music videos not. Browsing library works but I cannot play anything.

3) XBMC 12.1 (Linux i586) -> Default UPnP client (hacked PS3)
No issues, everything is fine.

4) XBMC 12.1 (Linux i586) -> VLC 2.0.5 (Windows 7 x86_64)
No issues, everything is fine.

5) XBMC 12.1 (Linux i586) -> XBMC 12.1 (Windows 7 x86_64)
Movies play fine but music videos not. Browsing library works but I cannot play anything.

6) XBMC 12.1 (Windows 7 x86_64) -> XBMC 12.1 (Linux i586)
Movies play fine but music videos not. Browsing library works but I cannot play anything.

7) XBMC 12.1 (Windows 7 x86_64) -> VLC 2.0.5 (Linux i586)
No issues, everything is fine.

8) XBMC 12.1 (Windows 7 x86_64) -> ShowTime 4.3.104 (hacked PS3)
Movies play fine but music videos not. Browsing library works but I cannot play anything.

9) XBMC 12.1 (Windows 7 x86_64) -> Default UPnP client (hacked PS3)
No issues, everything is fine.

Linux is Rosa 2012.1 Desktop Fresh, XBMC 12.1 from repositories.
For Windows 7 XBMC is downloaded from the official site.

Debug log for #2 & #6: http://file-store.rosalinux.ru/download/...3f8b027639

Am I alone with this issue or the bug should be filed as the issue really exists for other users?
Also filed a bug in Showtime's tracker: https://www.lonelycoder.com/redmine/issues/1671
I fixed this bug. Patch is submitted to XBMC bugtracker.

http://trac.xbmc.org/attachment/ticket/1...otag.patch

Please add"[FIXED]" to thread topic.