Kodi Community Forum

Full Version: using file creation date for sorting movies by date
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I just ran the "extra artwork downloader" mod and since it created new files in the folder of all my movies then right now my whole library has the same date as the "modified date"... So it is now totally impossible to sort the movies by date and everything is messed up. The newest files doesn't comes up first when sorting by descending date

Is there a way to force XBMC to use the file's created time instead of the modified time ?

I found this in the wiki but it doesn't looks like what i am looking for
Quote:<dateadded>2</dateadded> <!-- 0 results in using the current datetime when adding a video;
1 (default) results in prefering to use the files mtime (if it's valid) and only using the file's ctime if the mtime isn't valid;
2 results in using the newer datetime of the file's mtime and ctime -->

note i am not using the library mode to display my files so xbmc is not using the date the files were added to the database
How about copying the created date into the modified date?

Here's one for Windows (I'm sure there are others):
http://www.nirsoft.net/utils/bulk_file_changer.html

On Mac/Linux you could use the "touch" command.
isn't there a way to tell xbmc to use the created date instead ? The problem will come back everytime i run the artwork downloader addon Sad
still no solution?
anarchoi

I've been wondering this too for a long time!
You have your perfect setup with the movies sorted by descending date, and then it's all messed up after some sort of change like extra artwork downloader.
Thats frustrating!
I haven't looked for a solution yet, but I will start now. If I find anything, I'll let your know in this thread Smile

EDIT: I can see that they have been discussing this since 2009, but not really sure what the conclusion was: http://forum.xbmc.org/showthread.php?tid=58525&page=11
Y'all ain't crazy! It has been driving me nuts, too. I did come across this ticket which seems to be addressing our issue. No solution yet, though.

http://trac.kodi.tv/ticket/15590