Kodi Community Forum

Full Version: Need help with most episodes not showing up
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello, I'm having problems with setting up XBMC. I had the previous version installed on my computer and got all my TV shows to show up in the library. I recently upgraded to Frodo, and I think I screwed something up (when I upgraded I deleted XBMC then downloaded Frodo and installed it, not sure if that matters).

Almost none of my episodes are listed under "TV Shows". However they are in the "Files" section under "Videos". At first I thought that maybe they where miss named for XBMC (even though I remember them being there under the older version). But when I look at the show "Elementary" some episodes are available and some aren't. Here is a list of that directory (I used a directory lister to copy and paste the files to make sure I didn't have any typos when listing the files, so this is how they are named on the hard drive)

K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e01 - Pilot [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e02 - While You Were Sleeping [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e03 - Child Predator [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e04 - Rat Race [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e05 - Lesser Evils [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e06 - Flight Risk [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e07 - One Way To Get Off [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e08 - The Long Fuse [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e09 - You Do It To Yourself [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e10 - The Leviathan [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e11 - Dirty Laundry [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e12 - M [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e13 - The Red Team [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e14 - The Deductionist [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e15 - A Giant Gun Filled With Drugs [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e16 - Details [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e17 - Possibility Two [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e18 - Deja Vu All Over Again [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e19 - Snow Angels [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e20 - Dead Man's Switch [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e21 - A Landmark Story [1080p].mkv
K:\Collections\Tv Shows\Elementary\Episodes\Season 01\Elementary - s01e22 - Risk Management [1080p].mkv

For "Elementary" I have episodes 1, 2, 6, 17, 19, 20, 21, 22 available in the "TV Shows" section, but the rest of them are not listed.

I'm not sure that when I deleted the old version everything got deleted as when I started up Frodo the 1st time my K:\collections\TV Shows directory was already listed in the files section.

I also have entries for all my shows in the "TV Shows" section with art but no episodes for almost any but maybe 5 out of 50 shows.

I don't know if I did it right but her is my debug log if it helps http://xbmclogs.com/show.php?id=18483

Thanks for any help you can give
Remove Episodes

K:\Collections\Tv Shows\Elementary\Episodes\Season 01\

to

K:\Collections\Tv Shows\Elementary\Season 01\

Why would you have a folder called Episodes?

http://wiki.xbmc.org/index.php?title=Vid...s/TV_shows
Will have a look at your log, missed it initially because I am on phone in train.

Edit: please post how you defined your sources, can you copy the content of sources.XML?
saitoh's suggestion worked on a lot, about 70% of the episodes I have, but a few still aren't showing up.

As far as how the source is defined, do you mean as a TV show using tvdb scraper (that is what I have it under). As for the sources.xml where is that, I searched in C:\Program Files (x86)\XBMC\ and the search results didn't find that file.

I think I found the sources.xml here it is

<sources>
<programs>
<default pathversion="1"></default>
<source>
<name>Roms</name>
<path pathversion="1">K:\Collections\Roms\</path>
</source>
<source>
<name>Roms (2)</name>
<path pathversion="1">K:\Collections\Roms\</path>
</source>
</programs>
<video>
<default pathversion="1"></default>
<source>
<name>Tv Shows</name>
<path pathversion="1">K:\Collections\Tv Shows\</path>
</source>
<source>
<name>Moved TV Shows</name>
<path pathversion="1">J:\Moved TV Shows\</path>
</source>
<source>
<name>Chuck</name>
<path pathversion="1">K:\Collections\Tv Shows\Chuck\</path>
</source>
<source>
<name>Movies</name>
<path pathversion="1">K:\Collections\Movies\</path>
</source>
</video>
<music>
<default pathversion="1"></default>
<source>
<name>Music</name>
<path pathversion="1">J:\Collection\</path>
</source>
</music>
<pictures>
<default pathversion="1"></default>
</pictures>
<files>
<default pathversion="1">Tv Shows</default>
<source>
<name>Tv Shows</name>
<path pathversion="1">K:\Collections\Tv Shows\</path>
</source>
</files>
</sources>
Why do you have Tvshows defined twice?

(2013-05-14, 18:02)tidle73 Wrote: [ -> ]saitoh's suggestion worked on a lot, about 70% of the episodes I have, but a few still aren't showing up.

As far as how the source is defined, do you mean as a TV show using tvdb scraper (that is what I have it under). As for the sources.xml where is that, I searched in C:\Program Files (x86)\XBMC\ and the search results didn't find that file.

I think I found the sources.xml here it is

<sources>
<programs>
<default pathversion="1"></default>
<source>
<name>Roms</name>
<path pathversion="1">K:\Collections\Roms\</path>
</source>
<source>
<name>Roms (2)</name>
<path pathversion="1">K:\Collections\Roms\</path>
</source>
</programs>
<video>
<default pathversion="1"></default>
<source>
<name>Tv Shows</name>
<path pathversion="1">K:\Collections\Tv Shows\</path>
</source>

<source>
<name>Moved TV Shows</name>
<path pathversion="1">J:\Moved TV Shows\</path>
</source>
<source>
<name>Chuck</name>
<path pathversion="1">K:\Collections\Tv Shows\Chuck\</path>
</source>
<source>
<name>Movies</name>
<path pathversion="1">K:\Collections\Movies\</path>
</source>
</video>
<music>
<default pathversion="1"></default>
<source>
<name>Music</name>
<path pathversion="1">J:\Collection\</path>
</source>
</music>
<pictures>
<default pathversion="1"></default>
</pictures>
<files>
<default pathversion="1">Tv Shows</default>
<source>
<name>Tv Shows</name>
<path pathversion="1">K:\Collections\Tv Shows\</path>
</source>
</files>

</sources>

also Post a new debub log so we can see what the problem is with the last 30%