Kodi Community Forum

Full Version: Struggling to compile in archlinux
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Getting the following error on make after sucessfully building with bootstrap and configure;

SmbFile.cpp:30:26: error fatal: libsmbclient.h: No such file or directory

This should be installed as part of cmbclient, which is installed and up to date.

I see several references to this error in various builds that people are trying to compile on their own, but can't find a solution on google or the forums.

Anyone have thoughts?

Thank you very much in advance as well.
does the tag Gotham_alpha3 give you the same error? (git checkout Gotham_alpha3) the retroplayer6 branch is based on this tag.

And heads up, i'm rebasing on the Gotham_alpha4 tag so this may fix the problem.
Try this in xbmc src directory before compiling and see if it helps:

# fix samba4 libsmbclient.h location
sed -i -e 's:#include <libsmbclient.h>:#include <samba-4.0/libsmbclient.h>:' xbmc/filesystem/{SmbFile,SMBDirectory}.cpp
Thank you both, will try later today and report back.
Wasn't able to make this work (same error). I did attempt to install a few other versions and do some more google searching. Gotham alpha 3 doesn't work, but the latest git alpha 5 compiles fine. I tried poking around the commits and it looks like this was solved in May so hopefully your rebase will solve the issue.

Thanks again for all of your efforts and the assistance, looking forward to testing this soon.
If it was fixed in may, then the rebase should definitely squash the compile bug. I'll let you guys know when I've done the rebase (branch retroplayer7 will appear in my repo)
Hey guys,

I finished the rebase and a new retroplayer7 branch has been pushed to my repo. It's based on an unstable nightly version (2013-6-16) of Gotham alpha 5 (even though it says alpha 4 in the system info screen). I hit a couple road bumps with the new Settings API and render buffering, so keep an eye out for screwed up settings or skipping video. Everything seems to be working, but you never know!

I saw the unstable 7 in your repo last night, but was on my phone, will attempt to compile today,

Never got this working but last try was much closer, got stuck on a few dependancie issues and wasn't able to find non-conflicitn versions of a few. Arch has since updated a few dependancies that might help and I just noticed this on the Arch User Reposotories;


I assume this is working and will confirm tongiht. Excited to finaly have this working.
Great, let me know. The branch you want to compile is retroplayer8, btw
I have retroplayer8 installed on Arch, via the pkgbuild. While xbmc seems to work fine, when opening a game the screen just goes black.
remove the logspam from the forum
(2013-08-24, 14:54)Martijn Wrote: [ -> ]remove the logspam from the forum

Done. But I'm curious, how do you diagnose an issue without looking at the log?
Logs are invaluable. Please use http://xbmclogs.com for your debug logs (sorry our moderator is more about discouraging bad behavior that encouraging good behavior)
Sorry for the long post and I hope this doesn't fall under logspam, this is the relevant error section of cpp;

CPP xbmc/cores/RetroPlayer/RetroPlayer.o
In file included from RetroPlayer.h:23:0,
from RetroPlayer.cpp:22:
RetroPlayerVideo.h:44:5: error: extra qualification ‘CRetroPlayerVideo::Frame::’ on member ‘Frame’ [-fpermissive]
Frame::Frame() : width(0), height(0), pitch(0), isRendered(false) { }
In file included from /tmp/yaourt-tmp-xbmc/aur-xbmc-retroplayer-git/src/xbmc-retroplayer/xbmc/utils/log.h:28:0,
from /tmp/yaourt-tmp-xbmc/aur-xbmc-retroplayer-git/src/xbmc-retroplayer/lib/DllAvUtil.h:28,
from /tmp/yaourt-tmp-xbmc/aur-xbmc-retroplayer-git/src/xbmc-retroplayer/lib/DllSwScale.h:27,
from RetroPlayerVideo.h:25,
from RetroPlayer.h:23,
from RetroPlayer.cpp:22:
/tmp/yaourt-tmp-xbmc/aur-xbmc-retroplayer-git/src/xbmc-retroplayer/xbmc/guilib/GraphicContext.h:251:29: warning: ‘g_graphicsContext’ defined but not used [-Wunused-variable]
/tmp/yaourt-tmp-xbmc/aur-xbmc-retroplayer-git/src/xbmc-retroplayer/xbmc/utils/GlobalsHandling.h:223:22: note: in definition of macro ‘XBMC_GLOBAL’
static classname & g_variable = (*(g_variable##Ref.get()))
make[1]: *** [RetroPlayer.o] Error 1
make: *** [xbmc/cores/RetroPlayer/retroplayer.a] Error 2

So close, but still no cigar.
Pages: 1 2