Kodi Community Forum

Full Version: Foxconn AMD E350: Suspend/Resume help!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So I've been running XBMCBuntu for the last two years with xbmc-xvba and suspend resume worked fine with Oneiric
Recently decided to upgrade - booted with the latest XBMCBuntu Live USB and tried everything. Suspend/resume and resume from USB keyboard worked flawlessly (tried multiple times with varying sleep time etc). So went ahead and installed it to my hard drive.

After I installed to the main HDD, now the resume is erratic at best. Crashed 4 times out of 5 and had to get out with ALT-SysRq-REISUB.

After rebooting, did not find anything in /var/log/pm-suspend.log.
In /var/crash/, there's a susres-* file that shows KernelOops

Can anyone help? What should I be trying out? Doesnt teh live ISO load the same drivers as when its installed?

There was only one significant difference - when testing with the Live CD, I did not have my media HDD (extennally powered HDD) plugged in. Anyway, I think I have eliminated this too as I removed the HDD, rebooted to XBMCBuntu from the HDD and still resume is flaky...

Using: XBMCBuntu AMD (Ubuntu 12.10)
Machine: Foxconn NTA3500 (AMD E-350 APU)
Try to upgrade the fglrx driver to 13.6 beta. As this is a beta release, save and copy your /etc/ati/signature to get rid of the watermark.
@fritsch - Thanks! - that seems to help - upgraded 13.6 beta and also installed 12.2 XBMC-XVBA from ppa. However, now I no longer have sound after resume.

I've tried a few suspend/resume cycles and till now it seems to work - barring that I have no sound after resume Sad

I'm still a bit puzzled how the live USB works without issues but the moment I install it onto the HDD all sorts of things crop up Sad
Does restarting xbmc after resume help?
I'm booting straight into XBMC with the XBMCBuntu session: restarting lightdm fixes the sound - sudo service lightdm restart
PS all a little hazy with the different permutations that i've tried till now Smile. I'm at work so will confirm after I get back in the evening.

Updates after I sat down to try things out again
Suspend/resume really random today... first sus/res cycle worked a few times. Second suspend almost always resulted in a lockup. Now tried again and even the first time hangs. Seems like a really bad lock up as even ALT-SysRq-REISUB doesnt get me out of it
On a positive note, removed pulseaudio - that fixed the low volume issue.

Ignore this - just saw that the recco is to remove pulseaudio - will try that first before asking.
Also,this is OT (but maybe not) once I updated to XVBA build and latest fglrx, sound volume and clarity seems to have gone down... I've tried the amp settings in audio OSD menu - but that just lacks clarity. Going into system settings , audio, output device is shown as Pulse Audio etc.

Earlier (on oneiric ) I used to have HDMI 2.0 and HDMI 2.0 Generic or some such...