Kodi Community Forum

Full Version: XBMC Video Server: stream/download your library contents
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2013-10-29, 11:57)ziggurat Wrote: [ -> ]When setting up reverse Proxy I get

Code:
[email protected]:~$ service apache2 restart
Syntax error on line 86 of /etc/apache2/sites-enabled/000-default:
Invalid command 'RequestHeader', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
   ...fail!

Without this line the Reverse Proxy forwards the web page, but jsonrpc commands are a no go Sad In effect the webinterface renders, but no buttons work, and an "Connection Error" is presented on the screen as well.


A note, I have not actually upgraded to XBMC 13 yet, though I wanted to have this PHP program ready for when I do, and as an added bonus I hoped to use your instructions to actually get reverse proxy for the XBMC web interface working. Reverse proxy for other stuff is working great, I have reverse proxy for HTPC Manager (from HTPC.io), CouchPotato, SabNZBd+, Sick Beard and Webmin working great.

What's line 86 of your config? Are you using Ubuntu 13.10?
@ziggurat: you probably need to run "sudo a2enmod headers proxy_http".
(2013-10-29, 17:31)negge Wrote: [ -> ]@ziggurat: you probably need to run "sudo a2enmod headers proxy_http".

Yes of course that solved it! I didn't catch that line. Thank you!

(2013-10-29, 16:29)cones Wrote: [ -> ]What's line 86 of your config? Are you using Ubuntu 13.10?

Which config file? And no I'm still on 13.04, this is strickly an XBMC + Usenet machine so no reason updating for a few unity features. But if it might help, Id just have to ghost the whole system first in case it does not survive a straight update.


Also, new problem JsonRPC is not forwarded through the reverse proxy.
Which means that the site is displayed but none of the functions work.
Was asking because it doesn't work directly on 13.10 without fixing some things first. Can't help on your new issue.
@ziggurat: could you describe your problem in more detail? What error message do you get?
(2013-10-30, 20:10)negge Wrote: [ -> ]@ziggurat: could you describe your problem in more detail? What error message do you get?

This works fine while using the port number instead of the reverse proxy, but while using the reverse proxy I get this:
Image

Which is because of this:
Image
Please post your virtualhost settings (where you've configured the proxy). Preferably as a pastebin link.
(2013-11-01, 10:37)negge Wrote: [ -> ]Please post your virtualhost settings (where you've configured the proxy). Preferably as a pastebin link.

You got to know first that I have tried both with and without the <Location /xbmc/jsonrpc> and get the same result.
And of course the Authorization "Basic " is censored to hide my own password.

Pastebin link
Remove <Location /xbmc/jsonrpc>, you don't need that.
(2013-11-01, 16:50)negge Wrote: [ -> ]Remove <Location /xbmc/jsonrpc>, you don't need that.

Still the same result
In that case I have no clue, unless you forgot to restart Apache? Do you still get "file not found" when browsing to /xbmc/jsonrpc?
Just pushed some changes:
  • Added ability to filter movies by actor name. Unlike filtering by movie name there is no auto-complete here since the XBMC API doesn't provide a way to retrieve a list of all actors.
  • Clicking an actor image on a movie details page shows all movies with that particular actor
  • Clicking the actor name takes you to the IMDb search page for that actor (since IMDb doesn't have an API it's not trivial to determine the actual profile page)
  • Updated installation instructions for Ubuntu 13.10 and newer
  • Improved documentation about the proxy location feature
Yes I restarted Apache Sad

Here is the proxy settings, if it helps to identify the problem http://pastebin.com/Xc77r1zz
@Ziggurat: I would start over with a clean default configuration, then configure the reverse proxy for this software and get it working. After that add back one proxy definition at a time to see where it breaks. Also remove settings you don't understand unless you realize that you need them for something specific.
Hi All!

Today I have installed successfully my xbmc video server.

First of all I want to thank all the developers working on it Smile

Second: sometimes it is needed to load the mod_rewrite in Apache in order to let xvs to work so it may be a good idea to note that in installation guide Smile (this was my case in Ubuntu, it's quite strange indeed that mod_rewrite was not loaded).

Now, it's time for my issue!

Status:
- A server machine running Gotham Alpha, Apache running XBMC Video Server.
- Server is running on Ubuntu 12.04 LTS Precise
- XBC has Web Server Activated and listening on port 8080 (I can control XBMC on port 8080 via browser)

When I try to access to my Movie / TV Shows library what I get is an Error 500 (this is what Chrome console says) and in the log I have this:
http://paste.ubuntu.com/6349903/

(sorry for not using pastebin but it's down right now O.o)

I tried to modify chmod to 777 just for test (and then back to 755) but nothing happened :\

Any idea?



Thank you all Smile