Kodi Community Forum

Full Version: XBMC Video Server: stream/download your library contents
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2014-01-10, 19:38)toffy Wrote: [ -> ]I now have owncloud, index and php working, but xbmc-video-server dont work on the same server.

Works now Smile

So does it work now or not? If not, try accessing /xbmc-video-server and post any errors you find in /var/log/apache2/error.log.
yes, it works now. I have to set <Directory /var/www/xbmc-video-server/> for apache 2.4. it didn't work with <Directory /var/www/>
Interesting, the options should be inherited. I'll see if I can replicate your problem.
Hi !! I will explain my problem :

-Web server installed at port 8080
- with localhost everything is OK
- with lan computer everything is OK
- xbmc and xbmc video server at same computer.
- DMZ for this computer
- windows firewall disabled
- windows 8.1

I have a dyndns for: mydomain.dydns.org

Backend config for internet:

HOST: mydomain.dyndns.org
PORT: 8080
USER: xbmc
PASS: xbmc
PROXY LOCATION: none


I can access from internet to xmbc video server -> mydomain.dyndns.org/xbmc-video-server , can log in and change backend or create new one, but :

- I canĀ“t view movies !! When i click on movies , this error appears :

Error 500
Unable to connect to mydomain.no-ip.org:8080 . Error #0: stream_socket_client(): (0)


Any help??

THANKS!!
Quote:mydomain.dyndns.org

Quote:mydomain.no-ip.org

What happens when you try to ping your dyndns from the computer itself? You'll likely need to add a line in your hosts file to point that address at localhost.
(2014-01-14, 08:21)negge Wrote: [ -> ]
Quote:mydomain.dyndns.org

Quote:mydomain.no-ip.org

What happens when you try to ping your dyndns from the computer itself? You'll likely need to add a line in your hosts file to point that address at localhost.

My dynamic dns is no-ip. NOT dyndns, was my fault writting here this, but in config is all OK with no-ip.

When I do ping with from my server mydomain.no-ip.org gives me the external IP

Advices??

Thanksss
I think I read your original post wrong. It actually sounds like you haven't forwarded port 8080 to your server. If you don't want to do that, check the README on how to configure and use a reverse proxy, that way you'll only need to forward port 80 in your firewall.
(2014-01-14, 23:46)negge Wrote: [ -> ]I think I read your original post wrong. It actually sounds like you haven't forwarded port 8080 to your server. If you don't want to do that, check the README on how to configure and use a reverse proxy, that way you'll only need to forward port 80 in your firewall.

-Server has a DMZ (all ports open)

From internet if I try mydomain.no-ip.org:8080/xbmc-video-server , ask me for user/password . If I introduce xbmc/xbmc ( pass from the xbmc server ) , it shows a blank page "File not found".

if I try mydomain.no-ip.org/xbmc-video-server , i can log in xbmc-video-server with admin/admin, but the other problem happens.


My solution (not really a solution) was, change to local backend which allow me to go to movies and download de m3u file. Edit that file and put mi ip manually.

Thanks!!
mydomain.no-ip.org:8080 should be XBMCs web interface, so don't add anything after the port here. But at least the port seems to be open. Can you log in successfully with the API credentials?

Could you also please post the URL to a movie? I'm having a hard time figure out where the fault in your configuration is.
(2014-01-17, 08:18)negge Wrote: [ -> ]mydomain.no-ip.org:8080 should be XBMCs web interface, so don't add anything after the port here. But at least the port seems to be open. Can you log in successfully with the API credentials?

Could you also please post the URL to a movie? I'm having a hard time figure out where the fault in your configuration is.

I will do a summary:

http://mydomain.no-ip.org:8080/ -> Access to xbmc (only acess with xbmc/xbmc)
http://mydomain.no-ip.org:8080/xbmc-video-server/ -> Access to xbmc (only acess with xbmc/xbmc)
http://mydomain.no-ip.org/xbmc-video-server/ -> Access to xbmc video server (only acess admin/admin)
http://mydomain.no-ip.org -> Xampp error (access denied)

When Im logged in your API , default "localhost" is active with this setting when Im on the Movies:

- Watch icon -> http://mydomain.no-ip.org/xbmc-video-ser...movieId=85
- Download icon -> http://xbmc:[email protected]:8080/vfs/movietitlehere.mkv

I need change Backend profile to "Internet". When I do, if I go to Movies i get this error:

-Changed backend to Internet
-Error 500
-Unable to connect to miip:8080 . Error #0: stream_socket_client(): (0)


Profiles:

Default: Hostname localhost,port 8080, xbmc:xbmc
Internet: Hostname miip (or mydomain.no-ip.org),port 8080, xbmc:xbmc


Thank you so much for your help!!!
Try adding the following to the hosts file on the machine where you have installed XBMC Video Server

Quote:192.168.1.x mydomain.no-ip.org

Where 192.168.1.x is the internal address of the machine using XBMC. If it's the same machine you can use 127.0.0.1 as address.
(2014-01-17, 21:26)negge Wrote: [ -> ]Try adding the following to the hosts file on the machine where you have installed XBMC Video Server

Quote:192.168.1.x mydomain.no-ip.org

Where 192.168.1.x is the internal address of the machine using XBMC. If it's the same machine you can use 127.0.0.1 as address.

Same error...

This is crazy!!

Thanks!!
My Apache server won't run Sad

Quote: Restarting web server: apache2apache2: Could not reliably determine the server's fully qualified domain name, using ::1 for ServerName
apache2: Could not reliably determine the server's fully qualified domain name, using ::1 for ServerName
(98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
Action 'start' failed.
The Apache error log may have more information.

I want to run the Xbmc Video Server on my Raspberry Pi with Raspbmc (Gotham).
I also have the Music Player Deamon (MPD) running on this Pi.

Does the XBMC and MPD corrupt the Ports?
(2014-01-21, 16:25)Bambutscha Wrote: [ -> ]My Apache server won't run Sad

Quote: Restarting web server: apache2apache2: Could not reliably determine the server's fully qualified domain name, using ::1 for ServerName
apache2: Could not reliably determine the server's fully qualified domain name, using ::1 for ServerName
(98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
Action 'start' failed.
The Apache error log may have more information.

I want to run the Xbmc Video Server on my Raspberry Pi with Raspbmc (Gotham).
I also have the Music Player Deamon (MPD) running on this Pi.

Does the XBMC and MPD corrupt the Ports?

I think that error is just saying something else is running on port 80. XBMCs webserver likes to default to that port, i would check that first.
I changed the Port in XBMC.
XBMC Video Server now runs, but i have a new error.

If i go to Movies:

Error 500
Not Found (404)

displayed on the Screen.
Quote:exception 'CHttpException' with message 'Not Found (404)' in /var/www/xbmc-video-server/src/protected/components/XBMC.php:101
Stack trace:
#0 /var/www/xbmc-video-server/src/protected/components/XBMC.php(70): XBMC->performRequestInternal('VideoLibrary.Ge...', Array, 0)
#1 /var/www/xbmc-video-server/src/protected/models/VideoLibrary.php(90): XBMC->performRequest('VideoLibrary.Ge...', Array)
#2 /var/www/xbmc-video-server/src/protected/controllers/TvShowController.php(48): VideoLibrary::getTVShows(Array)
#3 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/web/actions/CInlineAction.php(49): TvShowController->actionIndex()
#4 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/web/CController.php(308): CInlineAction->runWithParams(Array)
#5 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/web/filters/CFilterChain.php(133): CController->runAction(Object(CInlineAction))
#6 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/web/filters/CFilter.php(40): CFilterChain->run()
#7 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/web/CController.php(1145): CFilter->filter(Object(CFilterChain))
#8 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/web/filters/CInlineFilter.php(58): CController->filterAccessControl(Object(CFilterChain))
#9 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/web/filters/CFilterChain.php(130): CInlineFilter->filter(Object(CFilterChain))
#10 /var/www/xbmc-video-server/src/protected/components/Controller.php(73): CFilterChain->run()
#11 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/web/filters/CInlineFilter.php(58): Controller->filterCheckConfiguration(Object(CFilterChain))
#12 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/web/filters/CFilterChain.php(130): CInlineFilter->filter(Object(CFilterChain))
#13 /var/www/xbmc-video-server/src/protected/components/Controller.php(56): CFilterChain->run()
#14 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/web/filters/CInlineFilter.php(58): Controller->filterRequireLogin(Object(CFilterChain))
#15 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/web/filters/CFilterChain.php(130): CInlineFilter->filter(Object(CFilterChain))
#16 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/web/CController.php(291): CFilterChain->run()
#17 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/web/CController.php(265): CController->runActionWithFilters(Object(CInlineAction), Array)
#18 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/web/CWebApplication.php(282): CController->run('index')
#19 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/web/CWebApplication.php(141): CWebApplication->runController('tvShow/index')
#20 /var/www/xbmc-video-server/vendor/yiisoft/yii/framework/base/CApplication.php(180): CWebApplication->processRequest()
#21 /var/www/xbmc-video-server/src/index.php(17): CApplication->run()
#22 {main}
REQUEST_URI=/xbmc-video-server/src/tvShow/index
-----
Also Yatse won't connect with XBMC on the new Port. Although it display's 404 if i use the old Port (80)

Can i chang the Ports of the XBMC Video Server?